• Boot into a black screen after update

    This is my first post here. I’m a Linux user for some years, but not too much into the depth of the OS. I’m using Antergos now for nearly a year as guest in virtualbox and I really love it. Some time ago I did the last update and since then I only get a black screen after boot.

    I tried really a lot of things mentioned here in the forum, but couldn’t solve the problem on my own. Therefore I ask for help here.

    I can switch to tty by Ctrl+Alt+F*. With Ctrl+Alt+F1 I get the following screen:

    starting version 235 
    AntergosRoot: recovering journal
    AntergosRoot: Clearing orphaned inode 1831449 (uid=1000, gid=100, mode=0100644,
    AntergosRoot: clean, 548237/2354688 files, 5063613/9406720 blocks [FAILED] Failed to start Avahi mDNS/DNS-SD Stack.
    See 'systemctl status avahi-daemon.service' for details.
             Starting Authorization Manager...
    [  OK  ] Started Authorization Manager.
    [  OK  ] Started Modem Manager.
    [  OK  ] Started Network Manager.
    [  OK  ] Reached target Network.
             Starting Permit User Sessions...
    [  OK  ] Started Permit User Sessions.
    [  OK  ] Reached target Multi-User System.
             Starting Light Display Manager...
    [  OK  ] Reached target User and Group Name Lookups.
             Starting Accounts Service...
    [  OK  ] Reached target Sound Card.
             Starting Network Manager Script Dispatcher Service...
    [  OK  ] Started Accounts Service.
    [  OK  ] Started Light Display Manager.
    [  OK  ] Reached target Graphical Interface.
    [  OK  ] Started Network Manager Script Dispatcher Service.

    I did not find anything helpful for me in the journal, Xorg.0.log, lightdm.log, x-0.log, but some of you knowledgeable people hopefully see more.

    I can’t post the log files here, because the post would be too long and I haven’t the previleg to upload files. I’d happy to send them, if I knew how.

    To mention, what I already did:

    1. I found an error in Xorg.0.log concerning the vboxvideo module. (EE) Failed to load module "vboxvideo" (module does not exist, 0). But the module exist and modprobe -a vboxvideo doesn’t give an error-message. I also found that this ‘missing module’ is not responsible for the black screen since I found the same error message in Xorg.0.log when I start a live iso of Antergos in the same virtual machine, which works perfectly.

    2. I tried to start the X server from command line but it seems to start and terminate immediately after start. The log file also shows, that it terminates successfully. Just to see what happens I installed xterm and twm which are called by the xinit script. With both installed the X server doesn’t terminate and I get twm with xterm. But still I can’t open a gnome-session even when I put exec gnome-session as last command in xinitrc.

    3. I changed from lightdm to gdm as mentioned in lightdm not loading and rebooted.

    Result after reboot: black screen. In journalctl I found: “gnome-shell Failed to create backend: Unable to open display, Display not”

    1. I tried (as recommended in https://bbs.archlinux.org/viewtopic.php?id=7329)
    startx /usr/bin/gnome-session 

    Result after reboot: Black screen, X server terminated successfully, but in /var/log/Xorg.1.log I got the following errors:

    # grep '(EE)' /var/log/Xorg.1.log
    (WW) warning, (EE) error, (NI) not inplemented, (??) unknoun.
    642.524] (EE) Failed to load module "vboxvideo" (module does not exist, 0)
    642.610]	 (EE) modeset(0): eglGetDisplay() failed
    642.611]	 (EE) modeset(0): glamor initialization failed 
    642.615] (EE) AIGLX: reverting to Software rendering
    1. Downgrade to webkit2gtk- as mentioned in https://forum.antergos.com/topic/5180/login-issue-with-lightdm-webkit-greeter-not-accepting-user-input/2

    Result after reboot: Black screen. In journalctl there was an entry ‘lightdm no password for autlogin’, which I was wondering about.

    1. Because of the ‘lightdm no password for autlogin’ I thought there might be an issue with permissions and applied the recommendation of https://forum.antergos.com/topic/6872/black-screen-and-mouse-pointer-after-login/8 which didn’t change anything.

    Since I tried now for more than a day to fix this problem, I hope some of you can help or point me in the right direction.


  • @robma
    There are lots of places where you can post your log files. For example, pastebin.com.

  • If this is the same bug that has effected all of us, another update has been released fixing this.

  • @izznogooood well, the latest pacman -Syyuu command 5 minutes ago didn’t solve the problem, unfortunately.

  • @joekamprad thank you for this hint, I will send the logs tomorrow

  • ok, here are my log files:

    journalctl -b -0 -> Journal

    Interesting for me is the gnome-session part

    gnome-session[802]: X Error of failed request:  BadValue (integer parameter out of range for operation)
    gnome-session[802]:   Major opcode of failed request:  154 (GLX)
    gnome-session[802]:   Minor opcode of failed request:  3 (X_GLXCreateContext)
    gnome-session[802]:   Value in failed request:  0x0
    gnome-session[802]:   Serial number of failed request:  19
    gnome-session[802]:   Current serial number in output stream:  20
    gnome-session[802]: gnome-session-check-accelerated: GL Helper exited with code 256
    gnome-session[802]: modprobe: FATAL: Module nvidia not found in directory /lib/modules/4.13.9-1-ARCH
    gnome-session-c[3946]: eglGetDisplay() failed
    gnome-session[802]: gnome-session-check-accelerated: GLES Helper exited with code 256

    I’m wondering, if there is any hint why the session does not survive and why it is fatal that the nvidia module is not found. I run Antergos in a virtualbox, which does not simulate nivida graphics as far as I know.


    Is there any other log which might be helpful?

  • I couldn’t solve this problem, but I was able to get a login screen. This didn’t let me start gnome either. So I installed xfce, which works fine since then. Perhaps one day I’ll get gnome running again. Meanwhile I spent a lot of time to get my antergos running with a GUI, so I won’t go for this problem for quiet a while.

  • Question is why something is invoke modprobe nvidia, may VM is using somehow using nvidia graphics directly, this is possible with the pass-through.

  • Thank you for the reply. I’m not aware that the VM is using the nvidia graphics directly. I don’t know how to check if pass-through is used or not. Since it worked before the antergos update and the virtualbox hasn’t changed since then, it should have to do with some settings for gnome. Do you have any further hint?

  • Ok, I got it solved. As Joe pointed out it had something to do with nvidia. Although the system runs in a virtual machine not using nivdia drivers, some nvidia files were installed: nvidia-340xx-utils and lib32-nvidia-340xx-utils. When I uninstalled them I got a warning, that wine and some other files will be uninstalled too, which made me wonder. But that was ok for me. After uninstalling I could login into gnome again. Yeah!

    When I reinstalled wine I was asked for some graphics options, which also had a nvidia option. This I didn’t remember. So may be the same day I updated my system I installed wine too and for whatever reason I seemingly did something strange: selecting the nvidia option, which prevented gnome from start.

    Now when I reinstalled wine I got a circular dependency between lib32-mesa and lib32-libglvnd. So I first installed only lib32-libglvnd with pacman -Sdd lib32-glvnd and afterwards pacman -S wine.

  • @robma
    Good to hear it is solved! :)

    Funny that installing wine inside virtualbox shows nvidia-340xx-utils etc. as optional dependencies. Though I don’t know how hard it would be to remove them in virtualbox case.

    Installing those circular dependencies together should not cause problems.

boot299 black75 Posts 12Views 2676
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.