• NVIDIA Powermizer not working?


    Hi…

    I have noticed that PowerMizer is not working anymore and it seems that the card is constantly working at performance level , I have tried a lot of things but no success , NVIDIA stacked at maximum performance.

    1.I have re installed Nvidia drivers , kernels etc

    1. Disable compositor in Plasma
    2. I have removed all widgets
    3. Install dkms,kernel and drivers

    Well I run out of ideas so am just wondering if the same thing is happening to you as well or is just my pc. :o?

    0_1509450706705_nvidiapanel.png

  • @kyrisk I have fixit by generating a new xorg

    nvidia-xconfig

    and adding

    Option “RegistryDwords” “PowerMizerEnable=0x1; PowerMizerDefaultAC=0x3;”

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    Option “Coolbits” "12"
    Option “RegistryDwords” "PowerMizerEnable=0x1; PowerMizerDefaultAC=0x3;"
    EndSection

  • it seems powermizer is completely broken and auto is not working.

    with the above solution it stays to adaptive so you cant play any games

  • @kyrisk said in NVIDIA Powermizer not working?:

    nvidia-xconfig

    is not working properly… you can still use it but only for creating a template:

    nvidia-xconfig  -o nvidia-xorgfile
    

    It is better to use nvidia-settings and load the rc-file automaticly on login.

    nvidia-settings --config ~/.nvidia-settings-rc --load-config-only 
    

    to get a starter for gnome:

    nano ~/.nvidia-settings-reload.sh
    

    with this inside:

    #!/bin/sh
    nvidia-settings --config ~/.nvidia-settings-rc --load-config-only &
    

    make it executable by:

    chmod +x ~/.nvidia-settings-reload.sh
    

    create autostarter:
    nano ~/.config/autostart/nvidia-settings-rc.desktop

    with this inside:

    [Desktop Entry]
    Type=Script
    Name=nvidia-settings-rc
    Comment=autoload nvidia-settings
    Exec=sh ~/.nvidia-settings-reload.sh
    
    chmod +x ~/.config/autostart/nvidia-settings-rc.desktop
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • My problem is powermizer that does not AUTO switching level profiles, If you have nvidia you will understand
    Powermizer always uses max perfomance and I dont want that because is using my GPU 100% even when my PC is idle…
    Even the fans of the GPU are working to the MAX and is very noisy and besides that it consume a lot of power.

  • manually:

    nvidia-settings -a '[gpu:0]/GPUPowerMizerMode=0'
    

    where 0=adaptive 1=maximum performance and 2=automatic

    inside xorg.conf or better 20-nvidia.conf

    in the “Device” section for your graphics cared, add:

    # adaptive strategy for any power source
    Option		"RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2233; PowerMizerDefault=0x3"
    
    # batt=max power saving, AC=max power saving
     Option		"RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x3333"
    
    # batt=adaptive strategy, AC=max performance
    Option		"RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x3322; PowerMizerDefaultAC=0x1"
    
    # batt=max power saving, AC=max performance
    Option		"RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x3; PowerMizerDefaultAC=0x1"
    
    # batt=max power saving, AC=adaptive strategy (my favorite)
    Option		"RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x3; PowerMizerDefaultAC=0x3"
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad said in NVIDIA Powermizer not working?:

    nvidia-settings -a ‘[gpu:0]/GPUPowerMizerMode=0’

    where 0=adaptive 1=maximum performance and 2=automatic

    Nothing of these are working on the fly so is another indication that powermizer is broken

    inside xorg.conf or better 20-nvidia.conf
    in the “Device” section for your graphics cared, add:

    adaptive strategy for any power source

    Option “RegistryDwords” “PowerMizerEnable=0x1; PerfLevelSrc=0x2233; PowerMizerDefault=0x3”

    batt=max power saving, AC=max power saving

    Option “RegistryDwords” “PowerMizerEnable=0x1; PerfLevelSrc=0x3333”

    batt=adaptive strategy, AC=max performance

    Option “RegistryDwords” “PowerMizerEnable=0x1; PerfLevelSrc=0x3322; PowerMizerDefaultAC=0x1”

    batt=max power saving, AC=max performance

    Option “RegistryDwords” “PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x3; PowerMizerDefaultAC=0x1”

    batt=max power saving, AC=adaptive strategy (my favorite)

    Option “RegistryDwords” “PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x3; PowerMizerDefaultAC=0x3”

    Does these settings will make powermizer to AUTOMATIC jump power levels according to what application or game I Am gonna run because as I see it , it will only adapt one strategy

  • @kyrisk said in NVIDIA Powermizer not working?:

    nvidia-settings -a ‘[gpu:0]/GPUPowerMizerMode=0’

    is not working too?

    because it is working here… but poermizer is not set the level as you already say, it put the level on needed performance…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad ok I found out that PowerMizer is not working with Multiple Monitors.

    I am using 3x Monitors and is not working but if I disable the 2 monitors is working fine

    I have searched a bit and it seems that is a well known bug

  • further more I have discovered that having all 3 monitors at resolution 1920x1080 Powermizer is working fine.
    BUT!
    If I have one monitor at resolution 2560x1440 and the other 2 at resolution 1920x1080 powemizer is NOT Working

    I have tried setting up 2x Monitor at 3840x2160 and is working fine but if I connect a third monitor at 1920x1080 Powermizer is not working it has to go full performance.

    I have tried also 2x monitors 2560x1440 with 1920x1080 … 2560x1440 with 3840x2160 and powermizer is working

    But with 3 monitors different resolution is not working :(

powermizer1 nvidia111 Posts 10Views 174
Log in to reply