• can't boot into Gnome-Shell after failed suspend


    I installed Antergos on my desktop yesterday (this is my third arch installation… this time I decided to use Antergos because I was in a bit of a hurry yesterday). I installed and booted up no problem, I used the system all day yesterday, no problems. When I went to bed for the night I put it to sleep (suspend). When I came back this morning I tried waking the machine but it would never return from suspend, so eventually I just did a hard boot. However, when it got past GRUB it was alternating between a black screen with only a mouse cursor and the blinking underscore on the top left. It continued to alternate between these two for the 20 minutes I waited. I don’t believe I rebooted yesterday so I don’t know if its related to the suspend or not or just a coincidence. I was able to get to another terminal with CTRL ALT F2, where I checked journalctl and dmesg. I’m getting a “nouveau DRM ponter to flat panel table invalid.” “secboot: error during falcon reset: -110” and “gr init failed, -110” I searched the web for this error and tried the various fixes I found online but none seem to do the trick. However, I noticed that it also had that the first error message also occurred yesterday when gnome was working fine, but the second two didn’t happen until today. It looks like gnome is running when I do a grep on “ps -ef” but it won’t let me actually control it or use it. What’s also weird is I am able to do a startx and gnome-shell on my second virtual terminal and it allows me to get into gnome-shell (with some configurations missing). I tried reinstalling the nouveau package, as well as the kernel, as well as mkinitcpio. Any suggestions?

  • Figured out a solution… installed linux headers package, then reinstalled nvidia-dkms package. Apparently n-dkms doesn’t work without linux headers. I’m not really sure how it ever worked in the first place, but whatever, it works now!

suspend33 gnome-shell12 boot175 Posts 2Views 74
Log in to reply