• can't boot into antergos after update, kernel panic (-13)


    Hi there,
    i tried to update my system and something gone horribly wrong…

    After a reboot, and behind the grub selection menu, there is nothing but a kernel warning - not syncing error (failed to execute /init - error -13) and so on…

    This is my pacman log:
    https://pastebin.com/8Qi8LEj7

    Can somebody please tell me how i can fix that? 😕

    Thank you in advance!

  • A half of the log is occupied by the error about missing space on a device:

    ...No space left on device
    

    I’d try to make more space available on a device, where initramfs is being built.

  • Seems that /tmp (probably in ramdisk) was out of space when updating.
    Might help commenting out tmpfs line in /etc/fstab, if the line exists.

    Send logs: https://forum.antergos.com/topic/10586/eat-logs; install eat: wget -q https://github.com/manuel-192/eat/raw/master/PKGBUILD && makepkg -sic
    Please don't hide information when asking for help.

  • i fixed it with chroot (as described here: https://www.soimort.org/notes/170407/)

    i understand that my system was running out of space, but i do not understand why!

    df

    Dateisystem    1K-Blöcke   Benutzt Verfügbar Verw% Eingehängt auf
    dev              1931600         0   1931600    0% /dev
    run              1937040      1396   1935644    1% /run
    /dev/sda7       75457692  35226468  39446932   48% /
    tmpfs            1937040     18600   1918440    1% /dev/shm
    tmpfs            1937040         0   1937040    0% /sys/fs/cgroup
    /dev/sda2         303104     49764    253340   17% /boot/efi
    tmpfs            1937040     33136   1903904    2% /tmp
    /dev/sda4      402475004 204778700 197696304   51% /home/flood/windrive
    tmpfs             387408        44    387364    1% /run/user/1000
    

    fdisk

    UUID=65fcb4da-7355-43c8-8b8c-a9a76f3aaeef / ext4 defaults,noatime,discard 0 1
    UUID=43b358b5-aea3-466b-b099-8ea9fb9cdf4a swap swap defaults 0 0
    UUID=EA31-9381 /boot/efi vfat defaults,noatime 0 0
    UUID=124C32DD4C32BAF5 /home/flood/windrive ntfs-3g
    

    i guess i have to increase the size of one of the partitions - but… can you kindly tell me which one? thank you!

    flo

  • @catchkantifyoucan

    So it is fixed now?
    The first error in your log was when writing into /tmp. The /tmp may have been quite full just before you tried to update.

    Could you still show the output of:

    lsblk -o NAME,FSTYPE,SIZE,LABEL,UUID,MOUNTPOINT
    

    Send logs: https://forum.antergos.com/topic/10586/eat-logs; install eat: wget -q https://github.com/manuel-192/eat/raw/master/PKGBUILD && makepkg -sic
    Please don't hide information when asking for help.

  • /tmp is handeld by tmpüfs and using RAM for carry /tmp files, so if you do not have enaugh RAM it can run full:
    Under systemd, /tmp is automatically mounted as a tmpfs even though no entry is specified in /etc/fstab.

    You can disable automounting it and use hd space instead.

    https://wiki.archlinux.org/index.php/Tmpfs#Disable_automatic_mount

    [updates once a week] = [90% less problems]
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    help development: donate antergos

  • yes sorry, it is solved - how do i mark it as “solved”? 🙂

  • 0_1511276630421_solved.png

    Solved ?

  • thank you, i searched at the first post, not at the bottom of the page.

  • @catchkantifyoucan said in can't boot into antergos after update, kernel panic (-13):

    thank you, i searched at the first post, not at the bottom of the page.

    You’re welcome 🙂

boot256 kernel119 panic7 Posts 10Views 1150
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.