• New Gnome install in VirtualBox extremely slow

    just tried to make a fresh install of Antergos Gnome into VirtualBox VM. Selected all default options, nothing special.
    But the freshly installed Gnome was unusable because it was extremely slow. Tried it a couple of times, same result.

    Then tried similar install to VM, only Xfce. It worked well, as usual.

    Used Antergos ISO 17.10.

    Any thoughts?

  • I had this issue too. I found out that VirtualBox had turned the execution cap down to nothing which made it slower than ever. Make sure that the execution cap is at 100%. Also, give your VM as much ram as you can staying in the green zone. I have a cpu with 4 threads so I can set the CPU to 2. Make sure that that you give your machine some video ram as well. If this doesn’t work thwn I don’t know what will! I hope this helped! ;)

  • @CadenMitchell
    Thanks for your answer!
    As a matter of fact, it sorted itself, :), I didn’t change anything, just installed again.
    Probably some update somewhere initially caused it and now fixed it.
    I’ve installed Gnome version to VM many times before, and only this time it was slow.

    EDIT: just realized that during this new working install I let cnchi manage mirrors, that might have made the difference.

  • Well, it is not sorted. :(

    It seems to depend on the selection of things in cnchi. I’ve tried some things in cnchi installation, and naturally it is very time consuming work to do.
    So far I haven’t been able to pinpoint the reason for slowness.
    But with “some” set of selections in cnchi the Gnome installation is not slow, and with some other set of selections it is very very slow.

    And I noticed another thing when it is slow: if the focus is moved outside of the VM window, then the actions inside the VM will instantly be executed.
    For example, when I click terminal icon inside VM window to start a terminal, it will not start. But when I click outside the VM window, the terminal starts immediately.

  • It also is a matter of virtualisation mode: use KVM if aviable
    And on Display setting use 3d is also boosting

  • Did several Gnome installs to VM. It seems that the problem has something to do with partitioning.

    If I select default automatic partitioning, Gnome works in most of the installs, although not always.
    If I select manual partitioning, then it most often is slow, but not always.

    No other selection than partitioning seem to have effect on the speed of the resulting install.

    And this slowness happens only with Gnome installations, not Xfce installations.

    I’ve been using VirtualBox already many years, and this is the first time this kind of problem occurred.
    And I put 8GB RAM to the VM, so that cannot be the issue. 3D boosting doesn’t seem to have any effect on the slowness.

  • Some more information and summary concerning this VM problem:

    • KDE installs and works OK.
    • MATE installs and works OK.
    • Xfce installs and works OK.
    • Gnome installs without issues, but using it after install is often very slow, as described above.
  • Do @developers have any idea about this?
    The problem still exists. Antergos GNOME in Virtualbox cannot be used.

  • OK, found a workaround, installing packages virtualbox-guest-dkms and linux-headers. But wait, it is not the end of story just yet!

    I got curious about why this problem started in the first place, and tried other DEs again. Xfce seems to work almost OK, but now it does not respond to e.g. window resize as before.

    A solution to that was to install virtualbox-guest-iso in my host, and use that for installing guest additions inside the guest.

    Reason: Oracle has found some problems in VirtualBox Linux guest systems with 5.2.0, and has provided a new guest iso version 5.2.1, and fortunately Antergos already has that package.

    So, for now at least, do not install virtualbox-guest-* inside the guest VM. Use the host iso instead.

gnome361 virtualbox47 slow37 extremely2 Posts 9Views 3268
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.