• MonoDevelop, cannot use Mono command to run .exe files


    Hello all,

    So I’ve only recently installed Antergos and am fairly new to it. I set up my stuff and downloaded the Mono packages and MonoDevelop so I can do my Uni work, and it all worked fine until I compiled my .cs and tried to run it.

    I looked online and saw that it said I should try doing sudo modprobe binfmt to initialize the module and then modify the startup so that it’s always run, that way mono would be able to run .exe files, however when I tried to do that I got this:
    modprobe: FATAL: Module binfmt not found in directory /lib/modules/4.13.8-1-ARCH

    I tried looking it up, trying to find how to install binfmt or why I’m missing it, but I’ve come up with nothing.

    Any help is appreciated.

    Thanks in advance,

    ParadAUX

  • do youn try to search for a package or AURBUILD first to get a better implementation into the system and possibility for easy updates?

    In AUR we get this candidates:

    monodevelop
    monodevelop-stable
    monodevelop-git

    pacaur -S monodevelop*
    

    or

    yaourt -S monodevelop*
    

    |* = -git / -stable /

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Quite honestly I didn’t, I opened the package manager and installed the MonoDevelop and it’s dependencies that showed up, I didn’t do it through the command line. I did use the mono dependencies and MonoDevelop itself. I honestly have no idea what I did wrong in terms of installation :/

  • @ParadAUX said in MonoDevelop, cannot use Mono command to run .exe files:

    downloaded the Mono packages and MonoDevelop

    this sounded like you download the “packages” and install manually…

    So what do you install exactly?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • I used the GUI package installer that comes with Antergos to download and install the stuff. I have:

    • mono
    • mono-addins
    • mono-basic
    • mono-debugger

    As the base libs, and I have the MonoDevelop Linux version downloaded from their website.

  • @ParadAUX

    It might be better to install related packages using the Antergos package manager instead of downloading files from their website. Otherwise some dependencies may be missing.

    To do so, you need to enable AUR support in the package manager. Or do the commands what Joe presented before on this thread.

monodevelop2 exe2 mono1 Posts 6Views 112
Log in to reply