• \[UPDATE ADVISORY\] \*\*libxcursor bug\*\* Updated: 6/12/14


    UPDATE:[/color:1pud533s][/size:1pud533s]
    The following command will correct the problem and allow you to update libxcursor:

    sudo unlink /usr/share/icons/default
    

    Cheers!

    If you have not updated yet:[/size:1pud533s]
    [list:1pud533s]Keep using the version you have (1.1.14-1) by adding libxcursor to the IGNORE list in /etc/pacman.conf[/list:u:1pud533s]
    [size]If you have updated and are experiencing issues running applications:[/size:1pud533s]
    [list:1pud533s]Downgrade to the previous version with these commands:

    yaourt -S downgrade --noconfirm
    >downgrade libxcursor
    

    You should select v1.1.14-1 when prompted.[/list:u:1pud533s]

    For more information: [https://bugs.archlinux.org/task/40658][0]
    Cheers!
    : https://bugs.archlinux.org/task/40658

  • UPDATE:[/color:1pud533s][/size:1pud533s]
    The following command will correct the problem and allow you to update libxcursor:

    sudo unlink /usr/share/icons/default
    

    Cheers!

    If you have not updated yet:[/size:1pud533s]
    [list:1pud533s]Keep using the version you have (1.1.14-1) by adding libxcursor to the IGNORE list in /etc/pacman.conf[/list:u:1pud533s]
    [size]If you have updated and are experiencing issues running applications:[/size:1pud533s]
    [list:1pud533s]Downgrade to the previous version with these commands:

    yaourt -S downgrade --noconfirm
    >downgrade libxcursor
    

    You should select v1.1.14-1 when prompted.[/list:u:1pud533s]

    For more information: [https://bugs.archlinux.org/task/40658][0]
    Cheers!
    : https://bugs.archlinux.org/task/40658

  • thank yo so much …

  • Thanks

  • how can we find out when this is fixed?

  • So far I do not have any issue with libxcursor even I just update my system few minutes ago…

      
    [email protected]:~   
    ➤ sudo pacman -Q libxcursor  
    libxcursor 1.1.14-2  
    
    
  • Oh Thanks!
    I have failures with Libreoffice, Virtualbox, Firefox customization

  • @“maxpro4u”:1hla6abk said:

    how can we find out when this is fixed?[/quote:1hla6abk]Follow the bug report over on arch’s tracker. I will try to keep an eye on it though there’s a very good chance I won’t catch it right away

  • thanks a lot for this.

  • Jan de Groot has written in the bug tracker talking about this bug. This seems to be a user error, not something about the package. The problem is that all of us with this problem have symlinked “/usr/share/icons/Adwaita” to “/usr/share/icons/default”. The new libxcursor place a index.theme file in “/usr/share/icons/default”, which in this case is adawita folder, referencing itself.

    To solve the problem first you need to unlink that folder with “unlink /usr/share/icons/default”. Then you can install the new libxcursor and everything will be fine.

  • WOW…

  • so what exactly is the solution? #unlink /usr/share/icons/default

  • @“Azrael^^”:3grqjgsz said:

    To solve the problem first you need to unlink that folder with “unlink /usr/share/icons/default”. Then you can install the new libxcursor and everything will be fine.[/quote:3grqjgsz] I’m still at work so I havent tested the fix but it makes sense so I don’t doubt it

    Best Regards,
    Dustin

  • May not be a package fault, but I don’t think it’s a users fault neither. I installed Antergos a bit more than a week ago and I’m absolutely certain I did not consciously do the symlink. Must come from another some other package …

  • I’m 91% sure its of our doing

    Best Regards,
    Dustin

  • No worries lots.oflogs , I ignore the package on the 2 systems I have running Antergos. I look forward for the announcement.

    Thanks and keep up the great work.

  • Thanks for the info!

    downgrading did the trick

  • @“lots.0.logs”:2ab25sk3 said:

    I’m 91% sure its of our doing
    It’s a good thing you are only 91% sure. Had you been 92% sure, I would likely have hauled off and given you a really stern look.

  • Cheers!

  • Hi yesterday read about removing the icon folder but with unlinking works, confirmed and running

Posts 51Views 16186
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.