• ACPI Bios Error


    I get the following error whenever I start up Antergos. After GRUB, I get

    [ 0.490561] ACPI BIOS Error (bug): _SB.PCIO._OSC: Excess arguments - ASL Declared 5, ACPI requires 4 (20170531/nsarguments-189)

    The system then boots up as normal.

    ![0_1509085491843_IMG_20171027_084936-min.jpg](Uploading 100%)
    I run a Compaq Presario A900 and everything is updated as of date of post.

    Thanks

  • @mathssite1 mostly if system boots fine and also is stable on usage and loads, you can ignore most acpi warnings, as they are only for debugging…

    But if you mind, give some specs to get into it:

    sudo pacman -S inxi
    inxi -v3
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad said in ACPI Bios Error:

    sudo pacman -S inxi

    System:    Host: Compaq Kernel: 4.13.8-1-ARCH x86_64 bits: 64 gcc: 7.2.0
               Desktop: Xfce 4.12.4 (Gtk 2.24.31) Distro: Antergos Linux
    Machine:   Device: laptop System: Hewlett-Packard product: Compaq Presario A900 Notebook PC v: F.31 serial: N/A
               Mobo: Hewlett-Packard model: 30ED v: 83.21 serial: N/A
               BIOS: Hewlett-Packard v: F.31 date: 02/29/2008
    Battery    BAT0: charge: 4.8 Wh 101.0% condition: 4.8/4.8 Wh (100%)
               model: Hewlett-Packard Primary status: Full
    CPU:       Dual core Intel Pentium Dual T2370 (-MCP-) 
               arch: Conroe rev.13 cache: 1024 KB
               flags: (lm nx sse sse2 sse3 ssse3) bmips: 6919
               clock speeds: max: 1733 MHz 1: 1728 MHz 2: 1728 MHz
    Graphics:  Card: Intel Mobile GM965/GL960 Integrated Graphics Controller (primary)
               bus-ID: 00:02.0
               Display Server: N/A
               drivers: intel (unloaded: modesetting,fbdev,vesa)
               tty size: 80x24
    Network:   Card-1: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter (PCI-Express)
               driver: ath5k bus-ID: 01:00.0
               IF: wlp1s0 state: up mac: 00:1f:3a:70:1b:8a
               Card-2: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
               driver: 8139too port: 1000 bus-ID: 02:01.0
               IF: enp2s1 state: down mac: 00:1b:38:f9:94:6c
    Drives:    HDD Total Size: 80.0GB (28.5% used)
               ID-1: model: Hitachi_HTS54168
    Info:      Processes: 132 Uptime: 3 days Memory: 1326.0/1995.0MB
               Init: systemd Gcc sys: 7.2.0
               Client: Shell (bash 4.4.121) inxi: 2.3.42 
    
    

    Thank you for the reassurance

  • @mathssite1 said in ACPI Bios Error:

    BIOS: Hewlett-Packard v: F.31 date: 02/29/2008

    there is an BIOS update aviable:
    Type:BIOS
    Version: F.34
    Operating systems:Windows Vista (64-bit)
    Release date:Sep 30, 2008
    File name: sp41279.exe (2.1 MB)
    Compaq Presario A900 Notebook PC series , WinFlash for HP Notebook System BIOS (for Notebooks with Intel Processors) , Windows Vista (64-bit) , 2.1 MB , sp41279.exe

    https://support.hp.com/us-en/drivers/selfservice/swdetails/compaq-presario-a900-notebook-pc-series/3641174/swItemId/ob-65442-1

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

acpi7 error196 bios16 Posts 4Views 171
Log in to reply