• How to extract to root folder?


    I want to change Gnome icons but after downloading the file I cant extract to the usr/share/icons folder as it needs root permission. How do I do this? Please ‘KISS’ with answer as I am too old or too thick to get my head around complicated terminal commands :rolling_eyes:

  • You could open the file manager as root. It will give you a bunch of errors in the terminal which you can ignore.

    Paste this command in terminal.
    sudo nautilus

    The file manager may be un-themed which is normal.

    You may also need to extract the files first to a home directory then use Nautilus as root to drag and drop them into the desired folder.

  • @underclock well that worked to access the folder as per instructions - so many thanks for that. I now have to figure out why Tweak Tools isn’t seeing it :rolling_eyes:
    Should not be this complicated to change Gnomes icons surely?

  • /usr/share/icons/ is the correct folder

    You may have to restart the Gnome desktop to see the changes.
    Try Alt-F2 then type in r and hit enter to quickly restart Gnome.

  • @underclock i have downloaded via github / Gnome-look Arc-OSX and Obsidian icons but Tweaks still does not see them. I did the Alt-F2 & I have rebooted the system. Yesterday I installed via pamac, Oxygen and it sees that ok. Baffled.

  • I would compare what you downloaded to other icon folders and make sure the format looks similar. The only other thing I can think of is file permissions. Right clicking the folder using nautilus as root.
    iconpermissions

  • @underclock I thought I sorted it. The icon packs are a master folder containing different folders. For example Obsidian master contains folders ‘Obsidian’ ‘Obsidian - aqua / amber etc’ so I removed the master & copied in the ‘Obsidian’ folder instead. Tweak saw it & I selected it but it broke Gnome completely. Had to live disc to remove the folder to get Antergos running again. Back to the drawing board.

  • The obsidian icon theme is in the AUR.

    https://aur.archlinux.org/packages/obsidian-icon-theme/

    Install it via Add/Remove Software

    I used packer which is a command line program to search the AUR packer -Ss obsidian

    And installed using packer -S obsidian-icon-theme everything seems to work fine.

  • @underclock From your link I downloaded Obsidian tar.gz. Extracted it & put all the individual folders in Icons. Tweak sees all & can be selected. Cheers. Great help :thumbsup:

  • @Uzi

    That theme package from AUR can be installed directly from Pamac (the default package manager and updater), too. It is much simpler that way, and you’ll get possible updates later.

    By default, AUR support is not enabled in Pamac, but it can easily be configured to do so (within Pamac).

  • and there is no need for root permissions to get icon themes work per user rights:

    simple copy them under ~/.icons/ (/home/your-users-name/.icons/)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad I tried that 1st but it didn’t work. Tweak did not see them. I think it is because the unzipped folder stops it. The content folders are what needs copying but that isn’t what the instructions say to do. Anyway I have Obsidian working & all looks stunning now. Antergos should look at it, given the colour options it offers.

  • yes it can#t be zippet needs to be a unzippet folder…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad Sorry you misunderstood me. I meant after extracting, there is one folder containing all the individual folders, you have to copy those in not the main/master folder.

  • sure only the folder including the icon files not the master folder ;)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

extract1 folder11 root12 Posts 16Views 245
Log in to reply