• Scudcloud (Slack Client) Not Starting


    Hey Guys,

    Installed scudcloud and seeing the following:

    [[email protected] ~]$ scudcloud 
    Traceback (most recent call last):
      File "/usr/bin/scudcloud", line 11, in <module>
        load_entry_point('scudcloud==1.63', 'gui_scripts', 'scudcloud')()
      File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 570, in load_entry_point
        return get_distribution(dist).load_entry_point(group, name)
      File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2755, in load_entry_point
        return ep.load()
      File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2409, in load
        return self.resolve()
      File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2415, in resolve
        module = __import__(self.module_name, fromlist=['__name__'], level=0)
      File "/usr/lib/python3.6/site-packages/scudcloud/__main__.py", line 16, in <module>
        import scudcloud.scudcloud as sca
      File "/usr/lib/python3.6/site-packages/scudcloud/scudcloud.py", line 2, in <module>
        from scudcloud.leftpane import LeftPane
      File "/usr/lib/python3.6/site-packages/scudcloud/leftpane.py", line 5, in <module>
        from PyQt5.QtWebKit import QWebSettings
    ImportError: libQt5WebKit.so.5: cannot open shared object file: No such file or directory
    [[email protected] ~]$ 
    

    Any thoughts? TIA.

  • @a4orce84

    ¿ Installation has been by AUR ?

    $ yaourt scudcloud
    1 aur/scudcloud 2:1.63-1 (54) (2,11)
        A Slack client for Linux
    2 aur/scudcloud-git v1.50.r62.gaaf496b-1 (4) (0,18)
        A Linux client for Slack
  • @judd -

    This is inside package manager, in the main antergos repository, NOT AUR.

    Version 1.63-4

  • @a4orce84 said in Scudcloud (Slack Client) Not Starting:

    Versión 1.63-4

    New version ===> aur/scudcloud 2:1.63-1

  • Bit of an Antergos newb, what’s the easiest way to ‘upgrade’ to the new version?

  • yaourt -Syyu --aur 
    

    o

    yaourt -Syua

  • [[email protected] ~]$ yaourt -Syyu --aur
    [sudo] password for aahmad: 
    :: Synchronizing package databases...
     antergos                                                                        165.4 KiB  2.41M/s 00:00 [###############################################################] 100%
     core                                                                            124.5 KiB  1297K/s 00:00 [###############################################################] 100%
     extra                                                                          1653.2 KiB  4.29M/s 00:00 [###############################################################] 100%
     community                                                                         4.1 MiB  8.60M/s 00:00 [###############################################################] 100%
     multilib                                                                        173.7 KiB  10.6M/s 00:00 [###############################################################] 100%
     sublime-text                                                                   1080.0   B  0.00B/s 00:00 [###############################################################] 100%
     sublime-text.sig                                                                543.0   B  0.00B/s 00:00 [###############################################################] 100%
     Foreign packages: \ 11 / 11
    [[email protected] ~]$ sudo pacman -Syy
    :: Synchronizing package databases...
     antergos                                                                        165.4 KiB  2.02M/s 00:00 [###############################################################] 100%
     core                                                                            124.5 KiB  1297K/s 00:00 [###############################################################] 100%
     extra                                                                          1653.2 KiB  4.45M/s 00:00 [###############################################################] 100%
     community                                                                         4.1 MiB  9.76M/s 00:00 [###############################################################] 100%
     multilib                                                                        173.7 KiB  12.1M/s 00:00 [###############################################################] 100%
     sublime-text                                                                   1080.0   B  0.00B/s 00:00 [###############################################################] 100%
     sublime-text.sig                                                                543.0   B  0.00B/s 00:00 [###############################################################] 100%
    [[email protected] ~]$ sudo pacman -uu
    error: invalid option '-u'
    [[email protected] ~]$ sudo pacman -Suu
    :: Starting full system upgrade...
     there is nothing to do
    [[email protected] ~]$ yaourt -Syua
    :: Synchronizing package databases...
     antergos is up to date
     core is up to date
     extra is up to date
     community is up to date
     multilib is up to date
     sublime-text is up to date
     Foreign packages: \ 11 / 11
    [[email protected] ~]$ 
    
  • cat /etc/pacman.conf
    ???

  • [[email protected] ~]$ cat /etc/pacman.conf 
    #
    # /etc/pacman.conf
    #
    # See the pacman.conf(5) manpage for option and repository directives
    
    #
    # GENERAL OPTIONS
    #
    [options]
    # The following paths are commented out with their default values listed.
    # If you wish to use different paths, uncomment and update the paths.
    #RootDir     = /
    #DBPath      = /var/lib/pacman/
    #CacheDir    = /var/cache/pacman/pkg/
    #LogFile     = /var/log/pacman.log
    #GPGDir      = /etc/pacman.d/gnupg/
    #HookDir     = /etc/pacman.d/hooks/
    HoldPkg     = pacman glibc
    #XferCommand = /usr/bin/curl -C - -f %u > %o
    #XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
    #CleanMethod = KeepInstalled
    #UseDelta    = 0.7
    Architecture = auto
    
    # Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
    #IgnorePkg   =
    #IgnoreGroup =
    
    #NoUpgrade   =
    #NoExtract   =
    
    # Misc options
    #UseSyslog
    #Color
    #TotalDownload
    CheckSpace
    #VerbosePkgLists
    
    # By default, pacman accepts packages signed by keys that its local keyring
    # trusts (see pacman-key and its man page), as well as unsigned packages.
    SigLevel    = Required DatabaseOptional
    LocalFileSigLevel = Optional
    #RemoteFileSigLevel = Required
    
    # NOTE: You must run `pacman-key --init` before first using pacman; the local
    # keyring can then be populated with the keys of all official Arch Linux
    # packagers with `pacman-key --populate archlinux`.
    
    #
    # REPOSITORIES
    #   - can be defined here or included from another file
    #   - pacman will search repositories in the order defined here
    #   - local/custom mirrors can be added here or in separate files
    #   - repositories listed first will take precedence when packages
    #     have identical names, regardless of version number
    #   - URLs will have $repo replaced by the name of the current repo
    #   - URLs will have $arch replaced by the name of the architecture
    #
    # Repository entries are of the format:
    #       [repo-name]
    #       Server = ServerName
    #       Include = IncludePath
    #
    # The header [repo-name] is crucial - it must be present and
    # uncommented to enable the repo.
    #
    
    # The testing repositories are disabled by default. To enable, uncomment the
    # repo name header and Include lines. You can add preferred servers immediately
    # after the header, and they will be used before the default mirrors.
    
    
    #[antergos-staging]
    #SigLevel = PackageRequired
    #Server = http://mirrors.antergos.com/$repo/$arch/
    
    [antergos]
    SigLevel = PackageRequired
    Include = /etc/pacman.d/antergos-mirrorlist
    
    #[testing]
    #Include = /etc/pacman.d/mirrorlist
    
    [core]
    Include = /etc/pacman.d/mirrorlist
    
    [extra]
    Include = /etc/pacman.d/mirrorlist
    
    #[community-testing]
    #Include = /etc/pacman.d/mirrorlist
    
    [community]
    Include = /etc/pacman.d/mirrorlist
    
    # If you want to run 32 bit applications on your x86_64 system,
    # enable the multilib repositories as required here.
    
    #[multilib-testing]
    #Include = /etc/pacman.d/mirrorlist
    
    [multilib]
    Include = /etc/pacman.d/mirrorlist
    
    # An example of a custom package repository.  See the pacman manpage for
    # tips on creating your own repositories.
    #[custom]
    #SigLevel = Optional TrustAll
    #Server = file:///home/custompkgs
    
    [sublime-text]
    Server = https://download.sublimetext.com/arch/stable/x86_64
    [[email protected] ~]$ 
    

    Would it be easier to uninstall and reinstall the new Scudcloud packages?

  • @a4orce84 said in Scudcloud (Slack Client) Not Starting:

    ¿Sería más fácil desinstalar y reinstalar los nuevos paquetes de Scudcloud?

    Try not a bad idea!

  • yaourt scudcloud 
    2
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • That did it, thanks @joekamprad !

    Thanks,
    Asif

  • @judd Not bad! it is allways good to do a full update befor installing new stuff ;)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • jajajajaja joke :)

starting10 client4 slack2 scudcloud1 Posts 15Views 127
Log in to reply