• Need help with a PCE-AC88 (ASUS) net adapter (or guidance)


    Hello!! :D (the lspci gets me this info for my wifi adapter “0b:00.0 Network controller: Broadcom Limited Device 43c3 (rev 04)”).

    I’ve been checking for a way to solve this (I can’t get wi-fi activated, nor even as an option) and all I have found points to exactly the same direction, extracting a file called “brcmfmac4366c-pcie.bin” from an ASUS firmware file and then place it in “/lib/firmware/brcm”.
    The problem is this, I used this 3 guides:

    https://ubuntuforums.org/showthread.php?t=2337200&p=13618497#post13618497

    wich didn’t work and I noticed these 2 errors (second and third line)

    [ 6.564945] brcmfmac 0000:0b:00.0: enabling device (0000 -> 0002)
    [ 6.676606] brcmfmac 0000:0b:00.0: Direct firmware load for brcm/brcmfmac4366c-pcie.txt failed with error -2
    [ 9.123400] brcmfmac: brcmf_pcie_download_fw_nvram: FW failed to initialize

    (there’s more lines but I just included the ones from brcmfmac)

    the same happens if I follow the instructions on this topic:

    https://forum.antergos.com/topic/6102/wifi-pci-card-drivers/16

    on this topic there’s an extracted file (brcmfmac4366c-pcie.bin) to dowload without having to do any hard work, but I get exactly the same error from above.

    the third guide I used is here:

    https://rhees.nl/2017/03/10/HOWTO-install-drivers-for-the-Asus-PCE-AC88-on-Debian-Jessie/

    In this guide I jumped to step 4, but I got stuck at this line:

    mkdir squashdir unsquashfs -f -d squashdir AsusPceAc88Driver.squashfs

    konsole tells me mkdir doesn’t have such command (-f), but looking at the squashfs manual, it seems to belong to it, the same for “-d”, so I don’w know it happens because there’s differences on this programs between antergos and debian.

    Any help with this will be greatly appreciated! :)
    It ha become a pain in the 4$$… T_T

    THANKS IN ADVANCE!!!
    HAVE A GREAT DAY!!!

    PD: if you need some info in order to help me, I will be glad to provide it! (please, just specify what and how to get it).

  • @Dante_Igashu

    What does the konsole return on ???

    lspci -k -nn | grep -A 3 -i net

    It is one of the most difficult Broadcom there, I have the 43142 which is the simplest, if you will, of all, but we will see what can be done, some brain of the forum will give you help.
    (Although it would also be good, it seems to me, not to merge, erase all of the above and start over.)

    This needs to be enabled:
    systemctl enable dhcpcd.service
    and
    systemctl enable NetworkManager.service

    and them restarting ???

    [read here] https://forum.ubuntu-fr.org/viewtopic.php?pid=21705625 [solved]

  • @judd

    (By erase and start over, you mean, modyfing the first post, like if I have tried to do nothing yet?) :O

    Hello!!! Thanks for replying! :)
    Something “weird” happened today. Last night I powered off my PC, after trying to make those file work and not even getting a Wi-Fi icon to appear, but today I turn it on again and there it is, the Wi-FI icon now appears and I can get wireless signal, but is choppy, I still get the icon to tell me I am connected but very often the PC just won’t get a site to load, and after a few minutes I get completely disconnected, which is very annoying, so I decide to try something else.
    I use, once again, the file provided on the second link of my first post (yep, I erased the file I extracted first and then copy the other file to the brcm folder), restart the system and the Wi-Fi icon is gone, so it seems the other file just won’t work, then I used the commands you provided, restart and still nothing.
    After this I erase the file from the brcm folder and copy back the file that I extracted, restart the system and Boom!! I have the Wi-Fi icon Again, I connect back to internet using Wi-Fi and this time it seems (at least right now) to be working properly…

    So, I will be using the PC for a couple of days and see if it keeps working correctly.
    Will be back to post whatever happens in a couple days…

    I will leave what konsole returns after using (just in case it is needed in the future):

    lspci -k -nn | grep -A 3 -i net
    
    06:00.0 Ethernet controller [0200]: Intel Corporation I211 Gigabit Network Connection [8086:1539] (rev 03)
            Subsystem: Gigabyte Technology Co., Ltd I211 Gigabit Network Connection [1458:e000]
            Kernel driver in use: igb
            Kernel modules: igb
    07:00.0 Ethernet controller [0200]: Qualcomm Atheros Device [1969:e0b1] (rev 10)
            Subsystem: Gigabyte Technology Co., Ltd Device [1458:e000]
            Kernel driver in use: alx
            Kernel modules: alx
    --
    0b:00.0 Network controller [0280]: Broadcom Limited Device [14e4:43c3] (rev 04)
            Subsystem: ASUSTeK Computer Inc. Device [1043:86fb]
            Kernel driver in use: brcmfmac
            Kernel modules: brcmfmac
    
    

    Thanks again for helping me! :)

  • @Dante_Igashu !

    Well I’m glad, and seeing the output of the console, the driver is in use and it’s fundamental that does not take error

    driver in use: brcmfmac :) ;)

    cheers !!!

Posts 4Views 133
Log in to reply