• fresh system fails booting on Loading initial ramdisk


    After install of the newest antergos image (17.10) the system fails to boot. Fallback kernel works.
    System is hp z840
    Xeon E5
    Nvidia 1080 card

    (the problem was also present with the last kernel update)

  • may nvidia drivers are not updated? they need to fit with current kernel version…

    Or you are using nouveau driver?

    https://antergos.com/wiki/de/miscellaneous/howto-boot-without-graphical-environment/
    https://antergos.com/wiki/de/hardware/graphics/antergos-nvidia-installer-2/

  • @joekamprad nvidia driver is up to day, nothing in logs that early :/

  • @krajnak.matus also nvidia installer says the card is not supported
    (GeForce GTX 1080)

  • you can try to rebuild kernel images:

    sudo mkinitcpio -p linux

  • @joekamprad I reinstalled the linux package from chroot so that was done with it. It also did not boot with nouveau … but fallback image works - maybe some sort of acpi/kms problem?

  • I’ll probably downgrade to some snap day, because I have quite a strong dependency on CUDA 8.0 which was upgraded to 9.0 recently

  • not even that works, hmm
    only managed to get it through by removing autodetect hook

  • as workaround you should install linux-lts kernel and boot with this, needs also nvidia-lts or nvidia-dkms + linux-lts-headers

  • linux-lts didnt work, but only tried with nouveau

  • howdo you do this? plz. give more details, as “didn’t work” is never helping…

  • I installed the system with linux-lts and nouveau driver, because the antergos tool did not recognise my card (new GTX 1080 Ti)

    1. tried to boot it and it failed on initial ramdisk (lts and standard).

    2. chrooted, reinstalled kernels and it was still the same (lts and standard).

    3. noticed it works on fallback init image (lts and standard)

    4. removed nouveau, installed nvidia drivers (without dkms) - did not work

    5. removed autodetect hook and it boots normally (basically equals a fallback image now)

    this sort of means autodetect hook misses a module I need to boot?

  • @krajnak.matus said in fresh system fails booting on Loading initial ramdisk:

    autodetect hook

    autodetect Shrinks your initramfs to a smaller size by creating a whitelist of modules from a scan of sysfs. Be sure to verify included modules are correct and none are missing. This hook must be run before other subsystem hooks in order to take advantage of auto-detection. Any hooks placed before ‘autodetect’ will be installed in full.

    this sort of means autodetect hook misses a module I need to boot?

    you get a good point and nice summery ;)

    It looks like that autodetect hook is creating a unbootable initramfs for your system to boot… thats not common!

  • can you pastebin a full boot log?

    journalctl -b -0 > ~/journal.txt
    

    upload journal.txt to a pastebin service like http://pasted.co/
    or use magically autpaste:

    sudo pacman -S pastebinit
    journalctl -b -0 > ~/journal.txt && pastebinit -i ~/journal.txt -b lpaste.net
    
  • This is after the last update - did not have time to do this sooner

    http://pasted.co/07ad4b24

    This is worse because it failed even without autodetect (tho I am not sure if update script uses autodetect by default - would expect to follow mkinitcpio.conf)

  • just installed dkms and put the autodetect hook back and system boots fine … this is quite random behaviour

    new journalctl:
    http://pasted.co/99a6f119

    edt : standard kernel, not lts

  • And looks all kind of graphics related… also huge amount of ACPI errors… i would take a look if a BIOS/EFI update is aviable for your board.

system129 booting48 fails37 fresh35 Posts 18Views 1832
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.