• How do I change the Gnome Web (Epiphany) user agent?

    I am using Gnome web because it is my favorite browser but some websites block features due to its user agent. One example is Outlook.com. It looks like it is ancient. I was able to change the ua in Zorin OS 12 and it had the brand new interface working. I, however, tried that same command again in Antergos and it didn’t work. How can I do this?

    Below is a screenshot of Outlook from Gnome Web user agent:

    0_1508778641685_Screenshot from 2017-10-23 11-07-26.png

  • /org/gnome/epiphany/web/user-agent is where it needs to be set now, but i can not find this inside dconf-editor only the old entry is there:
    0_1508781292967_Bildschirmfoto vom 2017-10-23 19-54-06.png

  • @joekamprad said in How do I change the Gnome Web (Epiphany) user agent?:


    I don’t have that. There is only “enable popups” in there. Editing /org/gnome/epiphany/user-agent doesn’t seem to do anything.

  • exact :) seems to be something to research on, because dconf itself say that the entry
    /org/gnome/epiphany/user-agent is deprecated and we should use /org/gnome/epiphany/web/user-agent instead… but this does not exist…

  • you can do it by this command:

    gsettings set org.gnome.Epiphany.web:/org/gnome/epiphany/web/ user-agent "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2049.0 Safari/537.36"
gnome361 web9 epiphany3 agent3 Posts 5Views 1214
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.