• Nvidia GeForce GT710 (desktop): Nvidia drivers install


    Hi All,
    Because of a problem with kaffeine app as dvb-t player (only audio no video) I would need to install nvidia proprietary drivers (so I solved on Manjaro Linux). I have read several threads (some dated) but I did not understand what the most appropriate (and updated) way to install the drivers on Antergos Linux.
    The graphics card is msi Nvidia GeForce GT 710 (desktop)
    Thanks in advance for Your help

  • i got the same card, and it is giving screen flimmering on nouveau, so i do install nvidia prop. drivers for it…

    I just use the nvidia-installer with the force option, because the card is not in the database (of the installer script) so:

    easyway

    sudo pacman -S nvidia-installer
    sudo nvidia-installer -f
    sudo systemctl reboot
    

    will do the trick…

    if you want KMS to get maybe want gnome-wayland-session working you need to hack a bit after this…

    adding nvidia-drm.modeset=1 to the kernel parameter inside grub:

    sudo nano /etc/default/grub
    and put nvidia-drm.modeset=1
    inside as you can see here:

    # GRUB boot loader configuration
    
    GRUB_DEFAULT=0
    GRUB_TIMEOUT=5
    GRUB_DISTRIBUTOR="Antergos"
    GRUB_CMDLINE_LINUX_DEFAULT="nvidia-modeset=1 resume=UUID=*****
    

    save the file [Ctrl+X]
    rebuild the grub.cfg:
    sudo grub-mkconfig -o /boot/grub/grub.cfg
    edit mkinitcpio.conf to get the module inside:

    sudo nano /etc/mkinitcpio.conf
    and edit like this:

    # vim:set ft=sh
    # MODULES
    # The following modules are loaded before any boot hooks are
    # run.  Advanced users may wish to specify all system modules
    # in this array.  For instance:
    #     MODULES="piix ide_disk reiserfs"
    MODULES="nvidia"
    
    # BINARIES
    ....
    

    save the file as above…

    rebuild kernel image:

    sudo mkconfig -p linux

    replace linux with linux-lts if you are using lts kernel…

    reboot again and you shpuld have early boot enabled… this will make it possible to run a GNOME session on wayland together with GDM instead of lightdm…

    I use also the persistence mode from nvidia http://docs.nvidia.com/deploy/driver-persistence/index.html
    thhis is simple done by enabeling the systemd-service:
    sudo systemctl enable nvidia-persistenced.service
    and i have nvidia-settings installed and run it on login with this to get better video quality:

    nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

    https://wiki.archlinux.org/index.php/NVIDIA/Troubleshooting#Avoid_screen_tearing

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Thank you for the reply.
    I tried the easyway, everything seemed to be fine but at restart after the first boot phase i only have a black screen with the blinking prompt (a tty2 terminal with Ctrl+Alt+F2).
    Sorry i’m a newbie with Antegos (and Arch) how can i fix this problem?

  • are using lightdm or do you change the dm before?
    (Desktop Manager Login Manager) #
    i would try to change the dm from TTY2:

    sudo pacman -S gdm (Gnome)
    sudo pacman -S sddm (KDE)

    sudo systemctl -f enable gdm or
    sudo systemctl -f enable sddm

    reboot

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • I did not change the dm. Using Antergos with Cinnamon DE, how can I check what the default display manager is?

  • @sardus-X
    You can check the status with
    systemctl status servicename
    For example,
    systemctl status lightdm

    You can also check what display manager you have installed with pamac, search for ‘display manager’.

  • checked with

    systemctl status display-manager
    

    lightdm seems to be the default display manager.

    with:

    systemctl status lightdm.service
    

    result Failed to start Light Display Manager. How can i fix it?

  • systemctl start lightdm.service ò systemctl restart lightdm.service

  • both do not work, no message, only clear the terminal and return the blinking prompt.
    Any idea?

  • @sardus-X
    If the problem is only how to start the services, then you could try commands

    systemctl enable lightdm.service
    systemctl start lightdm.service
    

    or similar if you have other display managers.

    If that doesn’t help, you could try blacklisting nouveau if not already done so, add kernel boot parameter modprobe.blacklist=nouveau.

  • @manuel said in Nvidia GeForce GT710 (desktop): Nvidia drivers install:

    If that doesn’t help, you could try blacklisting nouveau if not already done so, add kernel boot parameter modprobe.blacklist=nouveau.

    sorry, can you explain me how to?
    Thx

  • @sardus-X
    When you boot the USB stick, there is a line where you can write kernel parameters.

    Or in the grub.cfg you can write them, too, but that will be overwritten when you update grub. But to test it, you can write it to grub.cfg and run ‘grub-mkconfig -o /boot/grub/grub.cfg’.

    Or one way is to write a new permanent file /boot/grub/custom.cfg where you can copy the current Antergos boot entry (a menuentry block) from /boot/grub/grub.cfg. That file will not be overwritten by the system.

  • nouveau should already be away if user is installing by nvidia-installer…

    and as it looks like lightdm can not start at all, so we have to possible scenarios:

    • nvidia driver is not installed properly > reinstall iot with nvidia-installer -f and take a look that it does not fail!
    • lightdm issues to start caused by unknown error > install a other dm and try to start it:

    sudo pacman -S gdm
    sudo systemctl -f enable gdm
    sudo systemctl reboot

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Reinstalled nvidia-installer, nvidia drivers with nvidia-installer, no errors but does not work
    installed gdm, no errors but at every attempt to restart the boot progress stops at a different line.
    “Started Hostname service”
    “Started Network Manager Script Dispatcher Service”
    “started Accoun Service”

    however, in the output of the boot process can be read:
    “Starting GNOME Display Manager”

    “Started GNOME Display Manager”

    If i check with systemctl status display-manager, gdm is “active” (running) but with some warning lines after:

    “unable to kill session worker process”
    "Could not start command “/usr/lib/gdm/gdm-session-worker: to many open files”
    “Glib: g-child-watch-add-full: assertion ‘pid>0’ failed”

  • Update:
    how can i check that the Nouveau drivers are blacklisted?
    If i reinstall Antergos can i install nvidia drivers as an option during the installation (maybe I might be more lucky…)?
    Thx

  • @sardus-X said:

    how can i check that the Nouveau drivers are blacklisted?

    lspci -k | grep -A 2 -E "(VGA|3D)"

    lsmod | grep nvidia

  • as your card is not in the database there is no way to install driver during installation, but a new install and directly using nvidia-installer after first boot may solve your problem

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @judd said in Nvidia GeForce GT710 (desktop): Nvidia drivers install:

    @sardus-X said:

    how can i check that the Nouveau drivers are blacklisted?

    lspci -k | grep -A 2 -E "(VGA|3D)"

    lsmod | grep nvidia

    after typing in tty2:

    lspci -k | grep -A 2 -E "(VGA|3D)"
    

    In addition to the video card specifications, there is the following line:

    kernel modules: nouveau, nvidia_drm, nvidia
    

    what does it mean?

    after typing:

    lsmod | grep nvidia
    
    

    no reply message

  • @sardus-X

    lsmod | grep nouveau
    

    If that shows nothing, it is blacklisted.

  • @manuel said in Nvidia GeForce GT710 (desktop): Nvidia drivers install:

    @sardus-X

    lsmod | grep nouveau
    

    If that shows nothing, it is blacklisted.

    Nothing, as well as with nvidia. Are both blacklisted?

nvidia111 gt7101 geforce1 Posts 38Views 824
Log in to reply