• How to enable touchpad settings (horizontal & natural scrolling)


    When I first installed Antergos Gnome I wasn’t able to enable natural scrolling with the settings. I had to change the settings via the config file.

    Note: Before editing these system files make sure to back up your original in another folder!
    Improperly editing one of these files can cause your system to stop working. Mine personally stopped working after doing this wrong once. I had to manually fix the files through the command line to save my installation.

    You’ll have to create a new Synaptics file with:

    $ sudo cp /etc/X11/xorg.conf.d/50-synapticsconf /etc/X11/xorg.conf.d/new-50-synaptics.conf
    

    Then you’ll need to edit the new file you just made with the following command:

    $ sudo nano /etc/X11/xorg.conf.d/new-50-synaptics.conf
    

    Make it be like this:

    # Example xorg.conf.d snippet that assigns the touchpad driver
    # to all touchpads. See xorg.conf.d(5) for more information on
    # InputClass.
    # DO NOT EDIT THIS FILE, your distribution will likely overwrite
    # it when updating. Copy (and rename) this file into
    # /etc/X11/xorg.conf.d first.
    # Additional options may be added in the form of
    #   Option "OptionName" "value"
    #
    Section "InputClass"
            Identifier "touchpad catchall"
            Driver "synaptics"
            MatchIsTouchpad "on"
            Option "TapButton1" "1"
            Option "TapButton2" "2"
            Option "TapButton3" "3"
            Option      "VertScrollDelta"          "-111"
    	Option      "HorizScrollDelta"         "-111"
    # This option is recommend on all Linux systems using evdev, but cannot be
    # enabled by default. See the following link for details:
    # http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
            MatchDevicePath "/dev/input/event*"
    EndSection
    
    Section "InputClass"
            Identifier "touchpad ignore duplicates"
            MatchIsTouchpad "on"
            MatchOS "Linux"
            MatchDevicePath "/dev/input/mouse*"
            Option "Ignore" "on"
    EndSection
    
    # This option enables the bottom right corner to be a right button on
    # non-synaptics clickpads.
    # This option is only interpreted by clickpads.
    Section "InputClass"
            Identifier "Default clickpad buttons"
            MatchDriver "synaptics"
            Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
    EndSection
    
    # This option disables software buttons on Apple touchpads.
    # This option is only interpreted by clickpads.
    Section "InputClass"
            Identifier "Disable clickpad buttons on Apple touchpads"
            MatchProduct "Apple|bcm5974"
            MatchDriver "synaptics"
            Option "SoftButtonAreas" "0 0 0 0 0 0 0 0"
    EndSection
    

    Then you should be able to scroll naturally after a restart. More info @https://wiki.archlinux.org/index.php/Touchpad_Synaptics#Natural_scrolling.

    For horizontal scrolling you will have to run the following command:

    $ synclient HorizTwoFingerScroll=1
    

    More info @https://askubuntu.com/questions/264091/enable-horizontal-scrolling-in-ubuntu 4th post down.

    Check out my art website @https://sites.google.com/site/sidedvirusartandanimation/home ;)

  • Another option: move to libinput. After this, you will see some more configuration options in the gnome settings, including natural scrolling and two-finger scrolling.

    To switch to libinput, uninstall xf86-input-synaptics. Make sure libinput and xf86-input-libinput are installed (I think they are installed by default in Antergos, but synaptics is in charge if xf86-input-synaptics is also installed)

  • This is not the “right” way to do this…

    The files are numbered because Xorg reads them in order…

    Edit the one you have (you can opt to back it up, in a different folder!) Put it all in the “Section “InputClass””

        Option "TapButton1" "1"
        Option "TapButton2" "3"
        Option "TapButton3" "2"
        Option      "VertScrollDelta"          "-111"
        Option      "HorizScrollDelta"         "-111"
    

    (Ignore the TapButton if you dont tap…)
    As you can see I’ve “changed” the order of the buttons… (They dont actually change, 1=1 2= twofinger click/tap 3=threfinger click/tap (mwheel click) This way threefinger tap is “paste”

    PS: on Xorg no command is necessary

    (And i dont like the way touchpads feel with libinput, horrible…)

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • @izznogooood I did edit my post to move the natural scrolling part in the file and add the warning. I, however, fail to see the point of changing the “TapButton# ‘#’” because on my laptop this function works just fine by default.

    Check out my art website @https://sites.google.com/site/sidedvirusartandanimation/home ;)

  • hm, might be touch-pad specific.

    And why are you still creating a new file ? ;)

    OH! When I said edit the one you have i ment the “50-synapticsconf” file. Not your post :D (Sorry)
    The reason why it works is because “n” as in new comes after “5” as in 50 so Xorg reads the file last… But twice. You see? You should not / dont need to have two files.

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • @izznogooood Okay. I just said make the second file just in case you need to delete it because your system won’t start or something. Also, if there would have been an update to the file you would lose your configuration. This way still works because the settings are still there. Do you not need to copy the whole file or will the system just add the extra commands from the additional file?

    Check out my art website @https://sites.google.com/site/sidedvirusartandanimation/home ;)

  • Linux does not update config files without asking you :).

    And I would simply copy the original:

    sudo cp /etc/X11/xorg.conf.d/50-synaptics.conf /etc/X11/xorg.conf.d/50-synaptics.conf.bak
    sudo nano /etc/X11/xorg.conf.d/50-synaptics.conf
    

    Do your edits and if you ever need to go back simply copy the other way…

    sudo cp /etc/X11/xorg.conf.d/50-synaptics.conf.bak /etc/X11/xorg.conf.d/50-synaptics.conf
    

    I make things work…
    My humble wiki: https://anotherlinux.com/

Posts 7Views 213
Log in to reply