• TSC_DEADLINE disabled due to Errata; please update microcode to: 0xb2

    I just did an update of all my packages, and after I restarted I keep getting this error and cannot boot into my OS. I’ve tried to manually enable the u-code but no luck at all (it said no such file)(https://wiki.archlinux.org/index.php/microcode#Manual_method). Please help me~~

    EDIT1: I also got this error twice after the ucode-related error: “tpm_crb MSFT0101:00: [Firmware Bug]: ACPI region does not cover t”

    EDIT2: By being unable to boot I mean the screen is blank (black) and it keeps turning on and off repeatedly. I try to use ctrl+alt fX to enter tty but it was no luck at all.

  • I’m trying to setup a Archlinux x64 on a VM (Virtual Box). I got this exact same error when restarting after setting up GRUB 2 (GPT configuration). I 1st thought it was this problem that was preventing me from booting but I found out only my second error message (about crc32c module not loading) was in cause.

    After correcting this, I still got the same error message than you but can still boot. Do you have any additional error message ?

    Which version of intel-ucode did you installed on your computer ?

  • I was having a similar problem and used the “Automatic Method” from the same wiki article. I now see the following in my /boot/grub/grub.cfg:

    	echo	'Loading initial ramdisk ...'
    	initrd	/intel-ucode.img /initramfs-linux.img

    I didn’t have the intel-ucode package installed, so I did that before running the grub-mkconfig command.

    Unlike you, I was able to boot before making this change, but I would get random system freezes, and had to power down and reboot each time. This was the same message I was seeing in the logs at the time of the system freeze.

  • Where is your intel-ucode.img file?

  • @paul.fabre3000 Yes, my apology. I forgot to add them to my post. I also see the error said “tpm_crb MSFT0101:00: [Firmware Bug]: ACPI region does not cover t” I tried to search on it but it was no luck either.

  • @mark.edmunds Yes I tried the manual method and both /intel-ucode.img and /boot/intel-ucode.img didn’t work (it said that it couldn’t find the file)

  • @manuel I really don’t know :( Sorry I am a real noob when it comes to kernels and systems

  • Files intel-ucode.img and vmlinuz-linux should be in /boot.
    You can boot your machine with the Antergos installer USB stick and use a file manager to find your files.

  • @manuel It should be but when I add the initrd lines it told me that system cannot find the file, but still thanks for your suggestion, it is surely a good idea and I will try it out~~

    But paul.fabre3000 might also be right that the problem of being unable to boot may be caused by the other error I added.

  • @mmartin20tw
    If you can’t find intel-ucode.img in /boot/, you’ll have to install it yourself: pacman -S intel-ucode on archLinux (I never used antergos, so I don’t know about your package installer)

    Remember that you can “find / -name intel-ucode.img” if you’re not sure where to look at (may be long if you have a lot of files).

    My grub.cfg seem to be well configured, and the .img is correctly in /boot/
    But anyway, I’ll check my problem later when I’ll have more time.

  • @paul.fabre3000 May I ask that how can I install new packages without being able to enter tty? Or can I do it with LiveUSB? Thanks!

    Thanks a lot for the find method, it might help out :)

  • @paul-fabre3000
    I haven’t seen the error in my logs since I installed the intel-ucode.img and reconfigured grub, but I only saw it once or twice a day before then. The error was always associated with a hard system crash, so I’m hoping the changes I made will make my system more stable.

  • @mmartin20tw
    You should probably be able to do it with a LiveUSB.

    Try to manually mount your partition then ‘chroot’ inside.
    List availables partitions : lsblk

    Typically for me it’s:
    mount /dev/sda7 /mnt
    mount /dev/sda5 /mnt/boot
    arch-chroot /mnt

    On antergos the command should probably be ‘chroot’
    You should ask someone who know the system to help you. As I said, I never used antergos.

  • @paul.fabre3000 I just boot into LiveUSB and I the intel-ucode.img file is right there in the boot folder, so why would I get error message that said no such file when I add /boot/intel-ucode.img to my grub initrd line?

  • arch-chroot is OK in Antergos, too.

  • Maybe if grub directly load boot partition before mounting it, /boot/intel-ucode would become /intel-ucode.img.
    But if you tried both path then I have no idea why it’s saying “file not found”.

    EDIT: That would be in case you have a separate partition for /boot

  • This post is deleted!
  • @paul.fabre3000 Yes I just tried them both again but still the same results, it still said file not found. Really weird :(

  • Is /boot on a different partition than root (/)?

  • @manuel I am not sure but I do know that I mounted boot on the ESP partition of Windows 10 for the sake of dual booting. So I think that means they are on different partition right?

    EDIT1: When I use LiveUSB to find the intel-ucode.img file, i did find it under this route: /boot/intel-ucode.img

Posts 30Views 8438
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.