• Broke Dual Boot System (Windows10 and Antergos)


    Hey Guys,

    I know this isn’t a specific Antergos question, but I tried installing the Windows 10 Fall Creators Update, and now my system is borked (Dell XPS 13 9350).

    I was trying to instal the Win10 Fall Update, and increased my GPT partition to be able to install since it needs that partition to get some tmp files ready for the install, and now my computer will not boot:
    https://imgur.com/a/Wkra6

    I have found the following document:
    https://www.easeus.com/partition-manager-software/repair-efi-bootloder-in-windows-10-8-7.html#part5

    Trying to repair the EFI partition, but I get an “access is denied” when trying to run the “bootrec /fixboot” message.

    Can anyone help me out please ASAP? This is my computer for school! =(

    Thanks,
    Asif

  • @joekamprad – I think this is an issue with Grub, can you confirm please?

  • it is not an issue with grub itself, grub can not get the needed files it needs to boot…
    The filechange is may done by windows update, or by that what you are doing to get the update done… (second one is the issue here for sure ;) )

    Be more detailed here to make clear what exactly you need now and what you have done …

    Do you need Windows for shool or Linux? or both?
    You can boot to Antergos but not Windows? or you can not boot at all? ???

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Hey @joekamprad,

    Thanks for the reply. Sorry I was typing in a panic and angry state, since I was the one that triggered all of this last night. =)

    Let me take a step back and give you the information you need:

    Current Situation:
    Currently, I cannot boot into either my Windows 10 install or my Antergos install on my Dell XPS 13 (9350) laptop. When turning on my computer, I see the following in my grub-menu:

    Screenshot 1 - https://imgur.com/a/xnc1q

    You can see there are multiple Windows 10 entrees now (compared to yesterday). I tried repairing my grub menu (more details below) and those extra entrees popped up. Below, is a screenshot of the errors I see when selecting each OS:

    Windows 10 (#1 and #2 Entrees) Boot Screenshots - https://imgur.com/a/mEVZ9

    “Real” Windows 10 Entree Boot Screenshots:
    https://imgur.com/a/4uXke
    https://imgur.com/a/8eELo

    Antergos Boot Screenshot - https://imgur.com/a/DilSf


    How This Happened:
    So, I was trying to install the Windows 10 Fall Creators Update (officially released yesterday). Every-time I tried installing the update, I would get a “We couldn’t update the system reserved partition” error message. Doing some googling I found this was due to my 'System Reserved" partition not having enough space. I looked, and it was only 100mbs, and sure enough mine was using 90mbs on the system reserved partition.

    So, I read some people tried to grow (extend) this partition, and that’s where all the fun started. I used a partition tool, and grew the System Reserved Partition to 200mbs total. As far as I can tell that worked successfully:

    All Partitions Currently - https://imgur.com/a/OwI8T
    You can see that ‘volume 2’ is now successfully 200mbs (The System Reserved Partition). After I restarted, then all these problems started with things not working correctly.


    What I Tried To Do To Fix The Issue:
    I tried a few things to see if I could fix the issue last night. From the Windows side, I did this based off Dell’s recommendation of the System Partition / Repairing EFI:

    Link - http://www.dell.com/support/article/us/en/19/sln300987/how-to-repair-the-efi-bootloader-on-a-gpt-hdd-for-windows-7–8--81-and-10-on-your-dell-pc?lang=en

    I then saw on reddit someone mentioned this could actually be a GRUB issue, not an issue with Windows. So, @joekamprad I found a document you penned that discussed repairing GRUB here:

    Link - https://antergos.com/wiki/miscellaneous/how-to-fix-grub-with-efi-boot/

    I tried to follow this, and that is when the additional Windows 10 entrees showed up. Also, here is output from that command below:

    Screenshots:
    https://imgur.com/a/wDa5v

    This is not the exact output, as I ran it once and got a successful GRUB repair output…this is what happened when running it this morning again.


    So, that’s where I am currently. Basically, resizing my reserved system partition borked my system. I can no longer boot into either Windows 10 or Antergos. I use both OS’s for school, so best case scenario I’d like to recover both if possible, and not nuke the system and format everything to get it working again.

    Any help would be greatly appreciated. Please let me know if I can provide any other information in the troubleshooting process.

    Thanks,
    Asif

  • As it says it is allways a bad idea to install windows after linux, and this update looks like something similar to a reinstall of windows, as it changes the bootup parameters in a way…
    So what i would do here is to remove grub first by getting windows repair its boot up structure with windows system tools… (i do not have much knowldge here) then boot into Live Iso from Antergos and reinstall grub completly new.

    What you show up inside this screenschot https://imgur.com/a/wDa5v looks to me like you where not in chrooted inside your Antergos installation… as you whould be root already if so…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • But I didn’t even get to the install the update step. It broke before that point, when I was adjusting the System Reserved partition. I think this is an issue of where GRUB is pointing to, based on the UUID’s of the partitions.

  • but you do changes on the EFI partition…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • you can try to reinstall grub without repairing windows boot and see if it get your dualboot back also… there are a lot different ways to try …

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad
    Yeah, this might solve the problem.
    The UUIDs probably changed and operating systems do no more know how to boot.

  • Manuel,

    Can you tell me how to get the new UUID’s, and where in GRUB to actually update them?

    Or is that what reinstalling grub does behind the scenes?

    Thanks,
    Asif

  • @a4orce84

    Grub should be able to find your UUIDs automatically.
    But you need to be in chroot mode to update your grub.

  • @a4orce84 said in Broke Dual Boot System (Windows10 and Antergos):

    ¿Puedes decirme cómo obtener los nuevos UUID

    $ lsblk -f
    
  • Tried reinstalling my Grub Boot Menu, using this document:
    https://antergos.com/wiki/miscellaneous/how-to-fix-grub-with-efi-boot/

    My output from running it:
    https://www.evernote.com/shard/s91/sh/ca543a37-9064-4b68-839f-741e49f5313d/c5f5abb18a53abc8adc6f079b225b04c

    It appears to still give me the same errors when trying to boot into either Antergos OR Windows 10.

    Any other thoughts or ideas? =(

  • @a4orce84
    Hi,
    maybe you could try a different order of the commands in the beginning and another small modification like below:

    mount /dev/nvme0n1p5 /mnt
    arch-chroot /mnt
    mkdir -p /boot/efi
    mount /dev/nvme0n1p2 /boot/efi  # note the shorter path
    

    Does that order give you any less errors?

    EDIT: You should boot the USB stick with EFI, not BIOS-MBR.
    Could you show the output of:

    find /boot -name \*.efi -exec ls -l {} \;
    

    after the arch-chroot command?

  • @manuel to mount EFI from inside chroot can be smart! and also possible (i see this sometimes) that Livesystem is not bootup as EFI…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad
    Those last error messages seem to show that the Livesystem is not EFI, I wonder why…

  • Hey Guys,

    So, I figured out the issue on EFI Boot vs. BIOS-MBR. I looked closer at my Dell options when booting from USB, screenshot here:
    https://www.dropbox.com/s/xs7xc62p83d8t28/Screenshot 2017-10-20 17.14.17.png?dl=0

    Apparently, I was being dumb and choosing the “LEGACY BOOT” option when I first started troubleshooting. When I SHOULD have been choosing the “UEFI BOOT” option. Either way, I ran through all the tests again and all the results are the same:

    @joekamprad Grub Repair Document Output:
    https://www.evernote.com/shard/s91/sh/a44eeff0-210a-4c2e-8236-5638354915a1/496a1a845a5ffd9527ea157db6b3558f

    @manuel’s updated steps (in a slightly different order) Output:
    https://www.evernote.com/shard/s91/sh/47331089-cb99-4694-b892-ed24a14f740d/d86fad9264f8943e4158b33b7129a0e2

    Things are still busted it seems…I really don’t want to format and start over, but if we can’t figure this out over the weekend I might have to. =(

    Thanks again to both of you guys for all of your time and help, it is greatly appreciated!

    Thanks,
    Asif

  • @manuel said in Broke Dual Boot System (Windows10 and Antergos):

    @a4orce84
    find /boot -name *.efi -exec ls -l {} ;

    after the arch-chroot command?
    

    @manuel - here is the output to the above command after the arch-chroot command:

    [[email protected] ~]$ sudo su
    [[email protected] antergos]# mount /dev/nvme0n1p5 /mnt
    [[email protected] antergos]# arch-chroot /mnt
    [[email protected] /]# find /boot -name *.efi -exec ls -l {} ;
    -rw-r–r-- 1 root root 122880 Oct 20 17:17 /boot/grub/x86_64-efi/core.efi
    -rw-r–r-- 1 root root 122880 Oct 20 17:17 /boot/grub/x86_64-efi/grub.efi
    [[email protected] /]#

  • @a4orce84
    Sorry, I wasn’t clear, I meant the output after the mount of efi directory, too.

  • last one and also the one before seems to went good (Installation finished. No error reported)
    But windows installation is not detected at what means that may the windows bootup is screwed up also…but may grub will find, if you get to bootinto Antergos installation again and rerun os-prober from there…

    But the screenshot shows: antergos_grub as ID and it should be what you give with the command Antergos-grub

    So may it there is something wrong with EFI partition choosing ??? and the entry is the same as before not changed till now ???

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

system73 dual19 boot175 broke13 Posts 31Views 742
Log in to reply