• Laptop won't suspend when I close the lid


    Lenovo y510p with SLI nvidia cards.

    When this first started someone told me to run this command:
    gsettings set org.gnome.settings-daemon.plugins.xrandr default-monitors-setup ‘do-nothing’

    That worked until I updated my laptop today and now it’s going back to not suspending. The display turns off, but the laptop doesn’t actually sleep.

    I tried running the command again, but get this:

    $ gsettings set org.gnome.settings-daemon.plugins.xrandr default-monitors-setup ‘do-nothing’
    No such schema “org.gnome.settings-daemon.plugins.xrandr”

    Anyone have any ideas or suggestions?

  • I’m seeing a similar problem after the update to Gnome 3.26.1, but only when an external monitor is attached. Before the update my laptop would suspend whenever the lid was closed, even with an external monitor attached. Now the lid close action only suspends if the monitor isn’t connected. I can still manually suspend the laptop by pressing the power button.

    I have the following lines in my /etc/systemd/logind.conf:

    HandleLidSwitch=suspend
    HandleLidSwitchDocked=suspend
    

    But they don’t seem to be effecting the lid close behavior anymore.

  • I’ve got those same settings and it has no effect.

    I think because I have 2 cards it sees one as a monitor or something. I can’t get SLI to work, so I might take it out and see what happens.

  • Install TLP from AUR.

  • I was finally able to figure this out, at least for my setup. In addition to the settings in /etc/systemd/logind.conf, I also had to make the following change in /etc/UPower/UPoser.conf:

    # Some laptops are broken. The lid state is either inverted, or stuck
    # on or off. We can't do much to fix these problems, but this is a way
    # for users to make the laptop panel vanish, a state that might be used
    # by a couple of user-space daemons. On Linux systems, see also
    # logind.conf(5).
    #
    # default=false
    IgnoreLid=true
    

    Setting the IgnoreLid to true seemed to have resolved this for me, but prior to Gnome 3.26, this wasn’t necessary. I think making this change then allows the settings in logind.conf take effect. Discovered the trick from https://www.reddit.com/r/gnome/comments/7810g3/external_monitor_issues_with_gnome_3261/

  • @nerrollus said in Laptop won't suspend when I close the lid:

    When this first started someone told me to run this command:
    gsettings set org.gnome.settings-daemon.plugins.xrandr default-monitors-setup ‘do-nothing’

    Hi there😀. If you install dconf-editor, you can see that org/gnome/settings-daemon/plugins/ does not have “xrandr” anymore😞. Perhaps they moved it? If you install dconf-editor, you can visually view and change all of those values, allowing you to search for the possible new location of this “default-monitors-setup” value.

    I wish I could help more, but sadly I do not really know much about your issue. I just thought that someone might find this little bit of information helpful, so here it is!

    Good luck!
    -Keegan

  • @izznogooood said in Laptop won't suspend when I close the lid:

    Install TLP from AUR.

    https://wiki.archlinux.org/index.php/TLP#Installation

    I have it installed on all my machines and it’s really efficient!

  • TLP is in community repo now no need for AUR

laptop50 suspend45 lid13 close5 Posts 8Views 1553
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.