• Laptop won't suspend when I close the lid


    Lenovo y510p with SLI nvidia cards.

    When this first started someone told me to run this command:
    gsettings set org.gnome.settings-daemon.plugins.xrandr default-monitors-setup ‘do-nothing’

    That worked until I updated my laptop today and now it’s going back to not suspending. The display turns off, but the laptop doesn’t actually sleep.

    I tried running the command again, but get this:

    $ gsettings set org.gnome.settings-daemon.plugins.xrandr default-monitors-setup 'do-nothing’
    No such schema “org.gnome.settings-daemon.plugins.xrandr”

    Anyone have any ideas or suggestions?

  • I’m seeing a similar problem after the update to Gnome 3.26.1, but only when an external monitor is attached. Before the update my laptop would suspend whenever the lid was closed, even with an external monitor attached. Now the lid close action only suspends if the monitor isn’t connected. I can still manually suspend the laptop by pressing the power button.

    I have the following lines in my /etc/systemd/logind.conf:

    HandleLidSwitch=suspend
    HandleLidSwitchDocked=suspend
    

    But they don’t seem to be effecting the lid close behavior anymore.

  • I’ve got those same settings and it has no effect.

    I think because I have 2 cards it sees one as a monitor or something. I can’t get SLI to work, so I might take it out and see what happens.

  • Install TLP from AUR.

    I make things work…
    My humble wiki: https://anotherlinux.com/

lid5 suspend33 close4 laptop35 Posts 4Views 165
Log in to reply