• Can't run my VitualBox


    I created a virtualbox to install Windows 7, but I cant start the machine. Everytime I start the machine, I get the errors found in this image:
    [img:3k0ovixa]http://wpmasterdesign.com/screenshot/[/img:3k0ovixa]
    [http://wpmasterdesign.com/screenshot/][0]">[http://wpmasterdesign.com/screenshot/][1]

    Now, the specified host modules are installed. I have added myself to the Virtualbox user group.But I still cannot use any virtual machine I create. Any ideas what I have done wrong?

    [0]: <a href=
    [1]: http://wpmasterdesign.com/screenshot/

  • I created a virtualbox to install Windows 7, but I cant start the machine. Everytime I start the machine, I get the errors found in this image:
    [img:3k0ovixa]http://wpmasterdesign.com/screenshot/[/img:3k0ovixa]
    [http://wpmasterdesign.com/screenshot/][0]">[http://wpmasterdesign.com/screenshot/][1]

    Now, the specified host modules are installed. I have added myself to the Virtualbox user group.But I still cannot use any virtual machine I create. Any ideas what I have done wrong?

    [0]: <a href=
    [1]: http://wpmasterdesign.com/screenshot/

  • Hi, review the installation steps from the wiki to ensure you have not missed any: [https://wiki.archlinux.org/index.php/VirtualBox#Installation_steps_for_Arch_Linux_hosts][0]">[https://wiki.archlinux.org/index.php/Vi][1] … inux_hosts

    Let me know the result.

    Cheers!

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Vi

  • These are the simplified steps:

    [b:8wk2jz3u]
    Note:[/b:8wk2jz3u] These steps are for the kernel comes default with Archlinux and Antergos:

    $ pacman -Si linux
    

    Repositorio : core[/b:8wk2jz3u]
    Nombre : linux
    Versión : 3.14.4-1
    Descripción : The Linux kernel and modules

    if you do not have[b:8wk2jz3u] linux-headers[/b:8wk2jz3u] installed please install headers:

    sudo pacman -S linux-headers
    

    [b:8wk2jz3u]Step 1: Installation[/b:8wk2jz3u]

    $ sudo pacman -S virtualbox virtualbox-guest-iso  
    >
    

    [b:8wk2jz3u]
    Note:[/b:8wk2jz3u] The above command installed by default [b:8wk2jz3u]virtual-host-modules[/b:8wk2jz3u]

    [b:8wk2jz3u]Step 2 : Load the module[/b:8wk2jz3u]

    \# modprobe vboxdrv
    

    …but if you do not want to do manually at each startup :

    \# nano /etc/modules-load.d/virtualbox.conf
    

    vboxdrv

    [b:8wk2jz3u]Step 3 : Add usernames to the vboxusers group[/b:8wk2jz3u]

    \# gpasswd -a $USER vboxusers
    

    [b:8wk2jz3u]
    Troubleshooting[/b:8wk2jz3u]

    If you put the network adapter in [b:8wk2jz3u]bridged mode[/b:8wk2jz3u] may you continue to give error:

    \# modprobe -a vboxdrv vboxnetadp vboxnetflt  
    >
    

    or if you do not want to do manually at each startup:

      
    >\# nano /etc/modules-load.d/virtualbox.conf
    

    vboxdrv
    vboxnetadp
    vboxnetflt

    Best Regards

  • Hi I did the instructions here, and it fixed almost everything, the secret of course that it rebuilds the kernel AND
    put in all of the modules.

    One problem remains and probably can be fixed by the editing of the virtualbox.conf file.

    Mainly cause you say to edit it, with nano and so I did this but it is actually empty.
    So what lines should be in this virtualbox.conf file? What is its structure?

    I tried putting the lines from your manual into it, but I really do not know if this is correct or not.
    Could you email me a sample of yours? IU can change to suit my needs?
    Post a sample of what should be in this file?

    I still get the error message saying to run

    sudo /sbin/rcvboxdrv setup

    When I do then it will launch my VirtualBox, and all is well until I reboot and then it pops back up.
    For now I created a launcher on my desktop but thats a pain and should not be necsessary
    All the other instructions however work perfectly. I also will NOT or try to avoid updates although 9 new ones just came up.

  • Just put these lines:

    vboxdrv
    vboxnetadp
    vboxnetflt
    vboxpci 
    

    Cheers!

  • Today, after VirtualBox update:

    Unloading modules: 
    Loading modules: modprobe: FATAL: Module vboxnetadp not found in directory /lib/modules/4.4.3-1-ARCH
    modprobe: FATAL: Module vboxnetflt not found in directory /lib/modules/4.4.3-1-ARCH
    modprobe: FATAL: Module vboxpci not found in directory /lib/modules/4.4.3-1-ARCH
    modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/4.4.3-1-ARCH' 
    

    This is the same error and problem like 2-3 days ago.
    @edit: Reinstalled virtualbox-host-modules and everything is ok.

  • Yes this works fully, and makes this entire project COMPLETEL:Y SOLVED.

    I am printing out your guide as it is fully up to date, and complete in how to install Oracle Virtualbox 100 percent correctly and working in ARCH and probably a number of other Linux distros as well.

    And even updates now function properly.

    Oracle and Antergos have not yet fully caught up with each other on the releases, but you can just click cancel if asked within, as the updates are coming thru the built in software updater.

    Now I am off to figure out Lightworks. and then everything in my world will complete.

    There remains to be written a simple GUI based application that will take any DEB Linux or even RPM linux application that will simply allow you to download and install them. I know that is asking a lot but if they pull that one off, then ARCH based linux will likely become what everyone wants.
    Or in my case Antergos, because it has the ultimate installer.

    Then once Linux has a VSS engine to perform backups without leaving the running OS life is going to be utopia.

  • voepew wrote: Today, after VirtualBox update:

    Unloading modules: 
    Loading modules: modprobe: FATAL: Module vboxnetadp not found in directory /lib/modules/4.4.3-1-ARCH
    modprobe: FATAL: Module vboxnetflt not found in directory /lib/modules/4.4.3-1-ARCH
    modprobe: FATAL: Module vboxpci not found in directory /lib/modules/4.4.3-1-ARCH
    modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/4.4.3-1-ARCH' 
    

    This is the same error and problem like 2-3 days ago.

    @edit: Reinstalled virtualbox-host-modules and everything is ok.
    I reinstalled too but virtualbox is still failing:

    sudo /sbin/rcvboxdrv setup
    Unloading modules: 
    Loading modules: modprobe: FATAL: Module vboxnetadp not found in directory /lib/modules/4.4.3-1-ARCH
    modprobe: FATAL: Module vboxnetflt not found in directory /lib/modules/4.4.3-1-ARCH
    modprobe: FATAL: Module vboxpci not found in directory /lib/modules/4.4.3-1-ARCH
    modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/4.4.3-1-ARCH
    
  • @a-bostaurus https://www.archlinux.org/packages/community/x86_64/virtualbox-host-modules/download/ Just download and open. After that you will be able to use VirtualBox but every system update you will be asked to replace community modules to modules dkms - then type “n”. It should be fixed soon with new VirtualBox version.

  • Some minutes ago I came back to my compi, saw your propose, downloaded the zipped directory and thought: That is the same versionnumber as I found in community. So I reinstalled the hostmodules, did modppprobe and everything is working fine since that. I don’t know, what happened yesterday.

    ===> You must load vboxdrv module before starting VirtualBox:
    ===> # modprobe vboxdrv
  • There seems to be a permanent bug in virtualbox. The day before yesterday VB worked. Today I got an error information. To help I should “sudo /sbin/rcvboxdrv setup”. But I got the next error information, well known from further problems. But what helped in the past, does not help today. So VB is not usable. What could I do now?

    [sudo] Passwort für mz-c03: 
    Unloading modules: 
    Loading modules: modprobe: FATAL: Module vboxnetadp not found in directory /lib/modules/4.4.5-1-ARCH
    modprobe: FATAL: Module vboxnetflt not found in directory /lib/modules/4.4.5-1-ARCH
    modprobe: FATAL: Module vboxpci not found in directory /lib/modules/4.4.5-1-ARCH
    modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/4.4.5-1-ARCH
    sudo pacman -S virtualbox-host-modules
    Fehler: Ziel nicht gefunden: virtualbox-host-modules
  • This problem occurs only in community version. You can remove this one and install aur/virtualbox-bin version. Be sure you have core/linux-headers installed because after that you have to compile vbox modules typing sudo dkms autoinstall. After restart everything should working. I hope that it will work for you.

  • I deinstalled the community-version and I am going to install aur-version. There is a hint I do not know how to realize as a command; would you be so polite to write to me the command!

  • Installing did not work.
    sudo dkms autoinstall
    [sudo] Passwort für mz-c03:
    Error! Could not locate dkms.conf file.
    File: does not exist.
    [[email protected] yaourt-tmp-mz-c03]$ cd ~
    [[email protected] ~]$ sudo dkms autoinstall
    Error! Could not locate dkms.conf file.
    File: does not exist.

    [sudo] Passwort für mz-c03: 
    Error! Could not locate dkms.conf file.
    File:  does not exist.
    [[email protected] yaourt-tmp-mz-c03]$ cd ~
    [[email protected] ~]$ sudo dkms autoinstall
    Error! Could not locate dkms.conf file.
    File:  does not exist.
  • After that operation virtualbox is damaged as before. When I started I got the information to run

    ```[sudo] Passwort für mz-c03: 
    ```sudo: /sbin/rcvboxdrv: Befehl nicht gefunden
  • There should be a /dev/vboxdrv Looking at the filemanager, there is not such file or directory.

  • Are you sure you installed aur version typing yaourt -S virtualbox-bin? You should have linux-headers installed also.

  • When installing yaourt -S virtualbox-bin, I saw that the linux-headers were installed. Please, look also at this:

    core/linux-headers 4.4.5-1 [installed]
        Header files and scripts for building modules for Linux kernel
    aur/cloudabi-linux-headers 4.5.0rc1-3 (0) (0,00)
        Header files and scripts for building modules for cloudabi-Linux kernel
    aur/linux-selinux-headers 4.4.5-1 (9) (1,21)
        Header files and scripts for building modules for Linux-selinux kernel
  • Virtualbox 5.0.16 got pushed to the Arch community repo: https://www.archlinux.org/packages/community/x86_64/virtualbox/

    Does this help solve your problem @a-bostaurus ?

Posts 24Views 9130
Log in to reply