• Cannot mix incompatible Qt library (version 0x50901)


    After recent update of some qt packages (extra/qt5-base,extra/qt5-declarative, extra/qt5-multimedia, extra/qt5-svg , extra/qt5-tools, extra/qt5-x11, extra/qt5-xmlpatterns ) I found out that some aplications (AUR) don’t work: Megasync, Bomi player.
    The problem is:
    Cannot mix incompatible Qt library (version 0x50901) with this library (version 0x50902)
    All packages were updated form 5.9.1 to 5.9.2 version.
    How to fix this problem?
    Do we have to wait for that applications to recompile to newer qt?

  • I found solution.
    Problem was with aur qt5gtk2 package.
    I’m using it because some qt apps look ugly as hell on gnome.
    Solution was to recompile that package with qt library updated to 5.9.2 version.

  • @m110s thanks for sharing your findings! Will be very useful in case somebody else faces the same problem.

    Cheers!

Posts 3Views 133
Log in to reply