• Monitors are sleepping after few seconds of inactivity


    After upgrade to Gnome 3.26, my desktop started to show a strange behaviour. After few seconds (approximately 10 seconds) of inactivity, my two monitors sleep. If I press some key on the keyboard or move the mouse, the monitors turn on again.

    I’ve disabled all sleeping configurations on Power Manager config but I had not success.

    Edit: This problem only occurs after the first time I lock the desktop.

  • @leonicolas
    If you use only one monitor, does the problem persist?

  • I’ve tested and when I use only one monitor the problem not happens.

    To stop this behaviour, after it starts, I need to logoff and login again. After this process every think works well until I lock the computer.
    My coworker’s computer (with Antergos, Gnome and GDM) has the same problem. He uses 3 monitors.

    Some information about my configuration:

    • I’m not using LightDM, instead I use GDM.
    • The Gnome version is 3.26.1
    • My Antergos is up to date
  • graphics information would be helpfull too…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Hi @joekamprad

    *-display
    description: VGA compatible controller
    product: Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
    vendor: Intel Corporation
    physical id: 2
    bus info: [email protected]:00:02.0
    version: 09
    width: 64 bits
    clock: 33MHz
    capabilities: msi pm vga_controller bus_master cap_list rom
    configuration: driver=i915 latency=0

    (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20170403

  • @leonicolas said in Monitors are sleepping after few seconds of inactivity:

    Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
    so intel graphics then…
    what shows:

    cat /sys/class/drm/card0/power/rc6_enable
    

    ???

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad

    cat /sys/class/drm/card0/power/rc6_enable
    3

  • this should be fine :(
    But what you get inside powersettings?
    may you got some leftover setting here:

    ~/.config/autostart/screensaver-settings.desktop
    

    If not do you take a look inside settings:

    0_1508330456700_Bildschirmfoto vom 2017-10-18 14-39-52.png

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad

    My power settings are all disabled.
    The desktop is in Portuguese language.

    0_1508332068942_Captura de tela de 2017-10-18 11-01-31.png

  • @joekamprad
    I also tried to change the power settings using dconf-config, but the problem persists.

    0_1508332240442_Captura de tela de 2017-10-18 11-08-53.png

  • @joekamprad

    I tried to use Caffeine Gnome extension (https://extensions.gnome.org/extension/517/caffeine/) to disable the suspend action but the problem persists even though it is enabled.

  • i can see you are not the only one with problems on external/multi- monitor setups…
    I have some like this too on a Lenovo th external monitor, loosing connection is what i like to say, as it looks more like this and not a problem with timeout settings…

    So may related to X11/wayland and graphic drivers…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad

    One way to solve temporally the problem is disabling the Display Power Management Signaling (DPMS) on XServer, but It works only to the current session.

    xset -dpms; xset s off
    
  • you can make it permanent:

    nano ~/.config/autostart/screensaver-settings.desktop
    

    with this inside:

    [Desktop Entry]
    Type=Application
    Name=screensaver
    Comment=Set timeout of the screen saver to no not doing this!
    Exec=xset -dpms; xset s off
    

    make it executable with:

    chmod +x ~/.config/autostart/screensaver-settings.desktop
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Thank you @joekamprad

    I don’t know if we can mark this post as solved, but this workaround did that the problem not occurs again.

  • this is not the solution, it is only a workaround… but it solves your problem ;)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

Posts 16Views 223
Log in to reply