• pkexec thunar, not working properly.


    Hi,

    When I execute the command “pkexec thunar” I got this :

    Thunar: Failed to initialize Xfconf: Using X11 for dbus-daemon autolaunch was disabled at compile time, set your DBUS_SESSION_BUS_ADDRESS instead
    

    Thunar is hoppening with a minimal window size and don’t remember my settings. By closing thunar I got this :

    (thunar:1490): GLib-GObject-WARNING **: invalid (NULL) pointer instance
    
    (thunar:1490): GLib-GObject-CRITICAL **: g_signal_handler_disconnect: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
    

    I’m starting xfce4 with ~/.xinitrc and bash_profile :

    #!/bin/sh
    
    userresources=$HOME/.Xresources
    usermodmap=$HOME/.Xmodmap
    sysresources=/etc/X11/xinit/.Xresources
    sysmodmap=/etc/X11/xinit/.Xmodmap
    
    # merge in defaults and keymaps
    
    if [ -f $sysresources ]; then
    
    
    
    
    
    
    
        xrdb -merge $sysresources
    
    fi
    
    if [ -f $sysmodmap ]; then
        xmodmap $sysmodmap
    fi
    
    if [ -f "$userresources" ]; then
    
    
    
    
    
    
    
        xrdb -merge "$userresources"
    
    fi
    
    if [ -f "$usermodmap" ]; then
        xmodmap "$usermodmap"
    fi
    
    # start some nice programs
    
    if [ -d /etc/X11/xinit/xinitrc.d ] ; then
     for f in /etc/X11/xinit/xinitrc.d/?*.sh; do
      [ -x "$f" ] && . "$f"
     done
     unset f
    fi
    
    #twm &
    #xclock -geometry 50x50-1+1 &
    #xterm -geometry 80x50+494+51 &
    #xterm -geometry 80x20+494-0 &
    #exec xterm -geometry 80x66+0+0 -name login
    exec startxfce4
    
    #
    # ~/.bash_profile
    #
    
    [[ -f ~/.bashrc ]] && . ~/.bashrc
    
    if [ -z "$DISPLAY" ] && [ -n "$XDG_VTNR" ] && [ "$XDG_VTNR" -eq 1 ]; then
       startx -- -keeptty -nolisten tcp > /tmp/xsession-errors 2>&1
    fi
    

    What’s wrong ?

    Thanks.

  • I could be wrong here, but I don’t know if Thunar supports the pkexec commnad. If I remember correctly, @fernandomaroto ran into a similar problem with it awhile ago…

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO: https://rebornos.wordpress.com

    Friend's Website: http://nwg.pl

  • hehehe… I was wrong here in my assumption😄. Sorry about that. I just installed thunar out myself to see and you were right. It is supposed to work. I’ll be back when I actually have something helpful to add!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO: https://rebornos.wordpress.com

    Friend's Website: http://nwg.pl

  • Don’t worry…

    Yes, the /usr/share/polkit-1/actions/xorg.xfce.thunar.policy is installed by default for Thunar to work with :

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE policyconfig PUBLIC
     "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
     "http://www.freedesktop.org/standards/PolicyKit/1/policyconfig.dtd">
    <policyconfig>
    
      
    
     <vendor>Thunar</vendor>
     <vendor_url>http://xfce.org/</vendor_url>
     <icon_name>system-file-manager</icon_name>
    
    
     <action id="org.xfce.thunar">
     
     <description>Run Thunar as root</description>
     <description xml:lang="ar">شغل ثونار كجذر</description>
     <description xml:lang="ast">Executar Thunar como root</description>
     <description xml:lang="bg">Стартирай Thunar като администратор</description>
     <description xml:lang="ca">Executa Thunar com a root</description>
     <description xml:lang="cs">Spustit Thunar jako root</description>
     <description xml:lang="da">Kør Thunar som root</description>
     <description xml:lang="de">Thunar als Systemverwalter starten</description>
     <description xml:lang="el">Εκτέλεση Thunar ως διαχειριστής</description>
     <description xml:lang="en_AU">Run Thunar as root</description>
     <description xml:lang="en_GB">Run Thunar as root</description>
     <description xml:lang="es">Iniciar Thunar como superusuario</description>
     <description xml:lang="eu">Exekutatu Thunar root gisa</description>
     <description xml:lang="fi">Käynnistä Thunar pääkäyttäjän oikeuksin.</description>
     <description xml:lang="fr">Lancer Thunar en tant que root</description>
     <description xml:lang="gl">Executar Thunar como administrador</description>
     <description xml:lang="he">הפעל את Thunar כמשתמש על</description>
     <description xml:lang="hr">Pokreni Thunar kao root korisnik</description>
     <description xml:lang="hu">Thunar futtatása rendszergazdaként</description>
     <description xml:lang="id">Jalankan Thunar sebagai root</description>
     <description xml:lang="is">Keyra Thunar sem kerfisstjóri (root)</description>
     <description xml:lang="it">Esegui Thunar come amministratore</description>
     <description xml:lang="ja">root で Thunar を起動</description>
     <description xml:lang="kk">Thunar-ды әкімші ретінде орындау</description>
     <description xml:lang="ko">Root 권한으로 Thunar 작동</description>
     <description xml:lang="lt">Vykdyti Thunar administratoriaus teisėmis</description>
     <description xml:lang="ms">Jalankan Thunar sebagai root</description>
     <description xml:lang="nb">Kjør Thunar som root</description>
     <description xml:lang="nl">Thunar draaien met rootbevoegdheid</description>
     <description xml:lang="nn">Køyr Thunar som administrator</description>
     <description xml:lang="oc">Aviar Thunar en tant que root</description>
     <description xml:lang="pl">Uruchom Thunar jako root</description>
     <description xml:lang="pt">Executar Thunar como root</description>
     <description xml:lang="pt_BR">Rodar Thunar como superusuário</description>
     <description xml:lang="ro">Pornește Thunar ca root</description>
     <description xml:lang="ru">Запустить Thunar от суперпользователя</description>
     <description xml:lang="sk">Spustiť Thunar ako správca</description>
     <description xml:lang="sr">Покрени Тунара са кореним овлашћењима</description>
     <description xml:lang="sv">Kör Thunar som root</description>
     <description xml:lang="th">เรียกทำงาน Thunar ในฐานะ root</description>
     <description xml:lang="tr">Thunar'ı root olarak çalıştır</description>
     <description xml:lang="uk">Запустити Thunar з правами суперкористувача</description>
     <description xml:lang="zh_CN">以 root 身份运行 Thunar</description>
     <description xml:lang="zh_TW">以 root 身份執行 Thunar</description>
     <message>Authentication is required to run Thunar as root.</message>
     <message xml:lang="ar">التحقق مطلوب لتشغيل ثونار كجذر</message>
     <message xml:lang="ast">Ríquese l'autenticación pa executar Thunar como root.</message>
     <message xml:lang="bg">Изисква се удостоверяване за да стартирате Thunar като администратор</message>
     <message xml:lang="ca">Cal autenticació per executar Thunar com a root.</message>
     <message xml:lang="cs">Pro spuštění aplikace Thunar jako root se vyžaduje autentizace.</message>
     <message xml:lang="da">Der kræves godkendelse for at køre Thunar som root.</message>
     <message xml:lang="de">Legitimierung wird benötigt, um Thunar als Systemverwalter zu starten.</message>
     <message xml:lang="el">Απαιτείται πιστοποίηση για εκτέλεση του Thunar ως διαχειριστής.</message>
     <message xml:lang="en_AU">Authentication is required to run Thunar as root.</message>
     <message xml:lang="en_GB">Authentication is required to run Thunar as root.</message>
     <message xml:lang="es">Es necesario autentificarse para iniciar Thunar como superusuario.</message>
     <message xml:lang="eu">Autentifikazio beharrezkoa da Thunar root gisa exekutatzeko</message>
     <message xml:lang="fi">Jotta Thunar voidaan käynnistää pääkäyttäjän oikeuksin, todennus tarvitaan.</message>
     <message xml:lang="fr">Une authentification est requise pour lancer Thunar en tant que root.</message>
     <message xml:lang="gl">Requírese autenticación para executar Thunar como administrador</message>
     <message xml:lang="he">נדרש אימות כדי להפעיל את Thunar כמשתמש על.</message>
     <message xml:lang="hr">Potrebna je provjera za pokretanje Thunara kao root.</message>
     <message xml:lang="hu">A Thunar rendszergazdai futtatásához hitelesítés szükséges.</message>
     <message xml:lang="id">Otentikasi diperlukan untuk menjalankan Thunar sebagai root.</message>
     <message xml:lang="is">Auðkenningar er krafist til að keyra Thunar sem kerfisstjóri (root)</message>
     <message xml:lang="it">Per eseguire Thunar come amministratore è richiesta l'autenticazione</message>
     <message xml:lang="ja">root で Thunar を起動するには認証が必要です。</message>
     <message xml:lang="kk">Thunar-ды әкімші ретінде орындау үшін аутентификация керек.</message>
     <message xml:lang="ko">Root 권한으로 Thunar를 작동하려면 인증이 필요합니다.</message>
     <message xml:lang="lt">Thunar vykdymui administratoriaus teisėmis, reikalingas tapatybės nustatymas.</message>
     <message xml:lang="ms">Pengesahihan diperlukan untuk jalankan Thunar sebagai root.</message>
     <message xml:lang="nb">Identitetsbekreftelse kreves for å kjøre Thunar som root.</message>
     <message xml:lang="nl">Authenticatie is vereist om Thunar met rootbevoegdheid te draaien.</message>
     <message xml:lang="nn">Autentisering krevst for å køyra Thunar som administrator</message>
     <message xml:lang="oc">Una autentificacion es requesida per aviar Thunar en tant que root.</message>
     <message xml:lang="pl">Wymagane jest uwierzytelnienie, aby uruchomić program Thunar w trybie administratora.</message>
     <message xml:lang="pt">Autenticação necessária para executar Thunar como root.</message>
     <message xml:lang="pt_BR">Autenticação é requerida para rodar Thunar como superusuário.</message>
     <message xml:lang="ro">Pentru a porni Thunar ca root este nevoie de autentificare.</message>
     <message xml:lang="ru">Требуется аутентификация для запуска Thunar от суперпользователя</message>
     <message xml:lang="sk">Na spustenie Thunaru ako správca je potrebné overenie totožnosti.</message>
     <message xml:lang="sr">Потребна је потврда овлашћења ради покретања Тунара под кореним овлашћењима</message>
     <message xml:lang="sv">Autentisering krävs för att köra Thunar som root.</message>
     <message xml:lang="th">ต้องยืนยันตัวบุคคลก่อนเรียกทำงาน Thunar ในฐานะ root</message>
     <message xml:lang="tr">Thunar'ı root olarak çalıştırmak için kimlik doğrulaması gereklidir</message>
     <message xml:lang="uk">Вимагається розпізнавання для запуску Thunar з правами суперкористувача.</message>
     <message xml:lang="zh_CN">以 root 身份运行 Thunar 需要进行身份验证。</message>
     <message xml:lang="zh_TW">要以 root 身份執行 Thunar 需要認證。</message>
     <defaults>
     <allow_any>no</allow_any>
     <allow_inactive>auth_admin</allow_inactive>
     <allow_active>auth_admin</allow_active>
     </defaults>
     <annotate key="org.freedesktop.policykit.exec.path">/usr/bin/thunar</annotate>
     <annotate key="org.freedesktop.policykit.exec.allow_gui">true</annotate>
     </action>
    
    </policyconfig>
    

    Now, why he doesn’t properly… I’m still surching.

  • @sushi maybe you need pkexec dbus-launch thunar
    i use an alias here in my bash to run as pkexec (workaround), although i must admit i dont use pkexec here too much…

    alias pkexec='pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY'
    

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • Fernando, with ‘pkexec dbus-launch thunar’ it doesn’t start at all.

    Pkexec = Policykit is the way to go, gksu is obsolete for GUI interfaces.

    With geany, pkexec works well. I will have a look at the alias but anyway, Thunar should be able to work without.
    I’m still looking for a solution…

  • I still don’t have any solution but I found some usefull informations about and it seems to be a bug (with the Debian link which explains it) :

    link text

    And an Archlinux report :

    link text

    Here the dbus address seems to be fine :

    env | grep -i dbus
    DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
    

    And systemd too :

    systemctl status dbus.service
    ● dbus.service - D-Bus System Message Bus
       Loaded: loaded (/usr/lib/systemd/system/dbus.service; static; vendor preset: disabled)
       Active: active (running) since Tue 2017-10-24 07:29:40 CEST; 1h 30min ago
         Docs: man:dbus-daemon(1)
     Main PID: 636 (dbus-daemon)
        Tasks: 1 (limit: 4915)
       CGroup: /system.slice/dbus.service
               └─636 /usr/bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation
    
    oct 24 07:29:40 Cxxxxx systemd[1]: Started D-Bus System Message Bus.
    oct 24 07:29:40 Cxxxxx dbus[636]: [system] Activating via systemd: service name='org.freedesktop.PolicyKit1' unit='polkit.service'
    oct 24 07:29:41 Cxxxxx dbus[636]: [system] Successfully activated service 'org.freedesktop.PolicyKit1'
    oct 24 07:29:55 Cxxxxx dbus[636]: [system] Activating via systemd: service name='org.freedesktop.UDisks2' unit='udisks2.service'
    oct 24 07:29:55 Cxxxxx dbus[636]: [system] Successfully activated service 'org.freedesktop.UDisks2'
    oct 24 07:29:55 Cxxxxx dbus[636]: [system] Activating via systemd: service name='org.freedesktop.UPower' unit='upower.service'
    oct 24 07:29:56 Cxxxxx dbus[636]: [system] Successfully activated service 'org.freedesktop.UPower'
    
  • I can confirm i have the exact same issue, has anybody found a solution yet?

  • Thank for the reply.

    Not yet, look at the links posted in my last message.

  • It’s a confirmed bug :

    link text

    Follow and see…

    P.S. @ fernando :

    Opening a root Thunar
    
    Name: Open a root Thunar here
    Command: gksu thunar %f
    File pattern: *
    Appears if selection contains: Directories
    
    **Note: Some distributions no longer include gksu. Use pkexec instead.**
    

    link text

  • Thanks for that link, we just have to wait till they fix it upstream.

  • Hi,

    The problem is solved without a Thunar upgrade and I don’t know the axact reason why, probably because of an other package update.

    Anyway, pkexec thunar is working without errors and keeps the user settings.

  • Yay !!! That is great to hear😀.

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO: https://rebornos.wordpress.com

    Friend's Website: http://nwg.pl

  • Thanks for the update, time to test this once I get home.

  • I think that the reason is here :

    [2017-11-03 19:00] [ALPM] upgraded dbus (1.10.24-1 -> 1.12.0-1)
    [2017-11-03 19:00] [ALPM] upgraded lib32-dbus (1.10.24-1 -> 1.12.0-1)
    
properly19 thunar8 pkexec4 Posts 15Views 1447
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.