• No me funciona mongodb


    He instalado mongodb desde la herramienta add/remove software, sin embargo ahora quiero comenzar a utilizar mongo, y he seguido este tutorial: https://guiadev.com/tutorial-mongodb/#Instalando_MongoDB

    Pero al parecer no funciona el comando : sudo service mongod start
    Probé también sólo con: service mongod start y sigue sin funcionar

    ¿Alguien sabe donde puede estar el problema?

    Al hacer un mongo --version obtengo los siguientes datos:

    MongoDB shell version v3.4.9
    git version: 876ebee8c7dd0e2d992f36a848ff4dc50ee6603e
    OpenSSL version: OpenSSL 1.1.0f  25 May 2017
    allocator: tcmalloc
    modules: none
    build environment:
        distarch: x86_64
        target_arch: x86_64
    
  • @PedroFumero

    O Antergos usa o systemd. Portanto o comando é:

    sudo systemctl start mongod

    Deve também executar este comando:

    sudo systemctl enable mongod

    Assim não terá de fazer start sempre que reiniciar o computador. As minhas desculpas por responder em Português.

  • @Krugar He intentado hacer lo que me indicas, pero no me ha funcionado. La terminal me arroja el siguiente resultado:

    [[email protected] ~]$ sudo systemctl start mongod
    Failed to start mongod.service: Unit mongod.service not found.
    [[email protected] ~]$ sudo systemctl enable mongod
    Failed to enable unit: Unit file mongod.service does not exist.
    
  • @PedroFumero

    Parece que o serviço mudou de nome. Faça o seguinte:

    systemctl list-unit-files | grep mongo

    Isto vai mostrar qual é o nome do serviço. Depois:

    sudo systemctl enable <nome-do-serviço>
    sudo systemctl start <nome-do-serviço>

  • @Krugar Parece que ahora si funciona, te coloco una captura para que puedas ver el registro de la terminal 0_1507825496443_Screenshot from 2017-10-12 12-23-38.png

    Entonces cada vez que quiera utilizar mongodb luego de encender la pc debo iniciarlo con sudo systemctl start mongodb.service

  • Não. O enable iniciará o serviço automaticamente sempre que iniciar o pc.

    Have fun!

  • @Krugar Ahora entiendo. Muchas gracias!

funciona4 mongodb1 Posts 7Views 189
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.