• Stop Job is running running for


    Hello dear Antergos community,

    i have following problem:

    when i reboot or shutdown my gnome system i often get a stop job is running message . So it takes about 1min 30 secs sometimes longer for the system to shutdown/reboot.
    Now I have googled the problem and it seems I am not the only one facing this problem.
    In the arch wiki it tells me to follow the instructions of this link :
    https://freedesktop.org/wiki/Software/systemd/Debugging/#shutdowncompleteseventually.

    I cant seem to understand how to boot with the debug options mentioned there.
    Can someone please help me out and tell me what to do.
    Thanks.

  • systemd.log_level=debug systemd.log_target=kmsg log_buf_len=1M printk.devkmsg=on enforcing=0
    

    needs to be added to kernel parameters at boot see:

    https://wiki.archlinux.org/index.php/Kernel_parameters
    then reboot with the parameters…

    create the script by:

    sudo nano /usr/lib/systemd/system-shutdown/debug.sh
    

    put thius inside the file:

    #!/bin/sh
    mount -o remount,rw /
    dmesg > /shutdown-log.txt
    mount -o remount,ro /
    

    save with [Ctrl+X]
    make it executable by:

    sudo chmod +x /usr/lib/systemd/system-shutdown/debug.sh

    and reboot
    then you will get the report under /shutdown-log.txt
    copy it to your home by:

    cp /shutdown-log.txt ~/shutdown-log.txt
    

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • and do not forget to remove both after you get what you need:

    sudo rm /usr/lib/systemd/system-shutdown/debug.sh
    

    and delete the kernel parameters too…

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • I think the easiest is to edit system.conf

    sudo gedit /etc/systemd/system.conf

    remove the # from these lines (you may have to reboot to activate these settings)

    DumpCore=no
    DefaultTimeoutStartSec=05s
    DefaultTimeoutStopSec=05s

  • Thanlks for the help.

    I uploaded the shutdown-log.txt file but I cant seem to find a timeout entry maybe I did something wrong.

    I added the Kernel Parameters like this in terminal:

    sudo nano /etc/default/grub
    
    GRUB_CMDLINE_LINUX_DEFAULT="quiet systemd.log_level=debug systemd.log_target=kmsg log_buf_len=1M printk.devkmsg=on enforcing=0"
    

    Then I saved it and regenereated grub with:

    # grub-mkconfig -o /boot/grub/grub.cfg
    

    Then I created the debug.sh file like instructed.

    When I rebooted a timeout came.

    But in the created log there is no timeout to be seen.

    Hmm I cant seem to upload the zip file. I dont have enough privileges.

    So I uploaded it on Dropbox I hope that is ok.

    https://www.dropbox.com/s/i724slkymo6rkov/shutdown-log.zip?dl=0

running14 stop12 job2 Posts 5Views 554
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.