• Updating Antergos from 17.8 - must have missed a step?

    Hey, I am new to Antergos, but I think it is awesome. I have never used any branch of Arch, so please excuse my ignornace. I went to update today, and I tried

    pacman -Syu

    I was then prompted to update packages, which I did.

    If I now try (again):

    pacman -Syu

    I get:

    [[email protected] ~]$ sudo pacman -Syu
    :: Synchronizing package databases...
     antergos is up to date
     core is up to date
     extra is up to date
     community is up to date
     multilib is up to date
    :: Starting full system upgrade...
     there is nothing to do

    However, I still seem to be on version 17.8

    [[email protected] ~]$ cat /etc/*-release
    Antergos Linux release 17.8 (ISO-Rolling)
    NAME="Antergos Linux"
    PRETTY_NAME="Antergos Linux"

    Any tips on how I can get to the latest release?

    Thank you!

  • @YeeP Ha! Interesting. Never checked it before.

    I think Antergos simply doesn’t update release number in an installed system. Keeps the version of the ISO it was originally installed from. Just guessing.

    Mine is still at 17.1, though the system is upgraded almost hourly:

    └─> cat /etc/arch-release
    Antergos Linux release 17.1 (ISO-Rolling)

    There’s nothing to worry about.

  • @YeeP so you download the ISO from sourceforge? (17.8)

  • @joekamprad Yes I did, approximately 1 week ago.

    @just thanks for the tip, good to know.

  • As you installed without issue, it will be o.k. to use the 17.8 ISO, but better take the latest ones. Sourceforge download is not up to date. You will get the latest one over http://antergos.com

  • @YeeP said in Updating Antergos from 17.8 - must have missed a step?:

    cat /etc/*-release

    I have never installed arch here, only antergos and here is the output:

    NAME="Arch Linux"
    PRETTY_NAME="Arch Linux"
  • Guys, any text may be put in the /etc/arch-release and /usr/lib/os-release files. It is never changed on true Arch systems.

    Other Arch derivatives may vary two files’ content from time to time, but Arch doesn’t do it.

  • @joekamprad I did try that, but every time I tried to download 17.9, I would get a database error on the website. It was giving the error for at least 3 days, so I decided to look elsewhere for a download.

  • @just I tried to chat you for not going offtopic here, but you have some config in your account that prevent me from doing it… My screenfetch also show Arch, and not Antergos as some other users, where does screenfetch take the config from? (just ou of curiosity, since is not a problem here)

    @YeeP Are trying to download from sourceforge?
    I sucessfully downloaded the 17-10 version before yesterday if i’m not mistaken from antergos site.

  • @fernandomaroto My download is complete and working. I also confirmed that the antergos site download was working yesterday, but it was not early last week.

  • @fernandomaroto said in Updating Antergos from 17.8 - must have missed a step?:


    where does screenfetch take the config from?

    screenfetsh is a bash script. You may read it yourself.

    For Arch-based distros it gets some info from /etc/os-release, which is the symlink to /usr/lib/os-release. Yours has “Arch Linux”, so screenfetsh reports “Arch Linux”. On Antergoses with “Antergos” in /usr/lib/os-release screenfetch reports “Antergos”.


  • @YeeP
    You could do
    sudo pacman -Syyu
    Then could you show the output of
    pacman -Q linux
    (or linux-lts if you are using LTS kernel).

    I have the same 17.8 in /etc/os-release, so no worries mate.

  • @YeeP actual version of the ISO is 17.10 b.t.w. if direct ISO download do not work, you can try the torrent download too ;)

  • @joekamprad Thank you. I have seen that actually, but I was talking in past tense. When I tried to download 17.9, previously, there was a database error on the website. So, I went to sourcefourge and downloaded the 17.8 ISO.

    @manuel Looks like that is for the linux kernel version (thanks!):

    [[email protected] ~]$ pacman -Q linux
    linux 4.13.4-1
  • @YeeP
    I have linux 4.13.5-1 now ;)

updating31 step4 17.82 missed1 Posts 15Views 1558
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.