• Wireless not working even with right driver installed


    Hello antergos community i have a problem with my bcm4322 it does not want to work on anthergos but it does work on windows,debian,manjaro,osx.
    i have this kernel: 4.13.4-1-ARCH and i am using this firmware form the aur : b43-frimware,b43-fwcutter.
    Here is my lspci -v :

    03:00.0 Network controller: Broadcom Limited BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)
            Subsystem: Broadcom Limited BCM4322 802.11a/b/g/n Wireless LAN Controller
            Flags: bus master, fast devsel, latency 0, IRQ 11
            Memory at e2400000 (64-bit, non-prefetchable) [size=16K]
            Capabilities: <access denied>
            Kernel modules: ssb
    

    and here is my ifconfig :
    https://pastebin.com/91yUJKQA

  • @LostInNovo

    Which driver installed, maybe this one ???

    yaourt -S broadcom-wl-dkms
    

    Autodidacta en la VIDA …y en Linux, también.

  • do i need to reboot for it to work

  • @LostInNovo said in Wierless not working even with right driver installed:

    do i need to reboot for it to work

    Of course yes !!!

    Autodidacta en la VIDA …y en Linux, también.

  • still does not work

  • @LostInNovo said in Wierless not working even with right driver installed:

    still does not work

    then you can delete the previous drivers and leave only broadcom-wl-dkms

    and them

    reboot

    Autodidacta en la VIDA …y en Linux, también.

  • still does not work with the package you have specified

  • what about it

  • i have removed all te packages using yaourt what package is my best bet

  • @LostInNovo Have you tried the Arch forum solution that’s linked in @judd 's link? It seems really similar to your problem and it was solved by the steps described.

    Thinkpad E570 Intel core i5 (Kaby lake)
    8 GB RAM
    256 GB SSD + 1 TB HDD
    Intel HD Graphics

  • May try also booting with linux-lts Kernel.
    As you say it works under manjaro, can be caused by the fact they use older kernel.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • it is still not working may you please copy over the answer i can not find it sorry

  • the solution in the link: https://forum.antergos.com/topic/5558/wifi-not-working-bcm4322-on-hp-6735s is about the user having an issue with permission for networkmanager… as we at Antergos have this solved by using the wheel group this would not solve the problem, only may be if you have changed something related to permissions and groups, like creating a new user e.t.c.

    What you can try is to get to know if networkmanager is working properly:

    systemctl status NetworkManager.service
    should look like this:

       Active: active (running) since Tue 2017-10-10 22:49:31 CEST; 21min ago
         Docs: man:NetworkManager(8)
     Main PID: 410 (NetworkManager)
        Tasks: 3 (limit: 4915)
       CGroup: /system.slice/NetworkManager.service
               └─410 /usr/bin/NetworkManager --no-daemon
    
    

    check your permissions:
    (as your user [not root])

    groups should give you this:
    wheel users

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • ● NetworkManager.service - Network Manager
    Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
    Active: active (running) since Tue 2017-10-10 22:21:23 BST; 1min 50s ago
    Docs: man:NetworkManager(8)
    Main PID: 400 (NetworkManager)
    Tasks: 3 (limit: 4915)
    CGroup: /system.slice/NetworkManager.service
    └─400 /usr/bin/NetworkManager --no-daemon

    Oct 10 22:21:37 blamethepc NetworkManager[400]: <info> [1507670497.4201] dhcp4 (enp0s26u1u2): state changed unknown -> bound
    Oct 10 22:21:37 blamethepc NetworkManager[400]: <info> [1507670497.4244] device (enp0s26u1u2): state change: ip-config -> ip-check (reason ‘none’, internal state 'm
    Oct 10 22:21:37 blamethepc NetworkManager[400]: <info> [1507670497.4261] device (enp0s26u1u2): state change: ip-check -> secondaries (reason ‘none’, internal state
    Oct 10 22:21:37 blamethepc NetworkManager[400]: <info> [1507670497.4271] device (enp0s26u1u2): state change: secondaries -> activated (reason ‘none’, internal state
    Oct 10 22:21:37 blamethepc NetworkManager[400]: <info> [1507670497.4277] manager: NetworkManager state is now CONNECTED_LOCAL
    Oct 10 22:21:37 blamethepc NetworkManager[400]: <info> [1507670497.4863] manager: NetworkManager state is now CONNECTED_SITE
    Oct 10 22:21:37 blamethepc NetworkManager[400]: <info> [1507670497.4866] policy: set ‘Wired connection 2’ (enp0s26u1u2) as default for IPv4 routing and DNS
    Oct 10 22:21:37 blamethepc NetworkManager[400]: <info> [1507670497.5028] dns-mgr: Writing DNS information to /usr/bin/resolvconf
    Oct 10 22:21:38 blamethepc NetworkManager[400]: <info> [1507670498.4691] device (enp0s26u1u2): Activation: successful, device activated.
    Oct 10 22:21:39 blamethepc NetworkManager[400]: <info> [1507670499.5852] manager: NetworkManager state is now CONNECTED_GLOBAL

  • Btw im am still not getting it
    could someone please give me a list of commands to do
    such as :

    1. install this
    2. mod something
    3. do something else

    Sorry for being such an annoyance

  • Long one:

    get the right driver for your device there are two different ones for broadcom wireless:

    lspci -vnn -d 14e4:

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • [[email protected] ~]$ lspci -vnn -d 14e4:
    03:00.0 Network controller [0280]: Broadcom Limited BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)
    Subsystem: Broadcom Limited BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:04b1]
    Flags: bus master, fast devsel, latency 0, IRQ 11
    Memory at e2400000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel modules: ssb

  • @LostInNovo said in Wireless not working even with right driver installed:

    14e4:432b

    14e4:432b partially supported …

    b43 is the driver you need …this one is the included to the kernel one … as the other one seems not to work so you need the firmware installed:

    yaourt -S b43-firmware

    then blacklist the non needed driver by:
    sudo nano /etc/modprobe.d/blacklist.conf
    put this line inside:

    install brcm80211 /bin/false

    save with Ctlr+X

    uninstall the broadcom-wl driver

    sudo pacman -R broadcom-wl
    or if it is the dksm one
    sudo pacman -R broadcom-wl-dkms

    reboot system…

    If this do not help try again to take the other one:
    sudo pacman -S broadcom-wl
    But this time blacklist the kernel drivers:

    sudo nano /etc/modprobe.d/blacklist.conf

    add this line:
    install b43 /bin/false

    so that you have both inside and it looks like this:

    install brcm80211 /bin/false
    install b43 /bin/false
    

    save again and reboot…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • This post is deleted!
Posts 58Views 700
Log in to reply