• Problemas con el grub. Me carga directamente Windows 10 (portátil HP)


    @manuel

    Hi.

    Yeah, I’m sure that there is no Customized Boot. There is a Boot Option, where there is an UEFI Boot Order, but with that, I really can do anything except change the order of the boot between OS boot Manager and other devices as the USB or the DVD.

    In OS boot Manager option I check it, just in case it would allow me choose something, opening a secondary tab or something like that, but I can not to do nothing.

    My laptop is a HP Envy 17-j061ss.

    Regards.

  • @carlospj
    The HP laptop seems to be a bit tricky, since all things basically are already OK in your machine, but HP allows to boot only Windows.

    I have one more idea to go. Could you show the output of the following commands:

    mount /dev/sda2 /mnt
    find /mnt -name '*.efi' -exec ls -l {} \;
    
    

    EDIT: When you boot, if you press F9 key, what kind of menu do you get?

  • @manuel

    This is the output of the commands:

    [[email protected] antergos]# mount /dev/sda2 /mnt
    [[email protected] antergos]# find /mnt -name '*.efi' -exec ls -l {} \;
    -rwxr-xr-x 1 root root 1056672 Sep 19 01:34 /mnt/EFI/Microsoft/Boot/memtest.efi
    -rwxr-xr-x 1 root root 1224608 Sep 19 01:30 /mnt/EFI/Microsoft/Boot/bootmgfw.efi
    -rwxr-xr-x 1 root root 1209752 Sep 19 02:15 /mnt/EFI/Microsoft/Boot/bootmgr.efi
    -rwxr-xr-x 1 root root 1224608 Sep 19 01:30 /mnt/EFI/Boot/bootx64.efi
    -rwxr-xr-x 1 root root 122880 Oct 11 18:00 /mnt/EFI/antergos_grub/grubx64.efi
    -rwxr-xr-x 1 root root 122880 Oct 12 18:36 /mnt/EFI/grub/grubx64.efi
    -rwxr-xr-x 1 root root 122880 Oct 12 17:44 /mnt/EFI/antergos_grub_ez0c/grubx64.efi
    -rwxr-xr-x 1 root root 443904 Oct 12 19:16 /mnt/EFI/HP/BIOSUpdate/CryptRSA.efi
    -rwxr-xr-x 1 root root 259072 Oct 12 19:16 /mnt/EFI/HP/BIOSUpdate/CryptRSA32.efi
    -rwxr-xr-x 1 root root 850480 Oct 12 19:16 /mnt/EFI/HP/BIOSUpdate/HpBiosUpdate.efi
    -rwxr-xr-x 1 root root 820752 Oct 12 19:16 /mnt/EFI/HP/BIOSUpdate/HpBiosUpdate32.efi
    

    When I press F9 I get a menu with all the boot options (Antergos, Windows (Os Boot Manager), DVD, USB) and I can choose wherever I want. It’s the only way I can boot Antergos.

  • @carlospj

    There are still some things that can be done, in order of preference:

    1. Update HP’s firmware. A newer version might allow you to change the boot order. But be absolutely sure you have exactly the correct version for your machine, otherwise big problems follow!
    2. Use Windows bcdedit to make things work. Something like this might work (look at Microsoft help to make sure):
    bcdedit /set {bootmgr} path \EFI\grub\grubx64.efi
    
    1. You could try to use efibootmgr to change the boot order (man efibootmgr). May not work in HP though.
    2. If the items above do not help, then the last thing to try is:
    mount /dev/sda2 /mnt
    mv /mnt/EFI/Microsoft/Boot/bootmgfw.efi /mnt/EFI/Microsoft/bootmgfw.efi 
    cp /mnt/EFI/grub/grubx64.efi /mnt/EFI/Microsoft/Boot/bootmgfw.efi
    
    

    If you now can boot to Antergos, you probably need to run ‘grub-mkconfig -o /boot/grub/grub.cfg’ again and reboot.
    If it fails to find Windows to boot, then write the following to /boot/grub/custom.cfg:

    menuentry "Windows" {
      set file=/EFI/Microsoft/bootmgfw.efi   # or /EFI/Microsoft/Boot/bootmgfw.efi if you didn't move it
      insmod fat
      search --set=root --file $file
      chainloader $file
    }
    
    

    Please report your results. If none of the above work, then I probably don’t have any new ideas, but maybe small variations to the above.
    Hopefully this helps!

    EDIT: you probably want to create a rescue disk for Windows, and Antergos USB installer stick before making any of the changes above!

  • @manuel

    Hi manuel. Here I go again, with the results. And there are good news :)

    1. When I checked if my HP could have a Customized Boot, the first thing I did was update the “BIOS” to the newest version.
    2. It didn’t work
    3. The first things I tried with this boot problem was the efibootmgr command. With this command it changes the order boot but when you reboot, the order is again the same (Windows first). It’s like the changes were not saved.
    4. IT WORKED! FINALLY WORKED! 😀
      With this specific commands, I reboot and boot automatically to Antergos grub. How fails to find Windows, I added what you said to /boot/grub/custom.cfg and it worked too.
      Now my HP boots to Antergos grub and I have Windows option as well! Honestly, I had lost all hope but you made it work. You don’t know how I really really appreciate your help. Thank you very much!!!
      Of course, thank you too to other people, in this post and the previous post that tried to help me.
      Por supuesto, gracias a los demás que han tratado de ayudarme, tanto en este post como en el anterior.

    PD: I think that I should edit the firts message to say that this post have the most probably anwsers to the dual boot problem with Windows but warning that my issue was tricky because I have a HP machine, that it is problematic with dual boot issues. I’m sure there are many people with the same problem because they have a HP laptop.
    Creo que debería de editar el primer mensaje e incluso el título para decir que el post posiblemente resolverá la mayoría de los problemas que tenga la gente con el dual boot con Windows pero advirtiendo que en mi caso ha sido especialmente complicado por tener un portátil HP, que son problemáticos con el dual boot. Seguro que hay gente que le pasa lo mismo por tener un HP.

  • @carlospj

    Thanks, it was a pleasure to be of help from my part, and really nice to hear that it is working now! :)

    If you feel this thread is now solved, please mark it as such.

    If you edit the first post, you might remind that a similar solution may help also others, but there may be minor variations in the solution depending on how the system is installed, and depending also the machine model.

  • @manuel

    I’m going to mark as solved the thread. Only one more thing.

    When I saw that this commands fix the problem, I format the laptop and I made a new installation of Windows and Antergos.
    In this scenario, only with the using the final commands (point 4) happened an issue. The second command shows me that the directory didn’t exist or something like that.

    As the instalattion was new, I figured that some command that I used in other tries was missing.
    So, searching on the thread, I supposed that using this series of commands it would solved:

    mount /dev/sda5 /mnt
    mkdir -p /mnt/boot/efi  # editar: agregó -p
    mount /dev/sda2 /mnt/boot/efi
    arch-chroot /mnt
    pacman -S --needed efibootmgr  # no está seguro de que tiene que hacer esto
    grub-mkconfig -o /boot/grub/grub.cfg
    grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=grub
    

    And then, continuing with this ones:

    mount /dev/sda2 /mnt
    mv /mnt/EFI/Microsoft/Boot/bootmgfw.efi /mnt/EFI/Microsoft/bootmgfw.efi 
    cp /mnt/EFI/grub/grubx64.efi /mnt/EFI/Microsoft/Boot/bootmgfw.efi
    

    With that, the issue was fixed.

    Again, thank you very much for all your help!

    Regards.

Posts 47Views 9708
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.