• Problemas con el grub. Me carga directamente Windows 10 (portátil HP)


    @carlospj
    ¡Hola!
    Gracias por la información. Ahora creo que podemos hacer que funcione.
    Primero comprueba lo que hay en /boot/efi de /dev/sda5:

    umount /mnt
    mount /dev/sda5 /mnt
    ls -la /mnt/boot/efi
    

    Sólo si el último comando (ls -la) no muestra archivos (o da un error que es bueno), puede pasar a los siguientes comandos:

    mkdir -p /mnt/boot/efi  # editar: agregó -p
    mount /dev/sda2 /mnt/boot/efi
    arch-chroot /mnt
    pacman -S --needed efibootmgr  # no está seguro de que tiene que hacer esto
    grub-mkconfig -o /boot/grub/grub.cfg
    grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=grub
    

    Y si llegas tan lejos sin problemas, debería estar ahora en orden (sin mensajes de error espero)!
    Ahora puedes salir y reiniciar:

    exit
    umount /dev/sda2
    umount /dev/sda5
    reboot
    
  • @manuel

    Hola manuel.

    Respecto al comando ls -la, esto es lo que me muestra. No estoy seguro de si esto quiere decir que hay algo:

    [[email protected] antergos]# mount /dev/sda5 /mnt
    [[email protected] antergos]# ls -la /mnt/boot/efi
    total 8
    drwxr-xr-x 2 root root 4096 Oct 12 17:36 .
    drwxr-xr-x 4 root root 4096 Oct 12 17:43 ..
    
    
  • @carlospj
    Significa que no hay archivos en /boot/efi, y actualmente es bueno. Puede continuar como estaba planeado.

  • @manuel

    Al continuar, me muestra lo siguiente:

    [[email protected] antergos]# mkdir /mnt/boot/efi
    mkdir: cannot create directory ‘/mnt/boot/efi’: File exists
    [[email protected] antergos]#
    
  • @carlospj
    No hay problema, sólo seguir adelante.

    Por cierto, ¿es posible continuar en inglés? Sería mucho más fácil para mí.

  • @manuel

    Aqui te dejo lo siguiente:

    [[email protected] antergos]# mount /dev/sda2 /mnt/boot/efi
    [[email protected] antergos]# arch-chroot /mnt 
    [[email protected] /]# pacman -S --needed efibootmgr
    warning: efibootmgr-15-1 is up to date -- skipping
     there is nothing to do
    [[email protected] /]# grub-mkconfig -o /boot/grub/grub.cfg
    Generating grub configuration file ...
    Found theme: /boot/grub/themes/Antergos-Default/theme.txt
    Found Intel Microcode image
    Found linux image: /boot/vmlinuz-linux
    Found initrd image: /boot/initramfs-linux.img
    Found fallback initramfs image: /boot/initramfs-linux-fallback.img
      WARNING: Failed to connect to lvmetad. Falling back to device scanning.
    grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your device.map.
    done
    [[email protected] /]# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=grub
    Installing for x86_64-efi platform.
    Installation finished. No error reported.
    [[email protected] /]#
    

    En cuanto al ingles, si, podemos continuar en ingles. Si algo no lo entiendo o se me hace dificil expresarlo, te lo comento ;)

  • @carlospj
    Alright.
    Your system may already work, did you reboot?
    If it doesn’t work, I still have something more for you. :)

  • @manuel

    I just reboot and nothing. Still not working jaja

    Pending the following steps :slight_smile:

  • @carlospj

    Lets try to boot Antergos. You need to write a new file to /boot/grub/custom.cfg with the following contents:

    menuentry "Antergos" {
      search --set=root --file /boot/grub/x86_64-efi/grub.efi   # probably not needed
      linux /boot/vmlinuz-linux root=/dev/sda5 rw quiet
      initrd /boot/intel-ucode.img /boot/initramfs-linux.img
    }
    

    You can write the file for example with the following commands:

    mount /dev/sda5 /mnt  # you have done this many times now...
    nano /mnt/boot/grub/custom.cfg
    

    and just write the lines there. When done, just reboot.

  • If that doesn’t work, then I think your EFI path is not correct for your system. But lets wait for your results.

  • @manuel

    When you say “boot Antergos” you mean the ISO o the “real” Antergos?

  • One question: what is your machine model?

  • @carlospj
    I mean real Antergos install, not the ISO.

  • @manuel said in Problemas con el grub. Me carga directamente Windows 10 (Parte 2):

    One question: what is your machine model?

    HP Envy 17

    @manuel said in Problemas con el grub. Me carga directamente Windows 10 (Parte 2):

    @carlospj
    I mean real Antergos install, not the ISO.

    Ok. I will follow the steps and later I will tell you the results.

  • @manuel
    Hi manuel. I have tried what you say but Windows still boot automatically :(

  • @carlospj
    I found two articles about HP laptops:
    https://wiki.archlinux.org/index.php/HP_EliteBook_840_G1#UEFI_Setup
    and a link from the first:
    http://fomori.org/blog/?p=892

    So the question is: does your HP have something like “Customized Boot”? If so, then you could use it. If not, then the path of the Antergos EFI file needs to be modified, and that may not be the easiest solution to use in the long run. But, according to the articles, the problem is in the HP machine and its design choices: it is meant for Windows only (but can be worked around).

  • It seems that you should be able to boot using /EFI/antergos_grub/grubx64.efi instead of /EFI/Microsoft/Boot/bootmgfw.efi (of Windows).

    If you have that “Customized Boot” feature, then try to attach it to /EFI/antergos_grub/grubx64.efi according to the articles.

    EDIT: those paths should have backslashes (\) instead of slashes (/), sorry.

  • Sorry, I must leave now. But I probably can continue tomorrow unless you figure it out!
    :)

  • @manuel

    Hi manuel.

    I have been researching and my HP has not something like a Customized Boot (or at least I can not find it). I’ve read the articules and they are very insteresting. It seems that resolve this going to be pretty complicated. It is also bad luck, not to have the Customized Boot jaja

    Well, thank you and I’m waiting for you next answer, when you can ;)

    Regards.

  • @carlospj

    Are you sure there are no Customized Boot or anything similar that allows you to select what to boot?

    When you start your machine, before the operating system starts, you need to press some Function key, e.g. F9, F10, F2 or maybe Esc (that depends very much on the machine). Then you should get a menu where you can select various things, and one of them could be something related to selecting boot options.
    For more information, can you specify in more detail your PC model?

Posts 47Views 753
Log in to reply