• Not getting updates automatically


    Hi,

    Since a couple of weeks I’m not getting updates. I have to go into pacman, manually refresh the database and then I’ll get the new packages to install them.

    I’m sure it can be easily fixed modifying /etc/pacman.conf or /etc/pacman.d/mirrorlist but I don’t really know what’s wrong. How can I get this little issue fixed?

    Thanks in advance!

  • seems to be related to pamac updates that pamac do not update the .db automaticly… i do not know why but me and some others can reproduce this…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • I’ve receceived an update for pamac (6.0.3-3) on another Arch based distro on my spare laptop and I’m not 100 percent sure, but I guess the pamac devs handled the problem. So it must be soon that the update also appears in Antergos.

    Thinkpad E570 Intel core i5 (Kaby lake)
    8 GB RAM
    256 GB SSD + 1 TB HDD
    Intel HD Graphics

  • Update: I can now confirm, that Pamac 6.0.3-3 shows all updates.

    Thinkpad E570 Intel core i5 (Kaby lake)
    8 GB RAM
    256 GB SSD + 1 TB HDD
    Intel HD Graphics

  • @Bryanpwo

    Hi, I confirm just the opposite!
    Just tried update in pamac: nothing. Then directly after with pacman: linux-lts 4.9.54 arrived. So pamac is not updating properly…

  • I can only say that I haven’t had any update offers for some weeks. I thought it relates to my networking issues.

    So I can try manual update to check, if automatic checking does not work?

  • @manuel I’m talking about version 6.0.3-3 not 6.0.3.-2 that Antergos uses at this moment. You can download it from the AUR, but I’m sure it’s going to update very soon within Antergos.

    Thinkpad E570 Intel core i5 (Kaby lake)
    8 GB RAM
    256 GB SSD + 1 TB HDD
    Intel HD Graphics

  • @vpp21 It’s not related to anything in your environment, it’s Pamac.

    Thinkpad E570 Intel core i5 (Kaby lake)
    8 GB RAM
    256 GB SSD + 1 TB HDD
    Intel HD Graphics

  • @Bryanpwo, thanks for clarifying! :)

  • @Bryanpwo
    Alright, my bad for missing that. I too have been waiting for pamac to be fixed…

  • @Bryanpwo said in Not getting updates automatically:

    Update: I can now confirm, that Pamac 6.0.3-3 shows all updates.

    Thanks for your help! I knew something weird was happening with the updates. I’ll wait until antergos updates pamac.

  • Any ETA when we can expect a new Pamac in the Antergos repositories? I too haven’t seen any system updates for a few weeks now and was wondering what’s going on then saw this post.

    I tried to update Pamac from the AUR but it failed while trying to install a dependency. (forget which one)

  • @RoadHazard pamac 6.0.4-2 is in the antergos repositories now, I’ve just installed.

  • Going to install it now then:grinning:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • a bit I find it also nice, that the community must inform each other about updates :)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • What am I doing wrong?

    [[email protected] ~]$ pacman -S pamac
    error: you cannot perform this operation unless you are root.
    [[email protected] ~]$ sudo pacman -S pamac
    [sudo] password for roadhazard:
    warning: pamac-6.0.3-2 is up to date – reinstalling
    resolving dependencies…
    looking for conflicting packages…

    Packages (1) pamac-6.0.3-2

    Total Installed Size: 2.95 MiB
    Net Upgrade Size: 0.00 MiB

    :: Proceed with installation? [Y/n] n
    [[email protected] ~]$

    https://imgur.com/ISCQGXG

    https://imgur.com/TXZciOX

    I don’t see 6.0.4-2 anywhere.

  • Have you tried rebooting the system and try to update again?

    Thinkpad E570 Intel core i5 (Kaby lake)
    8 GB RAM
    256 GB SSD + 1 TB HDD
    Intel HD Graphics

  • @RoadHazard you can only get updated packages by updating the databese first, as the titler say pamac is not doing this autmaticly so you need to do it manual: sudo pacman -Syu will do a full system update
    sudo pacman -Sywill only update the db …
    Never do only update one program, partly updates will brake your system!

    If you have self-builded ackages from AUR installed this ones needs also to be updated… but you will get all this together inside pamac again shoirtly (if they do a good job)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad :blush: Oops did overlook that one.

    Thinkpad E570 Intel core i5 (Kaby lake)
    8 GB RAM
    256 GB SSD + 1 TB HDD
    Intel HD Graphics

  • @joekamprad sudo pacman -Syu got the updates flowing again, thanks!

automatically7 updates34 Posts 20Views 470
Log in to reply