• Black screen at login with lightdm + nvidia driver


    Hi All,

    I’m not an enormously knowledgeable linux user (although I’ve used it for quite a number of years now) and I’m an Arch newbie.

    I installed Antegros with Gnome 3, and everything seemed to go smoothly until I rebooted. Basic startup seemed to happen OK, but on loading the graphical desktop I was just greeted with a blank screen, no cursor, no nothing. Ctrl-Alt-F2 got me a TTY, however, and there didn’t seem to be anything obviously incriminating in the lightdm logs - lightdm had started successfully; and I didn’t see anything obvious in the X logs either.

    After reading a few posts online, I tried switching to GDM, and this seemed to work ok, so I left it at that. Unfortunately, after a while I came to realise how much I dislike Gnome 3, particularly on Wayland, and wanted to switch back to Cinnamon (I was a Mint user before). This is when the wheels started to fall off. I tried using pacman to get rid of gnome and install Cinnamon, but all I ended up with was some sort of butchered gnome with no apps. It seemed like perhaps it was gdm that was causing the problem, so I tried switching out for lightdm, but I got the black screen again.

    At this point I decided to start afresh and reinstall, selecting Cinnamon from the beginning. Black screen on bootup. Sigh. Installed gdm, disabled lightdm, enabled gdm - back to the sort of “butchered gnome install” instead of Cinnamon.

    More reading; switched to nouveau. Ok, now I have a system that boots with lightdm into Cinnamon: progress - I now know that the problem is some relationship between lightdm and nvidia. But nouveau is too slow for me - I want the proprietary driver, so I need to fix it.

    Since then I’ve tried blacklisting the intel driver in /etc/modprobe.d/blacklist.conf, adding rcutree.rcu_idle_gp_delay=1, and adding the nvidia module to the mkinitcpio config file. None of these has made any obvious difference - I still get the same black screen on startup.

    For reference, the system is Lenovo Thinkpad T440p with a NVIDIA Corporation GK208M [GeForce GT 730M] and Intel Corporation 4th Gen Core Processor Integrated Graphics Controller.

    I’m guessing that people are going to need logs and the output of some debug commands to help, but I’m a bit clueless at this level (I’ve never really understood X properly I’m afraid) so rather than guessing I’ll wait and then provide what people ask for.

    Thanks in advance for any help!

  • @herodotus uh looks like an adventure i was getting last days too… i find out i can solve this by removing accountsservice entry for gdm.

    I uninstall gdm, remove /var/lib/AccountsService/users/gdm then reinstall gdm and it works again!

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • but you will need to setup bumblebee first to get a working setup, if you do not do this?

    And my system is nvidia only Desktop not Notebook discrete+nvidia…

    I am not sure where I should lead someone with bumblebee problems, since there are different bingebeaches at the moment, so please @Community-Moderators drive in here… if someone knows what is the best way to get this working.
    i refer here for a read:
    https://antergos.com/wiki/de/hardware/bumblebee-for-nvidia-optimus/

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Right, yes, I do have Nvidia Optimus graphics and I did install the proprietary driver. This time through the install process I noticed the tooltip that warned against doing that - probably would be good to make that a bit more explicit than a hover-over given that it’s going to prevent the system from booting!

    I’ve got it working with bumblebee for the time being, which seems to be the only reasonable solution if you want to retain the option of maximum graphics performance.

    I’m still a bit confused as to why switching to gdm avoided this issue. Can anyone provide a simple explanation of why this is so I can deepen my understanding of what’s actually going on with all this stuff? If the problem is running Wayland on Optimus I wouldn’t have thought that the DM would make any difference unless the DM somehow forces the system to use the other driver…
    Cheers,

login79 black45 nvidia112 lightdm97 Posts 6Views 381
Log in to reply