• Grub doesn't keep screen resolution.


    Hi,

    I have a 4k x 2k screen resolution screen on a optimus/EFI system :

    00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06) (prog-if 00 [VGA controller])
    02:00.0 3D controller [0302]: NVIDIA Corporation GK107GLM [Quadro K1100M] [10de:0ff6] (rev ff) (prog-if ff)
    

    I changed the resolution in /etc/default/grub like this :

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXMODE=1600x1200
    
    # Uncomment to allow the kernel use the same resolution used by grub
    GRUB_GFXPAYLOAD_LINUX=keep
    

    After beeing sure that this resolution match the card with :

    sudo hwinfo --framebuffer 
    02: None 00.0: 11001 VESA Framebuffer                           
      [Created at bios.459]
      Hardware Class: framebuffer
      Model: ""
      Vendor: ""
      Device: ""
      SubVendor: "Intel(R) HSW Mobile/Desktop Graphics Chipset Accelerated VGA BIOS"
      SubDevice: 
      Revision: ""
      Memory Size: 31 MB + 960 kB
      Memory Range: 0x80000000-0x81feffff (rw)
      Mode 0x033c: 1920x1440 (+1920), 8 bits
      Mode 0x034d: 1920x1440 (+3840), 16 bits
      Mode 0x035c: 1920x1440 (+7680), 24 bits
      Mode 0x033a: 1600x1200 (+1600), 8 bits
      Mode 0x034b: 1600x1200 (+3200), 16 bits
      Mode 0x035a: 1600x1200 (+6400), 24 bits
      Mode 0x0307: 1280x1024 (+1280), 8 bits
      Mode 0x031a: 1280x1024 (+2560), 16 bits
      Mode 0x031b: 1280x1024 (+5120), 24 bits
      Mode 0x0305: 1024x768 (+1024), 8 bits
      Mode 0x0317: 1024x768 (+2048), 16 bits
      Mode 0x0318: 1024x768 (+4096), 24 bits
      Mode 0x0312: 640x480 (+2560), 24 bits
      Mode 0x0314: 800x600 (+1600), 16 bits
      Mode 0x0315: 800x600 (+3200), 24 bits
      Mode 0x0301: 640x480 (+640), 8 bits
      Mode 0x0303: 800x600 (+832), 8 bits
      Mode 0x0311: 640x480 (+1280), 16 bits
      Mode 0x037d: 3840x2160 (+3840), 8 bits
      Mode 0x037e: 3840x2160 (+7680), 16 bits
      Mode 0x037f: 3840x2160 (+15360), 24 bits
      Config Status: cfg=new, avail=yes, need=no, active=unknown
    

    In the first half of the boot the resolution is taken in account but it changes to the 4k x 2k during the second half. I have also tried to change the resolution in /etc/grub.d/00_header without success.

    Thanks for any suggestion.

  • so bumblebee… and booting up on integrated intel graphics?
    May it is possible to fix with:

    Early KMS start
    Tip: If you encounter problems with the resolution, you can check whether enforcing the mode helps.
    KMS is typically initialized after the initramfs stage. However it is possible to already enable KMS during the initramfs stage. Add the module radeon/amdgpu (for ATI/AMD cards), i915 (for Intel integrated graphics) or nouveau (for Nvidia cards) to the MODULES line in /etc/mkinitcpio.conf. For example:

    /etc/mkinitcpio.conf
    MODULES="... i915 ..."
    

    source: https://wiki.archlinux.org/index.php/Kernel_mode_setting#Early_KMS_start

    but as i am not a pro about bumblebee may @Community-Moderators have a warning/hint on this…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • I saw this early kms start long time ago but tried it right now without success.

  • After surching everywhere I found the very easy way. Just had to put the “video=1600x1200” option in /etc/default/grub like that :

    GRUB_CMDLINE_LINUX="video=1600x1200"
    

    Hope this help somebody else.

resolution14 grub80 Posts 4Views 179
Log in to reply