• keyboard layout switch [solved]


    Hi all,

    I recently installed Antergos XFCE,

    and I need 3 keyboard layouts:
    Russian, Italian and English.

    They are set all set up,
    but every time I switch to a different application,
    the keyboard changes to the default one which I set up during installation (Italian).

    It’ a pain to have to change language each time I switch application,
    specially because I always realise it after making mistakes in typing.

    Do you have any suggestion to solve this?
    Thanks,
    Maurizio.

  • I’m not XFCE user, so can’t give exact indications. Other DEs - Mate, Cinnamon, Plasma, Gnome - have the option which may be set to use either the same keyboard layout for all windows, or switch to default layout for newly opened windows.

    Try to find such an option in XFCE, and set it to use the same layout for all windows.

    In bocca al lupo Удачи Good luck

  • @maurizio
    I’m not an expert on this, but have you seen these?
    https://wiki.archlinux.org/index.php/Keyboard_configuration_in_console
    https://wiki.archlinux.org/index.php/Keyboard_configuration_in_Xorg
    Seems that changes need to be made in many places.

  • Thank you guys,

    Looks like there’s nothing about this on XFCE’s keyboard settings GUI,

    and the wiki is about setting keyboards, and switching between them,
    but nothing on keeping the layout across different windows.

  • The four DEs all have a very handy feature. They allow to use keyboard LED indicators whenever a layout differs from the default one. I use ScrollLock LED for this purpose.

    Guarda caso, my main layouts are English, Italian and Russian too :) . And also Finnish. English (US) is the default one.

    I don’t even need to search for a current layout on the screen. While typing in, I continue to look at the keyboard only. If the ScrollLock LED is turned off, I’m with English (US). If the LED is turned on, I’m either with Italian or Russian.

  • @just

    Guarda caso!

    Well, Italian is for me, Russian for my wife, and English for both of us.

    your solution may help,
    But I would feel more confortable in switching and keeping my choice across different windows.
    Will keep on searching, and eventually give you updates.

    Ciao!

  • @maurizio I’m on Gnome now but used XFCE as well. You have to go into the keyboard or language settings to change it global or per applications. With global your keyboard layout will apply for everything. Per apps logically every app will have their actual settings you have set.
    This setting maybe available with right click menu on the panel layout switcher plugin.
    if you can’t see that you have to add it manually to the panel.
    Hope it helps.

  • Thank Louis, it worked!

    I right clicked on the language switch on the panel, and selected ‘globally’.

    Cheers,
    Maurizio.

Posts 8Views 265
Log in to reply