• Wrong keyboard layout after install


    Hi!
    After i succesfully installed the gnome variant of antergos I found that the system ignored the keyboard setting that I chose during install. But I also am not able to select the swiss german keyboard in Region und Sprache.
    Is a swiss german keyboard not supported by gnome, antergos or the GUI?

  • If the language you’re looking for is present in this list:

    #de_AT.UTF-8 UTF-8  
    #de_AT ISO-8859-1  
    #[email protected] ISO-8859-15  
    #de_BE.UTF-8 UTF-8  
    #de_BE ISO-8859-1  
    #[email protected] ISO-8859-15  
    #de_CH.UTF-8 UTF-8  
    #de_CH ISO-8859-1  
    #de_DE.UTF-8 UTF-8  
    #de_DE ISO-8859-1  
    #[email protected] ISO-8859-15  
    #de_IT.UTF-8 UTF-8  
    #de_IT ISO-8859-1  
    #de_LI.UTF-8 UTF-8  
    #de_LU.UTF-8 UTF-8  
    #de_LU ISO-8859-1  
    #[email protected] ISO-8859-15  
    

    uncomment the line with it in the /etc/locale.gen file and regenerate locales. It will make it available in GUI only.

    It doesn’t set the keyboard layout for terminal and VTs. It is set through /etc/vconsole.conf file.

  • @theking2 BTW. The logon screen uses the proper keyboard layout.

  • @theking2 seems that some keyboard settings are failing on the installation, my one too i need to enable de keybord under Gnome and remove us what is choosen there as default, also the UI language is german…
    0_1507393982687_Bildschirmfoto vom 2017-10-07 18-32-41.png

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @just said in Wrong keyboard layout after install:

    If the language you’re looking for is present in this list:

    #de_AT.UTF-8 UTF-8  
    #de_AT ISO-8859-1  
    #[email protected] ISO-8859-15  
    #de_BE.UTF-8 UTF-8  
    #de_BE ISO-8859-1  
    #[email protected] ISO-8859-15  
    #de_CH.UTF-8 UTF-8  
    #de_CH ISO-8859-1  
    #de_DE.UTF-8 UTF-8  
    #de_DE ISO-8859-1  
    #[email protected] ISO-8859-15  
    #de_IT.UTF-8 UTF-8  
    #de_IT ISO-8859-1  
    #de_LI.UTF-8 UTF-8  
    #de_LU.UTF-8 UTF-8  
    #de_LU ISO-8859-1  
    #[email protected] ISO-8859-15  
    

    uncomment the line with it in the /etc/locale.gen file and regenerate locales. It will make it available in GUI only.

    It doesn’t set the keyboard layout for terminal and VTs. It is set through /etc/vconsole.conf file.

    I uncommented the line de-CH in locale.gen and ran locale-gen . this didn’t make the keyboard layout appear in region and langauge

  • @theking2 What eventually worked was this:

    1. In Region & Language change the language from English to Deutsch
    2. Logoff, logon
    3. In Region udn Sprache it is now possible to select Deutsch as language and Swiss as Region
    4. Switch Sprach back to Englisch, and Logoff Logon. Dispite wrongly translated message in German it is not needed to restart the computer.

    What I did first was change /etc/locale,gen and ran locale-gen as root

  • @theking2 said in Wrong keyboard layout after install:

    I uncommented the line de-CH in locale.gen and ran locale-gen . this didn’t make the keyboard layout appear in region and langauge

    Uncommenting de_CH UTF-8 adds a whole lot of German locales. I don’t speak Deutsch, so have no idea which one you’re interested in.

    0_1507465537785_gnome-german-locales-2017.10.08.png

    I’ll comment out de_CH again. It’s Arabic for me.

  • Just to make sure. I removed the # in locale.gen, ran locale-gen AND went through the cycle of changing the language from English to Deutsch, switched the keyboard, and change language from Deutsch to Englisch again. The keyboard settings were not available when running the OS in Englisch only when running in German. This is an obvious bug as I might want a Dutch user-interface with a Swiss - German keyboard. But this is gnome for you. Way behind Microsoft

  • @theking2 said in Wrong keyboard layout after install:

    …I might want a Dutch user-interface with a Swiss - German keyboard.

    No problem. You may have a GUI interface in any language you want, and the keyboard layout - in any other language. Just enable all locales you wish to use.

    Simply set Region & Language --> Formats to Dutch, and Region & Language --> Input Sources to Swiss-German. Done. Dutch and Swiss-German loacles must be enabled in /etc/locale.gen.

    For example, usually my GUI is in English (US) and the keyboard is with Italian layout. Sometime I switch to Italian GUI with English (UK) keyboard, configuring some system for my daughter. Or in English (US) GUI with the Russian keyboard layout, for my dad.

    GUI language and keyboard layout are unrelated between them and may be set independently one from another.

    But this is gnome for you. Way behind Microsoft

    Cannot disagree.

  • @just You’re right. But I have to vi /etc/locale.gen first, change the language, logoff/logon, and only than can change the keyboard, and have to change the langauge back causing another logoff/logon. I call this a work around. Not very user-centered. Considering that I selected the right keyboard layout in “cnchi” in the first place.

    I’m not annoyed, just puzzled.

  • @theking2 Once locale(s) are changed in /etc/locale.gen and regenerated with locale-gen, they become available immediately, even in the current X session.

    Logoff-logout aren’t needed.

  • @joekamprad All I see is this: alt text

  • @just Not true. I have to change the language which causes me to logoff and logon.

  • if you do not have all keyboards aviable inside settings something is wrong, it is not related to generated locales from /etc/locale.gen what i can see under Gnome…
    i have only enabled de utf 8 there and i can add any keyboardlayout i want…
    0_1507478395431_Bildschirmfoto vom 2017-10-08 17-58-41.png

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad
    Simple: In Region & Language I see the English keyboards when the language is English and I see the German keyboards when the language is set to Deutsch. Really.

    I will give antergos another go when the beta-bugs are dealed with.

  • @theking2 but what you show on the picture is language setting not keyboard setting.
    Language is relative to what you generate with locale-gen.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • I don’t think it is a cnchi related issue. I had been using Antergos for several months and suddenly my keyboard-layout was changed after an upgrade (previous to gnome 3.26) on two different computers. My systems are in English, but I use the spanish-la layout. Now this option disappeared.

  • yes i remember this bugs since ever when gnome get updated… but i do not get here what is causing the strange thing that @theking2 show us…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

keyboard37 layout5 Posts 33Views 520
Log in to reply