• ISO 17.10-x86_64 /arch/boot/vmlinuz not found


    Hi I downloaded the iso torrent image antergos-17.10-x86_64.iso copied it on a usb disk with rufus and attempted to boot.

    The boot into live fails with error /arch/boot/vmlinuz not found. If I look at the image I indeed see in /arch/boot/ only archiso.img not a vmlinuz .

    Is the 17.10-x86_64 image flawed?

  • @theking2 said in ISO 17.10-x86_64 /arch/boot/vmlinuz not found:

    Is the 17.10-x86_64 image flawed?

    No, it is not. The full Antergos 17.10 ISO, downloaded from NLUUG Ftp server, boots up from LiveUSB and runs live session without a problem.

  • 0_1507386750685_Bildschirmfoto vom 2017-10-07 16-30-12.png

    error /arch/boot/vmlinuz not found seems to be common under some EFI Bootloader Systems…
    looks like that they search on the wrong drive or can not read the filesystem of the stick correctly…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @theking2 It seems that rufus screwed up. The version I used didn’t completely install the USB device. I now used isotousb.exe and this worked just fine.

  • @theking2 i mostly use dd directly to write the iso, and etcher seems to do a very secure job too and is aviable for windows easely (dd is aviable too…)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @theking2
    Did you use the DD mode in Rufus?

  • @joekamprad
    And there’s Cygwin with dd that works, too (I tested it).

  • I had this problem, and I simply modified the EFI partition, changing the boot entries to /EFI/archiso/vmlinuz.efi instead of /EFI/archiso/vmlinuz. I think the ISO is flawed for EFI systems (or at least the fallback options are on 17.9 from my testing).

    Edit: So it is flawed in 17.10 as well, and here’s how to fix it:
    Step 1. Mount your EFI partition.
    EFI

    Step 2. Navigate to /loader/entries, and find the entry you’re trying to use. Rinse and repeat for all of them if you plan on using all of them.
    loader/entries

    Step 3. Open up your desired entry and find add .efi onto this line:
    i don't wanna write alt text anymore
    alt text

    Step 4. Save, and repeat steps 2-3 for all of the entries you plan on using. Hopefully the @developers will end up fixing this sooner or later.

  • @tenten8401
    Interesting discovery although my unofficial iso uses vmlinuz not vmlinuz.efi and it boots fine here (EFI in VM). As far as i know UEFI motherboards change from one to another, maybe yours require a different config??
    Requires an investigation though…

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto I’d like to say that’s not the case as the default live boot option has the .efi extension to it, and if you look in /EFI/archiso, it’s named vmlinuz.efi instead of vmlinuz.
    This is unedited from a 17.10 ISO:
    alt text
    alt text

    Outside of the EFI partition however:
    alt text

  • @tenten8401 said in ISO 17.10-x86_64 /arch/boot/vmlinuz not found:

    This is unedited from a 17.10 ISO

    Ah ok, i just checked the 17.9 and the config files are ok
    I’ll download the 17.10 here, but i trust you :)

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @manuel nah. used the <quote>recommened<unquote> iso mode.

    this is from the USB device when using isotousb:
    drwxr-xr-x 1 j users 2048 3. Okt 15:49 arch
    drwxr-xr-x 1 j users 2048 3. Okt 15:43 EFI
    drwxr-xr-x 1 j users 22528 3. Okt 15:43 isolinux
    drwxr-xr-x 1 j users 2048 3. Okt 15:43 loader

    If I remember correctly the one that rufus made was all uppercase folder names.

  • @theking2 Use dd mode if anything on Linux ISOs as I don’t think it created your EFI partition correctly.
    Etcher is also an excellent tool.

  • @tenten8401

    Hi just to confirm to you. Indeed vmlinuz.efi is present on boot 17-9 and 17-10 versions, but they boot fine here on VM, maybe your hardware needs a different specification to boot the kernel…

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • I feel like the VM isn’t booting to the EFI mode properly. If I boot in standard BIOS mode everything works, but in UEFI mode, only the first option works and the rest of the fallback options don’t. Same happens with my laptop too, so I don’t think it’s hardware specific.

  • i do test install with efi (VM) here and can see that if i choose systemd-boot i get error that resume entry is missing … but install and bootup wents fine with gnome and no extra options no handmade partition …

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • The first boot option in UEFI mode is completely fine and is set to vmlinuz.efi. All of the fallback options are still set to vmlinuz and result in the vmlinuz not found that I’m seeing.

iso47 archbootvmlinuz1 17.10-x86641 Posts 17Views 343
Log in to reply