• Suspend broken - Thinkpad E470


    Hopefully some of you can assist in this issue for me, I’ve looked elsewhere but I’ve found no fixes.

    I can’t seem to figure out the issue with suspend to RAM for my system. Whenever I close my laptop lid or do a ‘systemctl suspend’ the screen goes blank, the power button blinks slowly a few times then it seems to shutdown, during this time hitting the keyboard or mouse does nothing.

    My initial install of Antergos worked beautifully, but now it seems the opposite. This is a real killer for me.

    I have even gone as far as backing up all my work and running a fresh install but it is still the same issue.

    https://pastebin.com/6nu6PvvX - I’ve included this pastebin of dmesg.

  • I’ve tried most things on the links you provided but I’m still stuck with the same problem

  • Still haven’t cracked the issue here. Can someone provide some help? I’m beginning to lose my faith in Antergos…

  • I once had a simmilar issue . Changing the login manager from lightdm to gdm did the job.

  • @eliramrem said in Suspend broken - Thinkpad E470:

    I once had a simmilar issue . Changing the login manager from lightdm to gdm did the job.

    By following this post, you can try changing the boot loader:

    Install gdm with sudo pacman -S gdm

    and then en una tty 2,3,4... typear this:

    sudo su
    passwd:
    systemctl disable lightdm
    systemctl stop lightdm
    systemctl enable gdm
    systemctl start gdm
    
  • I’ve already tried replacing lightdm with gdm, but I have tried again and I am still getting the same problem.

    I’ve attempted downgrading ‘tlp’ to see if a new update broke the suspend function but it seems to have made no effect. I’ve tried other kernels also and still nothing…

    I can’t figure out what the problem is.

  • @judd That seems to be related to a bios issue, I have used this same system with windows and suspend worked fine. It also worked fine with linux for a while but an update seems to have broken something.

    I will investigate further to find what the issue may be.

thinkpad10 broken17 e4701 suspend34 Posts 9Views 261
Log in to reply