• No /etc/adjtime directory - cnchi error


    alt text
    Every time that I try to install Antergos, I get this message. A similar looking error came with the solution of “resetting the BIOS clock” because of hwclock errors. I went into BIOS and changed my clock values to match my timezone (strangely enough, it had been 7hr ahead for years now without showing this on the desktop). Same result.
    What do?

  • Hi!

    • Can you share your log? It’s in /tmp/cnchi.log file

    • When you boot with the live cd, is there a /etc/adjtime file?

    • In a terminal, what do you get if you run this command?
      sudo hwclock --systohc --utc

    I’ve just modified Cnchi so it does not fail if that file is not there, but this will only mask the error… (in the github version, you will still see the error until we package a new version of Cnchi)

  • @karasu said in No /etc/adjtime directory - cnchi error:

    Hi!

    • Can you share your log? It’s in /tmp/cnchi.log file

    • When you boot with the live cd, is there a /etc/adjtime file?

    • In a terminal, what do you get if you run this command?
      sudo hwclock --systohc --utc

    I’ve just modified Cnchi so it does not fail if that file is not there, but this will only mask the error… (in the github version, you will still see the error until we package a new version of Cnchi)

    Thank you very much for taking the time to address this!
    <can you upload your log?
    Sure.
    [0_1507397247448_cnchi.log](Uploading 100%)
    <When you boot with the live cd, is there a /etc/adjtime file?
    Nope.
    <In a terminal, what do you get if you run this command?
    <sudo hwclock --systohc --utc
    I get this:

    hwclock: Cannot access the Hardware Clock via any known method.
    hwclock: use the --debug option to see the details of our search for an access method

    I then ran sudo hwclock --systohc --utc --debug. I got this:

    hwclock from util-linux 2.30.2
    Trying to open: /dev/rtc0
    Trying to open: /dev/rtc
    Trying to open: /dev/misc/rtc
    No usable clock interface found.
    hwclock: Cannot access the Hardware Clock via any known method

  • @Conation
    @karasu
    It doesn’t look like my file uploaded correctly. Here’s a paste of it.

  • Hi,

    It looks like hwclock is unable to access to your clock system. We’ve never found this before!

    Well… there is a very easy modification you can do to cnchi to be able to install (just delete one line).

    Here it goes:

    • Load livecd iso
    • Wait until Cnchi is updated and close it.
    • Open a terminal
    • Edit install.py file: sudo nano /usr/share/cnchi/cnchi/installation/install.py
    • Search for self.auto_timesetting() (it should be in line 1373)
    • Delete the whole line (ctrl+k), save (ctrl+o) and quit (ctrl+x).
    • Run Cnchi again: sudo -E cnchi -dv (do not close the terminal).

    I hope this is not too cumbersome. Cheers!

  • I had exactly the same error.
    I got the missing /etc/adjtime by using the command sudo hwclock -w --directisa

  • @karasu said in No /etc/adjtime directory - cnchi error:

    Hi,

    It looks like hwclock is unable to access to your clock system. We’ve never found this before!

    Well… there is a very easy modification you can do to cnchi to be able to install (just delete one line).

    Here it goes:

    • Load livecd iso
    • Wait until Cnchi is updated and close it.
    • Open a terminal
    • Edit install.py file: sudo nano /usr/share/cnchi/cnchi/installation/install.py
    • Search for self.auto_timesetting() (it should be in line 1373)
    • Delete the whole line (ctrl+k), save (ctrl+o) and quit (ctrl+x).
    • Run Cnchi again: sudo -E cnchi -dv (do not close the terminal).

    I hope this is not too cumbersome. Cheers!

    Thank you very much! This worked.

cnchi109 directory2 error185 etcadjtime1 Posts 7Views 282
Log in to reply