• IPC connect call failed


    I just booted up my Antergos system and ran a update (haven’t updated for a long while because I have not had access to this PC) and ran into an issue…

    The keys were not updated, so I downloaded the new keys but they wouldn’t get accepted. So I ran “pacman-key --init”, but then I got this error:

    gpg: starting migration from earlier GnuPG versions
    gpg: can't connect to the agent: IPC connect call failed
    gpg: error: GnuPG agent unusable. Please check that a GnuPG agent can be started.
    

    Easy enough, maybe the gpg-agent was not started.
    So I ran “gpg-agent -v --daemon” and got this error:

    gpg-agent: relocation error: gpg-agent: symbol gcry_get_config, version GCRYPT_1.6 not defined in file libgcrypt.so.20 with link time reference
    

    And I have no idea what this means and I can’t find anything that works on the forums…
    I can’t download anything because I do not have the keys, even by adding the manually I get an PGP Signature error…

    Any ideas?

  • Solved!

    libgcrypt was corrupted for some reason. By forcing signature checking to never in “/etc/pacman.conf”

    SigLevel = Never
    

    and then force reinstalling “libgcrypt” by (not sure if “–force” is needed)

    sudo pacman -S libgcrypt --force
    

    and then

    sudo pacman --init
    sudo pacman --populate archlinux antergos
    sudo pacman --refresh-keys
    sudo pacman -Syyu
    

    Works perfect now.

Posts 2Views 511
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.