• keyboard -input randomly seems to freeze for 1-2s


    I’m not sure if I posted this question in the right section, if its better placed somewhere else I’m thankful if a mod can move it!

    As topic above. This is slightly irritating, and started to appear for about 2-3 days ago. So when I’m typing, every 5-7 minutes or so the input seems to freeze for about 1-2 seconds, and Then it all appears at the same time. This happens both in command line, Firefox, Chromium, Vim etc.

    I am using a Asus Zenbook 3 UX390UA

    I should say that I can still use the mouse when the keyboard input freezes, however the mouse clicking input action can sometime freeze, but since I’m not using the mouse far as much as the keyboard I can not say if the freeze is as frequent. Or if it’s related.

    Keyboard and mouse I’m talking about is integrated laptop keyboard and touchpad. (And apple magic bluetooth mouse, same issue as far as the mouse goes. Haven’t tried another keyboard.

    Is the problem formulated good enough?
    Where should I start looking?
    What kind of information can I provide for more experienced to look at?

    Thanks
    Alge

    Mr. Poopybutthole: Oooohwee! Whatever you want, Rick, we're here to help!
    Rick: Thanks, Mr. Poopybutthole. I always could count on you.

  • Which kernel are you using?
    I’m just guessing here, but you could try a different kernel with the antergos-kernel-manager package. If you are willing to sacrifice your time for trying it, please report here the results.
    Note that in case of booting problems you can boot from the Live USB and chroot to go back to a working kernel.

  • @manuel

    x86_64 Linux 4.13.3-1-ARCH

    Okay, I will look into that. Thanks!

    I just noticed that the mouse “click” action and the keyboard input freezes at the SAME time.

    Mr. Poopybutthole: Oooohwee! Whatever you want, Rick, we're here to help!
    Rick: Thanks, Mr. Poopybutthole. I always could count on you.

  • @algeee said in keyboard -input randomly seems to freeze for 1-2s:

    if its better placed somewhere else I’m thankful if a mod can move it!

    place is the right one as it is “hardware - kernel -driver -w.e.”

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @manuel

    Could it be the swap memory? I have 4GB SWAP (and 8GB RAM).

    I am pretty new to Linux overall, so I really don’t know where to start. But the problem has now gotten worse, only writing up to this point at the reply the input (seemed) to freeze about 5 times. (Total of 40 sec). Seemed, because even if the text and/or mouse click don’t seem to appear, it does a few seconds later, just wanted to clarify that.

    Mr. Poopybutthole: Oooohwee! Whatever you want, Rick, we're here to help!
    Rick: Thanks, Mr. Poopybutthole. I always could count on you.

  • Okay:

    So I “downgraded” (?) kernel from x86_64 Linux 4.13.3-1-ARCH to
    x86_64 Linux 4.13.4-1-ARCH. With “antergos-kernel-manager” as mentioned by @manuel above.

    Yesterday the problem was so severe that I could not use the computer properly.

    The problem now seemes to be solved. I haven’t had any problem since the kernel “downgrade” anyways!

    Mr. Poopybutthole: Oooohwee! Whatever you want, Rick, we're here to help!
    Rick: Thanks, Mr. Poopybutthole. I always could count on you.

  • 4.13.3 < 4.13.4 :)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Yay! I’m glad to hear it worked for you:grinning:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @algeee
    You could also try to use the ‘linux-lts’ kernel, if your machine is not very new. The linux-lts kernel has a much longer support time, and if it works for you, then it should be more problem free than the ‘linux’ kernel.
    Just install linux-lts and optionally linux-lts-headers, reboot and select the linux-lts boot entry.

  • @manuel

    Okay, thanks! For now I am satisfied with the solution, but if this problem occurs later on I will definitaly look into lts-kernel!

    Mr. Poopybutthole: Oooohwee! Whatever you want, Rick, we're here to help!
    Rick: Thanks, Mr. Poopybutthole. I always could count on you.

  • So if you feel this is solved now, could you mark it as solved?

  • Okay, so the problem came back… It seems to get worse as I get more uptime… Or maybe I just start noticing it.

    I notice it mostly when looking at a film because the frame freezes but the audio does not. I also noticed that the “clicking action” on the mouse Did work during the “freeze”, i.e I could pause the film.

    Mr. Poopybutthole: Oooohwee! Whatever you want, Rick, we're here to help!
    Rick: Thanks, Mr. Poopybutthole. I always could count on you.

  • @algeee
    I guess the problem has to do with drivers (probably graphics) or how the kernel is optimized. So you may still try e.g. linux-zen kernel if you haven’t already. If that doesn’t help, then I suggest you check your graphics driver (Intel?). Then maybe someone more familiar with those things than me could give you some ideas.

  • Okay, NOW it’s solved.

    I disabled all of my extensions, and the freezings disappeared. I do not know which one of the extensions that caused the problem, but I will get back when I know!

    Mr. Poopybutthole: Oooohwee! Whatever you want, Rick, we're here to help!
    Rick: Thanks, Mr. Poopybutthole. I always could count on you.

  • @algeee
    What extensions do you mean? Which DE do you have?
    This could be valuable information to others if they experience similar problems.

  • Okay, so this is regarding ASUS Zenbook 3 UX390UA

    PROBLEM:

    When I’m typing, every 5-7 minutes or so the input seems to freeze for about 1-2 seconds, and Then it all appears at the same time. This happens both in command line, Firefox, Chromium, Vim etc.

    And furthermore:
    I notice it mostly when looking at a film because the frame freezes but the audio does not. I also noticed that the “clicking action” on the mouse Did work during the “freeze”, i.e I could pause the film.

    INFO:
    DE: GNOME
    GTK Theme: Numix-Frost [GTK2/3]
    Kernel: x86_64 Linux 4.13.4-1-ARCH

    SOLUTION:

    Disable all GNOME extensions.

    ACTIVE EXTENSION WHEN PROBLEM OCCURRED:

    Arc Menu by LinxGem33
    Auto OVPN by yomun
    Battery Percentage by eagleoneraptor
    Clipboard Indicator by Tudmotu
    Dash to Dock by michele_g
    Dynamic Battery by Exalm
    Dynamic Panel Transparency by rockon999
    Removable Drive Menu by fmuellner
    Remove Accessibility by lomegor
    Remove Dropdown Arrows by mpdeimos
    Sensory Perception by HarlemSquirrel
    Sound Input & Output Device Chooser by kgshank
    Start Overlay in Application View by tmk
    Transparent Notification by ipaq3870
    User Themes by fmuellner

    EXTENSION THAT IS NOT CAUSING THE PROBLEM:

    Arc Menu by LinxGem33
    Battery Percentage by eagleoneraptor
    Dynamic Panel Transparency by rockon999
    Remove Dropdown Arrows by mpdeimos
    Start Overlay in Application View by tmk
    User Themes by fmuellner

    Mr. Poopybutthole: Oooohwee! Whatever you want, Rick, we're here to help!
    Rick: Thanks, Mr. Poopybutthole. I always could count on you.

  • @algeee Thanks! Now we have a reference for others.

Posts 17Views 300
Log in to reply