• Xerox WorkCentre 6605DN driver please?


    I have a pc running kde 5 and I can not get the printer Xerox WorkCentre 6605DN working. I had it working before but had to reinstall antergos and now can not get the proper driver. I believe I got the driver before from Aur and now Aur have several drivers but it does not specify 6605DN.

    Has anyone got this printer or can anyone let me know what driver to use or how to configure it. I have tried kde printer configuration and http://localhost:631/ but haven’t got the proper driver.

    I read somewhere that the 7228 driver works for this printer but again Aur does not specify. I can download the PPD driver from http://www.openprinting.org/printer/Xerox/Xerox-WorkCentre_7228 but how do I install this if that is the right one. For example Xerox-WorkCentre_7228-Postscript-Xerox.ppd where do I put this driver on the system?

    Thanks in advance

  • Should be this one https://aur.archlinux.org/packages/xeroxprtdrv/

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad said in Xerox WorkCentre 6605DN driver please?:

    https://aur.archlinux.org/packages/xeroxprtdrv/

    thanks joekamprad I can get it on aur. I will try on the system with the Xerox tomorrow evening and let you know how I got on.

  • @lmcogs I tried xeroxprtdrv from aur and then sudo xeroxprtmgr

    first had to download drivers found at ‘Resources’ ‘Link Resources’ ‘Drivers and Downloads’ bottom of page at http://www.office.xerox.com/multifunction-printer/color-multifunction/workcentre-6605/enus.html.

    Ran the file with sudo sh and accept the license. Not sure what happened or where drivers were installed or if they were.
    then ran sudo xeroxprtmgr and the xerox config program ran and found the printer. However, the config is not too clear and one needed more infor on what to do. The program crashed a couple of times when I tried the Queue option. I wasn’t sure what to name this queue. However I added the suggested printer and it installed it but to a place \\file\dev\null.
    In kde in print management system settings I managed this printer and sent a test page which as was thought sent to \dev\null.

    Did not know how to overcome this. I found this link from someone having same problem in arch http://forum.support.xerox.com/t5/Printing/ERROR-OSInterface-Failed-to-open-config-file/td-p/178203

    Anyway not all bad news since I read on another link from ubuntu, I think where someone advised taking a ppd file from the windows installer. This can be found from drivers at first link, the file is xr6605dn.ppd.

    I then went to systems setting print manager and created a new printer but installed driver from local file xr6605dn.ppd. If I remember on the second page where you get option to install driver there were two option something about apple hp sock ( not sure of name). When I tried first it did not work but then I tried the second and that worked.

    I must say it was hours of trying and not too clear or comprehensive instructions. I concur with
    bjorntj in the xerox support forum above.

    So the xerox 6605DN works in linux. Xerox does a good job with xeroxprtdrv but need a lot more instructions on how to configure it. I would also like to know what arch or antergos think of the programme.

  • i will take a look to it tomorrow, seems interesting ;)

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

Posts 5Views 188
Log in to reply