• Error updating a package "out of space"?


    I was updating my Unity install and it failed, where I saw a bunch of error messages related to it being out of space. I do have plenty of hard drive space left so I’m not sure what it’s referring to about that. Attached is a screenshot of the messages I got.0_1506899807066_unity-update-error.png

  • It appears that your /tmp directory has run out of space temporarily due to building such a large package. I do not remember how exactly to change the directory it builds things in, but in Pamac there’s a built in option to change it via it’s Preferences option graphically.

    Hope this helps and good luck:grinning:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Keegan

    Hmm I did some poking around online and did read about this being an issue with /tmp. Specifically, it’s a problem with some large packages because the /tmp directory apparently lives in RAM.

    I found advice to go into /etc/makepkg.conf and manually set the build directory that way (see attached screenshot) but it didn’t work. I had different messages displayed (as if it were getting further) during the update but it still eventually said it was out of space.

    0_1506908724785_set-build-dir.png

  • I would honestly try setting the BUILDDIR to = whatever directory you wish to, such as /usr or /etc. It’s just an idea, but that way it would be outside of your /tmp directory and would have as much available space as your root partition has.

    Hope this helps!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Keegan

    Thanks for sticking around to help me out.

    That’s actually exactly what I did. As you can see above, I chose to put the BUILDDIR in /home/$USER/.tmp/makepkg, so it should have access to all the space it needs. Do you think it makes a difference that this package comes from the AUR? I used pacaur to install it. Do you think there’s another setting I need to change somewhere, perhaps related to packages coming from the AUR?

  • I don’t really know:disappointed:. I have to go to bed now (it’s getting really late here) but I’ll be back to take a better look at your last post in the morning:grinning:. And it’s no problem. Helping others out is why I’m here!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Keegan

    Ah ok. I appreciate you looking at it again later when you have time. Just for good measure, I restarted my computer just to see if that would help, since I did make a config change when I changed the BUILDDIR. Unfortunately, still same problem. Here’s the output of the update:

    0_1506911302061_unity-fail-still.png

  • inside pamac settings on tab AUR you can choose a different folder for building… choose one under your home directory instead of /tmp what is handeled by tmpfs inside your RAM…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad said in Error updating a package "out of space"?:

    inside pamac settings on tab AUR you can choose a different folder for building… choose one under your home directory instead of /tmp what is handeled by tmpfs inside your RAM…

    That did the trick. I didn’t realize there were settings that could be changed in the GUI. I was able to change the build directory for AUR though and then the update went through no problem.

    Thanks!

  • Yay:grinning:. I’m glad to hear your problem was successfully solved, @mattwelke! I would have been back sooner, but I was experienceing issues with Lightdm (login manager) and so could not get into my system for a bit. (It was my own fault, too much messing around:smile:).

    Anyways, I’m so glad your issue is now solved!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

error200 space4 updating21 Posts 10Views 312
Log in to reply