• Gnome Boxes Startup issues


    Hi guys. I’m a huge fan of Gnome Boxes for how simple it is to use and how clean the interface is. I’ve been using it for a long time, and know it to be rock steady on Fedora.

    On Antergos, I installed the package and it booted up the first time like normal, allowing me to create a VM and everything perfectly. However, the next time I tried to boot it up, Gnome Boxes launched for about two seconds, had the spinning circle go round a few times, and then closed unexpectedly. I tried it again and the same thing keeps on happening. Nothing I do fixes the issue, it still goes through this odd boot loop.

    Have you guys seen issues like this before? If so, how did you fix it?

    Ubuntu ~ Debian ~ Fedora ~ Antergos
    Dell XPS 15 9530

  • gnome-boxes --checks
    and:

    journalctl -f /usr/bin/gnome-boxes
    while running it

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Hi @joekamprad, thanks for the reply.

    Here is what I got using gnome-boxes --checks:
    (gnome-boxes:2441): Boxes-WARNING **: util-app.vala:250: Failed to execute child process ?restorecon? (No such file or directory)
    • The CPU is capable of virtualization: yes
    • The KVM module is loaded: yes
    • Libvirt KVM guest available: yes
    • Boxes storage pool available: yes
    • The SELinux context is default: no

    Report bugs to https://bugzilla.gnome.org/enter_bug.cgi?product=gnome-boxes.
    Boxes home page: https://wiki.gnome.org/Apps/Boxes.

    Here is what I got from the journal -f /usr/bin/gnome-boxes command:

    – Logs begin at Mon 2017-07-17 21:44:11 PDT. –
    Oct 01 14:26:06 sentinel gnome-boxes[2897]: machine.vala:611: Failed to start zen_installer-2017: Unable to start domain: Cannot access storage file ‘/home/mach01/.local/share/gnome-boxes/images/boxes-unknown’ (as uid:4294967295, gid:4294967295): No such file or directory
    Oct 01 14:26:07 sentinel gnome-boxes[2897]: machine.vala:611: Failed to start zen_installer-2017: Unable to start domain: Cannot access storage file ‘/home/mach01/.local/share/gnome-boxes/images/boxes-unknown’ (as uid:4294967295, gid:4294967295): No such file or directory
    Oct 01 14:26:09 sentinel gnome-boxes[2897]: libvirt-machine.vala:483: Unable to delete domain: Domain not found: no domain with matching uuid ‘9c7a9a68-ac86-4972-936e-8e771ea8c722’ (boxes-unknown)
    Oct 01 14:26:09 sentinel gnome-boxes[2897]: libvirt-machine.vala:498: Unable to delete storage volume: Storage volume not found: no storage vol with matching name 'boxes-unknown’
    Oct 01 14:26:15 sentinel gnome-boxes[2897]: libvirt-machine.vala:483: Unable to delete domain: Domain not found: no domain with matching uuid ‘9c7a9a68-ac86-4972-936e-8e771ea8c722’ (boxes-unknown)
    Oct 01 14:26:15 sentinel gnome-boxes[2897]: libvirt-machine.vala:498: Unable to delete storage volume: Storage volume not found: no storage vol with matching name 'boxes-unknown’
    Oct 01 14:26:15 sentinel gnome-boxes[2897]: machine.vala:611: Failed to start zen_installer-2017: Unable to start domain: Cannot access storage file ‘/home/mach01/.local/share/gnome-boxes/images/boxes-unknown’ (as uid:4294967295, gid:4294967295): No such file or directory
    Oct 01 14:26:16 sentinel gnome-boxes[2897]: machine.vala:611: Failed to start zen_installer-2017: Unable to start domain: Cannot access storage file ‘/home/mach01/.local/share/gnome-boxes/images/boxes-unknown’ (as uid:4294967295, gid:4294967295): No such file or directory
    Oct 01 14:26:16 sentinel gnome-boxes[2897]: machine.vala:611: Failed to start zen_installer-2017: Unable to start domain: Cannot access storage file ‘/home/mach01/.local/share/gnome-boxes/images/boxes-unknown’ (as uid:4294967295, gid:4294967295): No such file or directory
    – Reboot –
    Oct 01 14:28:52 sentinel gnome-boxes[2570]: gvir_storage_vol_get_info: assertion ‘GVIR_IS_STORAGE_VOL(vol)’ failed

    Whenever, I click on Gnome-Boxes, it loads for a second, the toggle wheel rolls a few times, and closes, so I’m not sure when to run the second command.

    Ubuntu ~ Debian ~ Fedora ~ Antergos
    Dell XPS 15 9530

  • I had the same or similar issue. I didn’t bother with dealing with the segfault, removed Boxes, and installed virt-manager instead.
    https://forum.antergos.com/topic/6905/gnome-boxes-segfaulting

  • Hi @triode13 Thanks for the tip. I tried to install Qemu and Virt-manager using Yaourt like how @joekamprad mentioned in the other forum posts, but when I try to open virt-manger, it doesn’t start or open. I’m wondering if this is a Wayland issue (yet another, I know) since I know VMware has some issues with Wayland too.

    Ubuntu ~ Debian ~ Fedora ~ Antergos
    Dell XPS 15 9530

  • @joekamprad Thanks for the info. I guess I’m just going to have to wait until gnome-boxes 3.26 comes out.

    Do any of you guys have any other VM software you like that’s simple, clean, easy to use, and works with Wayland?

    Ubuntu ~ Debian ~ Fedora ~ Antergos
    Dell XPS 15 9530

issues52 gnome250 boxes2 startup14 Posts 7Views 259
Log in to reply