• Syntax errors are detected in generated GRUB config file.


    I just checked my /usr/lib/grub directory, but x86_64-efi is completely missing!

  • @Keegan said in Syntax errors are detected in generated GRUB config file.:

    Manually go through your files and delete

    /etc/grub.d

    hehehe… this file is completely gone still !!! Does anyone know how to add it back?

    Thanks!

  • /usr/lib/grub/x86_64-efi/ is installed with grub… and you also do not remove it before i am right?

  • so chrooting into it, and reinstall grub, reconfigure grub, reinstall it will may help

  • I might have manually removed that folder earlier, but it should still have come back upon reinstalling grub, right?

  • @joekamprad said in Syntax errors are detected in generated GRUB config file.:

    so chrooting into it, and reinstall grub, reconfigure grub, reinstall it will may help

    My idea exactly! I think I’m going to go try this right now.

  • Strange. I’m following this guy’s instructions for reinstalling grub, but grub-install does not work! Is that just another version of sudo grub-mkconfig -o /boot/grub/grub.cfg?

  • Hmmm… grub-install is working now😀.

  • and now I get this:

    [[email protected] /]#  grub-mkconfig -o /boot/grub/grub.cfg
    Generating grub configuration file ...
    Found linux image: /boot/vmlinuz-linux-zen
    Found initrd image(s) in /boot: initramfs-linux-zen.img
    Found fallback initrd image(s) in /boot: initramfs-linux-zen-fallback.img
    Found linux image: /boot/vmlinuz-linux-lts
    Found initrd image(s) in /boot: initramfs-linux-lts.img
    Found fallback initrd image(s) in /boot: initramfs-linux-lts-fallback.img
    Found linux image: /boot/vmlinuz-linux
    Found initrd image(s) in /boot: initramfs-linux.img
    Found fallback initrd image(s) in /boot: initramfs-linux-fallback.img
      WARNING: Failed to connect to lvmetad. Falling back to device scanning.
    grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your device.map.
    done
    [[email protected] /]# 
    
    
  • grub-install and grub-mkconfig are not the same. The first is related to that you can boot at all, the latter to what you’ll boot to.

  • @Keegan
    What was your grub-install line?

  • I found this article on the Wiki about it, but am unsure what to do:

    https://bbs.archlinux.org/viewtopic.php?id=201650

  • @manuel said in Syntax errors are detected in generated GRUB config file.:

    What was your grub-install line?

    Sorry, I didn’t see this post until now. Here it is:

    [[email protected] /]# grub-install /dev/sda1
    Installing for x86_64-efi platform.
    Installation finished. No error reported.
    [[email protected] /]# 
    
  • Here’s a screenshot of all my partitions from gparted:
    0_1506778800268_DeepinScreenshot_gpartedbin_20170930133918.png
    Hope this can help!

  • @Keegan
    I think the grub-install should target to the disk, not the partition.
    So:

    grub-install /dev/sda
    

    not sda1.

  • but UEFI system here? so grub install needs to go to /boot/efi

  • @joekamprad
    Oh yes you are right. @Keegan don’t grub-install to /dev/sda, since you don’t have an extra small partition there with bios_grub flag.

  • @Keegan Seems that you soon may have to reinstall your system …

  • @manuel said in Syntax errors are detected in generated GRUB config file.:

    @Keegan Seems that you soon may have to reinstall your system …

    I’ve been thinking the same thing too!I read somewhere there was a way to generate a list of all your packages, but I cannot remember the exact command. Does anyone know it?

    Thanks!

  • @Keegan
    Something like pacman -Q with some extra options, don’t recall all details now…
    EDIT: see https://wiki.archlinux.org/index.php/Pacman/Tips_and_tricks

grub111 detected14 syntax3 generated1 Posts 97Views 7771
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.