• Syntax errors are detected in generated GRUB config file.


    Whenever I try to run sudo grub-mkconfig -o /boot/grub/grub.cfg, for some reason it fails with this as the output:

    $ sudo grub-mkconfig -o /boot/grub/grub.cfg
    Generating grub configuration file ...
    Found theme: /boot/grub/themes/deepin/theme.txt
    Found linux image: /boot/vmlinuz-linux
    Found initrd image: /boot/initramfs-linux.img
    Found fallback initramfs image: /boot/initramfs-linux-fallback.img
    Found linux image: /boot/vmlinuz-linux-lts
    Found initrd image: /boot/initramfs-linux-lts.img
    Found fallback initramfs image: /boot/initramfs-linux-lts-fallback.img
    Found linux image: /boot/vmlinuz-linux-zen
    Found initrd image: /boot/initramfs-linux-zen.img
    Found fallback initramfs image: /boot/initramfs-linux-zen-fallback.img
    Found Windows Boot Manager on /dev/[email protected]/EFI/Microsoft/Boot/bootmgfw.efi
    error: out of memory.
    error: syntax error.
    error: Incorrect command.
    error: syntax error.
    Syntax error at line 278
    Syntax errors are detected in generated GRUB config file.
    Ensure that there are no errors in /etc/default/grub
    and /etc/grub.d/* files or please file a bug report with
    /boot/grub/grub.cfg.new file attached.
    [[email protected] ~]$ 
    

    Anyone have any ideas? os-prober executes fine still…

    Thank you!

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • What file have you edited before you ran grub-mkconfig? Can you post its contents?

  • I just installed linux-zen. However, I doubt this is truly the problem, as I recall running into ths before after almost nuking my computer on accident a month ago !!! I can post a link to that previous thread in just a minute when I find it!

    And thank you for all of your help and interest in this problem, @Krugar. It is greatly appreciated by me:slight_smile:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • Yep! Just found my previous post from a month or so ago here:

    https://forum.antergos.com/topic/7598/gparted-merging-partitions/35

    Hope this helps!

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • Testing shows that the linux-zen kernel is “the best” and brings interesting features, but this kernel sometimes gives boot problems. Sometimes I have to reboot a couple of times to properly start the grub.

    Test realizados demuestran que el kernel linux-zen es el mejor y trae características interesantes, pero este kernel a veces da problemas con el arranque. Algunas veces me toca reiniciar un par de veces para que arranque correctamente el grub.

    Aprendiendo que no es poco

  • Hmmm… I just tried adding another command to my process here, and this is what happens now (including all of my commands to get there):

    [[email protected] ~]$ sudo mkinitcpio -p linux
    ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
      -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
    ==> Starting build: 4.13.3-1-ARCH
      -> Running build hook: [base]
      -> Running build hook: [udev]
      -> Running build hook: [autodetect]
      -> Running build hook: [modconf]
      -> Running build hook: [block]
      -> Running build hook: [keyboard]
      -> Running build hook: [keymap]
      -> Running build hook: [resume]
      -> Running build hook: [filesystems]
      -> Running build hook: [fsck]
    ==> Generating module dependencies
    ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
    ==> Image generation successful
    ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
      -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
    ==> Starting build: 4.13.3-1-ARCH
      -> Running build hook: [base]
      -> Running build hook: [udev]
      -> Running build hook: [modconf]
      -> Running build hook: [block]
    ==> WARNING: Possibly missing firmware for module: aic94xx
    ==> WARNING: Possibly missing firmware for module: wd719x
      -> Running build hook: [keyboard]
      -> Running build hook: [keymap]
      -> Running build hook: [resume]
      -> Running build hook: [filesystems]
      -> Running build hook: [fsck]
    ==> Generating module dependencies
    ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
    ==> Image generation successful
    [[email protected] ~]$ sudo os-prober
    /dev/[email protected]/EFI/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi
    [[email protected] ~]$ sudo grub-mkconfig -o /boot/grub/grub.cfg
    Generating grub configuration file ...
    Found theme: /boot/grub/themes/deepin/theme.txt
    wrong argument count. You have to give the config as parameter 1!
    [[email protected] ~]$ 
    

    At least the error message is shorter now:grinning:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Keegan said in Syntax errors are detected in generated GRUB config file.:

    I just installed linux-zen.

    I won’t be able to help :(
    It’s just that grub problems are a bummer and I’m afraid of giving the wrong advice and getting you into more trouble, since I know little about the above kernel and can’t understand why you would get this error from a arch kernel straight install.

  • Maybe I can change the theme here? Right now it says

    Found theme: /boot/grub/themes/deepin/theme.txt
    wrong argument count. You have to give the config as parameter 1!
    

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Krugar I think the same :confused:

    Aprendiendo que no es poco

  • @Krugar said in Syntax errors are detected in generated GRUB config file.:

    It’s just that grub problems are a bummer and I’m afraid of giving the wrong advice and getting you into more trouble, since I know little about the above kernel and can’t understand why you would get this error from a arch kernel straight install.

    I completely understand:slight_smile:. Although i can assure you that this issue is not related to installing Linux-Zen, as I’ve actually had this issue for over a month here, I have just never felt the need to fix it until now. And really, I don’t mind too much if my computer goes down for a few days:grinning:. At this point, any advice you can give me is valuable, even if it gets me into trouble. If we put our heads together, I’m sure we’ll be able to get this solved in the end!

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • I think, in this case, it’s not a Zen kernel problem

    Aprendiendo que no es poco

  • Yep. It looks like the theme should be “Antergos-default”. How can I change it back to that though?

    Thank you:grinning:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Velkerk said in Syntax errors are detected in generated GRUB config file.:

    I think, in this case, it’s not a Zen kernel problem

    Same with me. I wonder if it’s the Deepin theme that’s causing this, as I recall installing Deepin (not from my ISO, but rather a much more dangerous install manually) at about the same time this issue first appeared. If we could change the theme, that would be great!

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Keegan It’s possible. I hope the developers can help you

    Aprendiendo que no es poco

  • Here’s my current grub.cfg file:

    #
    # DO NOT EDIT THIS FILE
    #
    # It is automatically generated by grub-mkconfig using templates
    # from /etc/grub.d and settings from /etc/default/grub
    #
    
    ### BEGIN /etc/grub.d/00_header ###
    insmod part_gpt
    insmod part_msdos
    if [ -s $prefix/grubenv ]; then
      load_env
    fi
    if [ "${next_entry}" ] ; then
       set default="${next_entry}"
       set next_entry=
       save_env next_entry
       set boot_once=true
    else
       set default="0"
    fi
    
    if [ x"${feature_menuentry_id}" = xy ]; then
      menuentry_id_option="--id"
    else
      menuentry_id_option=""
    fi
    
    export menuentry_id_option
    
    if [ "${prev_saved_entry}" ]; then
      set saved_entry="${prev_saved_entry}"
      save_env saved_entry
      set prev_saved_entry=
      save_env prev_saved_entry
      set boot_once=true
    fi
    
    function savedefault {
      if [ -z "${boot_once}" ]; then
        saved_entry="${chosen}"
        save_env saved_entry
      fi
    }
    
    function load_video {
      if [ x$feature_all_video_module = xy ]; then
        insmod all_video
      else
        insmod efi_gop
        insmod efi_uga
        insmod ieee1275_fb
        insmod vbe
        insmod vga
        insmod video_bochs
        insmod video_cirrus
      fi
    }
    
    set menu_color_normal=light-blue/black
    set menu_color_highlight=cyan/blue
    
    if [ x$feature_default_font_path = xy ] ; then
       font=unicode
    else
    insmod part_gpt
    insmod ext2
    set root='hd0,gpt7'
    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt7 --hint-efi=hd0,gpt7 --hint-baremetal=ahci0,gpt7  4f920bf1-e738-4e62-afcc-6cf59261b022
    else
      search --no-floppy --fs-uuid --set=root 4f920bf1-e738-4e62-afcc-6cf59261b022
    fi
        font="/usr/share/grub/unicode.pf2"
    fi
    
    if loadfont $font ; then
      set gfxmode=auto
      load_video
      insmod gfxterm
      set locale_dir=$prefix/locale
      set lang=en_US
      insmod gettext
    fi
    terminal_input console
    terminal_output gfxterm
    insmod part_gpt
    insmod ext2
    set root='hd0,gpt7'
    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt7 --hint-efi=hd0,gpt7 --hint-baremetal=ahci0,gpt7  4f920bf1-e738-4e62-afcc-6cf59261b022
    else
      search --no-floppy --fs-uuid --set=root 4f920bf1-e738-4e62-afcc-6cf59261b022
    fi
    insmod gfxmenu
    loadfont ($root)/boot/grub/themes/Antergos-Default/ascii.pf2
    loadfont ($root)/boot/grub/themes/Antergos-Default/rlwy14.pf2
    loadfont ($root)/boot/grub/themes/Antergos-Default/rlwy16.pf2
    insmod png
    set theme=($root)/boot/grub/themes/Antergos-Default/theme.txt
    export theme
    if [ x$feature_timeout_style = xy ] ; then
      set timeout_style=menu
      set timeout=5
    # Fallback normal timeout code in case the timeout_style feature is
    # unavailable.
    else
      set timeout=5
    fi
    ### END /etc/grub.d/00_header ###
    
    ### BEGIN /etc/grub.d/01_grub-customizer_menu_color_helper ###
    set color_normal=light-blue/black
    set color_highlight=cyan/blue
    ### END /etc/grub.d/01_grub-customizer_menu_color_helper ###
    
    ### BEGIN /etc/grub.d/10_antergos_proxy ###
    
    menuentry "Antergos Linux" --class antergos --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-4f920bf1-e738-4e62-afcc-6cf59261b022' {
    	load_video
    	set gfxpayload=keep
    	insmod gzio
    	insmod part_gpt
    	insmod ext2
    	set root='hd0,gpt7'
    	if [ x$feature_platform_search_hint = xy ]; then
    	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt7 --hint-efi=hd0,gpt7 --hint-baremetal=ahci0,gpt7  4f920bf1-e738-4e62-afcc-6cf59261b022
    	else
    	  search --no-floppy --fs-uuid --set=root 4f920bf1-e738-4e62-afcc-6cf59261b022
    	fi
    	echo	'Loading  linux kernel ...'
    	linux	/boot/vmlinuz-linux root=UUID=4f920bf1-e738-4e62-afcc-6cf59261b022 rw  quiet resume=UUID=80386cf6-55dc-4136-b9f5-5bbdb2881223
    	echo	'Loading initial ramdisk ...'
    	initrd	 /boot/initramfs-linux.img
    }
    submenu "Advanced options for Antergos Linux"{
    menuentry "Antergos Linux Recovery" --class antergos --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-4f920bf1-e738-4e62-afcc-6cf59261b022' {
    		load_video
    		set gfxpayload=keep
    		insmod gzio
    		insmod part_gpt
    		insmod ext2
    		set root='hd0,gpt7'
    		if [ x$feature_platform_search_hint = xy ]; then
    		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt7 --hint-efi=hd0,gpt7 --hint-baremetal=ahci0,gpt7  4f920bf1-e738-4e62-afcc-6cf59261b022
    		else
    		  search --no-floppy --fs-uuid --set=root 4f920bf1-e738-4e62-afcc-6cf59261b022
    		fi
    		echo	'Loading  linux kernel ...'
    		linux	/boot/vmlinuz-linux root=UUID=4f920bf1-e738-4e62-afcc-6cf59261b022 rw  quiet resume=UUID=80386cf6-55dc-4136-b9f5-5bbdb2881223
    		echo	'Loading initial ramdisk ...'
    		initrd	 /boot/initramfs-linux.img
    }
    menuentry "Antergos Linux LTS Recovery" --class antergos --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-4f920bf1-e738-4e62-afcc-6cf59261b022' {
    		load_video
    		set gfxpayload=keep
    		insmod gzio
    		insmod part_gpt
    		insmod ext2
    		set root='hd0,gpt7'
    		if [ x$feature_platform_search_hint = xy ]; then
    		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt7 --hint-efi=hd0,gpt7 --hint-baremetal=ahci0,gpt7  4f920bf1-e738-4e62-afcc-6cf59261b022
    		else
    		  search --no-floppy --fs-uuid --set=root 4f920bf1-e738-4e62-afcc-6cf59261b022
    		fi
    		echo	'Loading  linux kernel ...'
    		linux	/boot/vmlinuz-linux root=UUID=4f920bf1-e738-4e62-afcc-6cf59261b022 rw single 
    		echo	'Loading initial ramdisk ...'
    		initrd	 /boot/initramfs-linux-fallback.img
    }
    menuentry "Antergos Linux LTS Kernel" --class antergos --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-4f920bf1-e738-4e62-afcc-6cf59261b022' {
    		load_video
    		set gfxpayload=keep
    		insmod gzio
    		insmod part_gpt
    		insmod ext2
    		set root='hd0,gpt7'
    		if [ x$feature_platform_search_hint = xy ]; then
    		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt7 --hint-efi=hd0,gpt7 --hint-baremetal=ahci0,gpt7  4f920bf1-e738-4e62-afcc-6cf59261b022
    		else
    		  search --no-floppy --fs-uuid --set=root 4f920bf1-e738-4e62-afcc-6cf59261b022
    		fi
    		echo	'Loading  linux-lts kernel ...'
    		linux	/boot/vmlinuz-linux-lts root=UUID=4f920bf1-e738-4e62-afcc-6cf59261b022 rw  quiet resume=UUID=80386cf6-55dc-4136-b9f5-5bbdb2881223
    		echo	'Loading initial ramdisk ...'
    		initrd	 /boot/initramfs-linux-lts.img
    }
    menuentry "Antergos Linux LTS Kernel" --class antergos --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-4f920bf1-e738-4e62-afcc-6cf59261b022' {
    		load_video
    		set gfxpayload=keep
    		insmod gzio
    		insmod part_gpt
    		insmod ext2
    		set root='hd0,gpt7'
    		if [ x$feature_platform_search_hint = xy ]; then
    		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt7 --hint-efi=hd0,gpt7 --hint-baremetal=ahci0,gpt7  4f920bf1-e738-4e62-afcc-6cf59261b022
    		else
    		  search --no-floppy --fs-uuid --set=root 4f920bf1-e738-4e62-afcc-6cf59261b022
    		fi
    		echo	'Loading  linux-lts kernel ...'
    		linux	/boot/vmlinuz-linux-lts root=UUID=4f920bf1-e738-4e62-afcc-6cf59261b022 rw single 
    		echo	'Loading initial ramdisk ...'
    		initrd	 /boot/initramfs-linux-lts-fallback.img
    }
    menuentry "Antergos Linux - Fallback" --class antergos --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-4f920bf1-e738-4e62-afcc-6cf59261b022' {
    		load_video
    		set gfxpayload=keep
    		insmod gzio
    		insmod part_gpt
    		insmod ext2
    		set root='hd0,gpt7'
    		if [ x$feature_platform_search_hint = xy ]; then
    		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt7 --hint-efi=hd0,gpt7 --hint-baremetal=ahci0,gpt7  4f920bf1-e738-4e62-afcc-6cf59261b022
    		else
    		  search --no-floppy --fs-uuid --set=root 4f920bf1-e738-4e62-afcc-6cf59261b022
    		fi
    		echo	'Loading  linux kernel ...'
    		linux	/boot/vmlinuz-linux root=UUID=4f920bf1-e738-4e62-afcc-6cf59261b022 rw  quiet resume=UUID=80386cf6-55dc-4136-b9f5-5bbdb2881223
    		echo	'Loading initial ramdisk ...'
    		initrd	 /boot/initramfs-linux-fallback.img
    }
    menuentry "Antergos Linux LTS Kernel - Fallback" --class antergos --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-4f920bf1-e738-4e62-afcc-6cf59261b022' {
    		load_video
    		set gfxpayload=keep
    		insmod gzio
    		insmod part_gpt
    		insmod ext2
    		set root='hd0,gpt7'
    		if [ x$feature_platform_search_hint = xy ]; then
    		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt7 --hint-efi=hd0,gpt7 --hint-baremetal=ahci0,gpt7  4f920bf1-e738-4e62-afcc-6cf59261b022
    		else
    		  search --no-floppy --fs-uuid --set=root 4f920bf1-e738-4e62-afcc-6cf59261b022
    		fi
    		echo	'Loading  linux-lts kernel ...'
    		linux	/boot/vmlinuz-linux-lts root=UUID=4f920bf1-e738-4e62-afcc-6cf59261b022 rw  quiet resume=UUID=80386cf6-55dc-4136-b9f5-5bbdb2881223
    		echo	'Loading initial ramdisk ...'
    		initrd	 /boot/initramfs-linux-lts-fallback.img
    }
    }
    ### END /etc/grub.d/10_antergos_proxy ###
    
    ### BEGIN /etc/grub.d/20_linux_xen ###
    ### END /etc/grub.d/20_linux_xen ###
    
    ### BEGIN /etc/grub.d/30_os-prober ###
    menuentry 'Windows Boot Manager (on /dev/sda1)' --class windows --class os $menuentry_id_option 'osprober-efi-BC18-4BBE' {
    	insmod part_gpt
    	insmod fat
    	set root='hd0,gpt1'
    	if [ x$feature_platform_search_hint = xy ]; then
    	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt1 --hint-efi=hd0,gpt1 --hint-baremetal=ahci0,gpt1  BC18-4BBE
    	else
    	  search --no-floppy --fs-uuid --set=root BC18-4BBE
    	fi
    	chainloader /EFI/Microsoft/Boot/bootmgfw.efi
    }
    ### END /etc/grub.d/30_os-prober ###
    
    ### BEGIN /etc/grub.d/40_custom_proxy ###
    
    # This file provides an easy way to add custom menu entries.  Simply type the
    # menu entries you want to add after this comment.  Be careful not to change
    # the 'exec tail' line above.
    
    
    ### END /etc/grub.d/40_custom_proxy ###
    
    ### BEGIN /etc/grub.d/41_custom ###
    if [ -f  ${config_directory}/custom.cfg ]; then
      source ${config_directory}/custom.cfg
    elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
      source $prefix/custom.cfg;
    fi
    ### END /etc/grub.d/41_custom ###
    

    PS. I find it rather hummorous that it explicitly says “DO NOT EDIT THIS FILE”, which is exactly what I’m thinking of doing of course:smile:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • Turns out the problem is not with the Deepin theme, but perhaps /etc/default/grub? No matter what I do, I always get this error:

    wrong argument count. You have to give the config as parameter 1!
    [[email protected] ~]$ 
    

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • Here’s my current etc/default/grub file, which is somehow made by deepin?

    # Written by com.deepin.daemon.Grub2
    GRUB_BACKGROUND="/boot/grub/themes/deepin/background.png"
    GRUB_CMDLINE_LINUX=""
    GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=80386cf6-55dc-4136-b9f5-5bbdb2881223"
    GRUB_DEFAULT="0"
    GRUB_DISTRIBUTOR="`/usr/bin/lsb_release -d -s 2>/dev/null || echo Deepin`"
    GRUB_GFXMODE="auto"
    GRUB_GFXPAYLOAD_LINUX="keep"
    GRUB_PRELOAD_MODULES="part_gpt part_msdos"
    GRUB_TERMINAL_INPUT="console"
    GRUB_THEME="/boot/grub/themes/deepin/theme.txt"
    GRUB_TIMEOUT="5"
    export GRUB_COLOR_HIGHLIGHT="cyan/blue"
    export GRUB_COLOR_NORMAL="light-blue/black"
    

    If someone could kindly post their file, that would be great:grinning:. Then I could just copy and paste yours and be done here!

    Thanks!

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Keegan said in Syntax errors are detected in generated GRUB config file.:

    etc/default/grub

    Not that one either apparently…I just found a backup directory containing everything in /boot/grub/, but it didn’t solve the issue:disappointed:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Keegan said in Syntax errors are detected in generated GRUB config file.:

    Building image from preset: /etc/mkinitcpio.d/linux.preset: ‘default’

    sudo mkinitcpio -p linux is using linux.preset and not /etc/mkinitcpio.d/linux-zen.preset
    First i’d recommend you to reinstal llinux-zen and linux-zen-headers and then try sudo grub-mkconfig -o /boot/grub/grub.cfg again.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto said in Syntax errors are detected in generated GRUB config file.:

    First i’d recommend you to reinstal llinux-zen and linux-zen-headers and then try sudo grub-mkconfig -o /boot/grub/grub.cfg again.

    Will do! And thank you so much for all of your help, @fernandomaroto.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

generated1 detected8 syntax2 grub76 Posts 97Views 1499
Log in to reply