• Wrong OpenGL Version


    Hello there,

    I have a really weird issue today. Yesterday I tested Metro2033 Redux on my machine and it worked. Today, it won’t start and says that I need ‘OpenGL 4.0 or higher’. I was confused, as the only changes that I installed recently are:

    [2017-09-29 13:34] [ALPM] upgraded lvm2 (2.02.174-1 -> 2.02.174-2)
    [2017-09-29 13:34] [ALPM] upgraded device-mapper (2.02.174-1 -> 2.02.174-2)
    [2017-09-29 13:34] [ALPM] upgraded alsa-lib (1.1.4.1-1 -> 1.1.4.1-2)
    

    But the game is right, my OpenGL string must have changed somehow:

    $ glxinfo | grep OpenGL
    OpenGL vendor string: VMware, Inc.
    OpenGL renderer string: llvmpipe (LLVM 5.0, 128 bits)
    OpenGL core profile version string: 3.3 (Core Profile) Mesa 17.2.1
    OpenGL core profile shading language version string: 3.30
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    OpenGL core profile extensions:
    OpenGL version string: 3.0 Mesa 17.2.1
    OpenGL shading language version string: 1.30
    OpenGL context flags: (none)
    OpenGL extensions:
    OpenGL ES profile version string: OpenGL ES 3.0 Mesa 17.2.1
    OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
    

    This is very weird! I hope someone else can help me. My Hardware Specs:
    AMD FX6150
    AMD Radeon 7970
    8GB DDR3 RAM

    Edit:
    What really bothers me is that OpenGL says it is using LLVM as renderer and not my graphics card. Should’nt my Radeon hardware be mentioned there?

  • @FrankyFire said in Wrong OpenGL Version:

    OpenGL renderer string: llvmpipe (LLVM 5.0, 128 bits)

    i see this on another post too seems to be related to kernel

    4.13.3-1-ARCH

    may try the LTS Kernel and see if it is the same.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad said in Wrong OpenGL Version:

    @FrankyFire said in Wrong OpenGL Version:

    OpenGL renderer string: llvmpipe (LLVM 5.0, 128 bits)

    i see this on another post too seems to be related to kernel

    4.13.3-1-ARCH

    may try the LTS Kernel and see if it is the same.

    Thank you very much, that’s the solution!

    See post #5 in thread for how to downgrade EASILY

    To everyone who (like me) haven’t downgraded packages or even kernels before, theres this good guide to this.
    Take the kernel version from here that came before your version (take a look at the date, because version 4.3.13 comes before 4.3.2) and download it. Do the same with the same version for the linux-headers. After that I copied those files to the pacman cache directory, but you don’t need to do this. For downgrading I used (change directory if you didn’t moved your files):

    sudo pacman -U /var/cache/pacman/pkg/linux-4.12.8-2-x86_64.pkg.tar.xz /var/cache/pacman/pkg/linux-headers-4.12.8-2-x86_64.pkg.tar.xz /var/cache/pacman/pkg/vhba-module-20170610-13-x86_64.pkg.tar.xz 
    

    Restart your system and play again!

    Sadly one last question is left for me. The Arch-Wiki mentions also downgrading the kernel modules. But how to do this easily? I can list them with

    lsmod
    

    But how to downgrade all of them at once? Or do i really need to downgrade everyone of them itself. Right now my system complains about not being able to load the kernel-modules.

  • @FrankyFire
    Maybe use package ‘downgrade’? ;)
    And there is the brand new package antergos-kernel-manager …

  • @manuel said in Wrong OpenGL Version:

    And there is the brand new package antergos-kernel-manager …

    THIS!

    I just love Antergos for this. Didn’t expected something like this. Ignore my last answer and just use this tool!
    -Solved

  • If you do not build modules manual against the kernel, you will using them delivered with the kernel, so no need to do this by hand… only stuff “outside” the kernel like nvidia driver and so on… I do not wanted to force you to downgrade the kernel i want you to just install LTS-kernel (linux-lts) long term support kernel it is linux-lts 4.9.52-1 …
    You can install them alongside with current kernel and choose on boot menu (advanced options)

    … but fine ;)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Using linux-lts is not really “downgrading” in my book.
    But it is simple to set up. Just some terminal commands:

    pacman -S --needed linux-lts linux-lts-headers
    pacman -Rsn linux linux-headers
    

    as root and you should be good to go.

  • Thanks guys, didn’t know that. Thank you very much for that additional Info :smile:

Posts 8Views 246
Log in to reply