• Konsole & zsh -- strange terminal name symbols


    Hello everyone
    I have zsh with oh-my-zsh
    I have applied a theme and after that Konsole is showing me garbage as the title of the terminal.
    See attached (bottom name)
    0_1506623097129_82fb0fbc-941d-4896-8ac7-bef56365a051-image.png

    My .zshrc

    //echo -ne "\e]0;$PWD\a"
    ZSH=/usr/share/oh-my-zsh/
    source $ZSH/oh-my-zsh.sh
    ZSH_THEME="ys"
    source $ZSH/oh-my-zsh.sh
    echo -ne "\e]0;$PWD\a"
    plugins=(colorize iwhois kate man osx)
    

    Any ideas?
    I have tried to remove the terminal name (Konsole settings) but it did not resolve the issue.

    4.13.2-1-zen - KDE Plasma 5.10.5 (Qt 5.9.1)
    i7-4820K 3900 - 32GB RAM - GTX 1060 6GB
    HDD 2000.4GB, SSD1 250.1GB, SSD2 480.1GB
    Init: systemd, zsh 5.4.2

  • It is affecting yakuake also. so i think it is something with me zshrc but I can’t find what

    0_1506623959788_cb5a0180-ea63-40c0-9c6a-69d43f2b3f4a-image.png

    4.13.2-1-zen - KDE Plasma 5.10.5 (Qt 5.9.1)
    i7-4820K 3900 - 32GB RAM - GTX 1060 6GB
    HDD 2000.4GB, SSD1 250.1GB, SSD2 480.1GB
    Init: systemd, zsh 5.4.2

  • may it is the zsh theme?

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • it is the “ys” theme

    4.13.2-1-zen - KDE Plasma 5.10.5 (Qt 5.9.1)
    i7-4820K 3900 - 32GB RAM - GTX 1060 6GB
    HDD 2000.4GB, SSD1 250.1GB, SSD2 480.1GB
    Init: systemd, zsh 5.4.2

  • It doesnt matter which theme I use, always the same
    %15<…<%~%<<[email protected]%m: %~

    4.13.2-1-zen - KDE Plasma 5.10.5 (Qt 5.9.1)
    i7-4820K 3900 - 32GB RAM - GTX 1060 6GB
    HDD 2000.4GB, SSD1 250.1GB, SSD2 480.1GB
    Init: systemd, zsh 5.4.2

  • @mbalino said in Konsole & zsh -- strange terminal name symbols:

    [email protected]%m:

    this looks like [email protected]

    Formatted:
    [[email protected]:/current/path]%

    Code
    [%[email protected]%m:%c]%#

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad
    But where is it?

    I do not have in .zshrc
    I looked in oh-my-zsh.sh and it is not there
    I looked in ys.zsh-theme and it is not there

    If I comment the ZSH_THEME, the problem disappears…

    4.13.2-1-zen - KDE Plasma 5.10.5 (Qt 5.9.1)
    i7-4820K 3900 - 32GB RAM - GTX 1060 6GB
    HDD 2000.4GB, SSD1 250.1GB, SSD2 480.1GB
    Init: systemd, zsh 5.4.2

  • May this helps?

    #Uncomment the following line to disable auto-setting terminal title.
    DISABLE_AUTO_TITLE="true"
    

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad said in Konsole & zsh -- strange terminal name symbols:

    DISABLE_AUTO_TITLE=“true”

    Thank you very much!!

    That was the problem !

    4.13.2-1-zen - KDE Plasma 5.10.5 (Qt 5.9.1)
    i7-4820K 3900 - 32GB RAM - GTX 1060 6GB
    HDD 2000.4GB, SSD1 250.1GB, SSD2 480.1GB
    Init: systemd, zsh 5.4.2

terminal31 konsole2 zsh2 strange11 Posts 9Views 232
Log in to reply