• Overscanning through HDMI


    Hello,

    I have just installed Antergos on my laptop,
    and when I connect it to my 31 inches tv through HDMI, the screen is too much zoomed, and all the edges are cut out. I googled and I found this is called overscanning.

    I am using xf86-video-ati driver, the free driver.
    I thought to change to the proprietary driver, but looks like it’ s quite buggy. (does anyone know about it?).
    Anyway, if I can solve this overscnning, I am happy with the free one. Unfortunately I couldn’t find any solution in the web.

    My video card is:

    01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Robson CE [Radeon HD 6370M/7370M] (prog-if 00 [VGA controller])
    	Subsystem: Acer Incorporated [ALI] Device 0487
    	Flags: bus master, fast devsel, latency 0, IRQ 29
    	Memory at a0000000 (64-bit, prefetchable) [size=256M]
    	Memory at b4000000 (64-bit, non-prefetchable) [size=128K]
    	I/O ports at 3000 [size=256]
    	Expansion ROM at 000c0000 [disabled] [size=128K]
    	Capabilities: <access denied>
    	Kernel driver in use: radeon
    	Kernel modules: radeon
    
    

    and my tv is a Panasonic Viera 31 inches.

    Thanks in advance for your support

  • Would you know what DE you are using?

    Thanks!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO: https://rebornos.wordpress.com

    Friend's Website: http://nwg.pl

  • Hi Keegan,
    Thanks for your reply.

    I am using XFCE.

  • Can you maybe change the resolution of your screen? That might help, but obviously I don’t know if your problem can be solved that easily for sure ;).

    Hope this can help!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO: https://rebornos.wordpress.com

    Friend's Website: http://nwg.pl

  • @maurizio said in Overscanning through HDMI:

    Robson CE [Radeon HD 6370M/7370M]

    https://wiki.archlinux.org/index.php/xrandr#Correction_of_overscan_tv_resolutions

    something like:

    xrandr --output HDMI-0 --set underscan on --set "underscan vborder" 25 --set "underscan hborder" 40

    should help on this…

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • It’s working, thanks a lot!

    How shall I make it consistent at boot,
    shall I add the command to xorg.conf ?

  • wau! i just copy paste from the wiki 😉

    i would ad this as a startup script:
    https://wiki.archlinux.org/index.php/Xfce#Startup_applications

    sudo nano .xrandr-underscan.sh

    #!/bin/bash
    xrandr --output HDMI-0 --set underscan on --set "underscan vborder" 25 --set "underscan hborder" 40 &
    

    [ctrl+X] to save
    chmod -x .xrandr-underscan.sh
    to make it executable, and then add it to Startup applications:

    Alternatively, add the commands you wish to run (including setting environment variables) to xinitrc (or xprofile when a display manager is being used).

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • it’s ok,

    I found how to make it consistent after every boot,

    I created a file ~/.xconfig and I just copied the command in it:

    xrandr --output HDMI-0 --set underscan on --set "underscan vborder" 25 --set "underscan hborder" 40
    

    and now it’s working.
    Thanks a lot for your help!

  • this was anwasy one! glad to be helpfull, stuff like this is very annoying for the eyes 😉

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Hi Joekamprad,

    I am reopening the thread,
    because I found that if I create an .xconfig file with the xrandr command in it,
    then I am unable to set the volume through HDMI, and it appears as ‘unplugged’ in pavucontrol! 😲

    So I removed the .xconfig file, and I created an executable to run as a startup script, following your advice,
    but after reboot the video is overscanned again.

    I tried by putting the executable in /usr/local/bin,
    and now it works if I give the command through terminal,
    but doesn’t work if I add it to the startup scripts.

    do you have any advice? 🤔

  • may you need to put a delay to the command, to let the desktop load before…

    sleep 15 && xrandr --output HDMI-0 --set underscan on --set "underscan vborder" 25 --set "underscan hborder" 40

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • it’s not working yet,

    I tried ‘sleep 15’ and ‘sleep 30’, but no luck.

    The script runs fie from the terminal, and also the waiting time works.

  • looks like something is overwriting it… i have not that much experiences with xrandr…

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • you can try watching the journal while this happen:

    journalctl -f inside a terminal

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Hi all,

    I can say that the issue is solved now.

    as an answer to Judd,
    Yes, I searched in the TV settings, and couldn’ t find any underscanning button, or any menu entry about it.

    But then I found this wiki:

    https://bbs.archlinux.org/viewtopic.php?id=157564

    which is just what I needed!

    I simply put the xrandr command line in the ‘session and startup’ gui, and it worked!

    Anyway I had to make the command more simple. The command that works is:

    xrandr --output HDMI-0 --set underscan on
    

    This may be useful for others, too.

    Thanks a lot for your help,
    Maurizio.

Posts 16Views 907
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.