• Please help with jottalib? AUR, github, Python

    Can someone please help me figure out how to use the program called jottalib from AUR?


    • Install
    • Configure username and password
    • Backup my files

    Jottalib is a cli program for backing up files to my online backup service of choice, jottacloud.com. Or at least I think so? There aren’t any official Linux client yet.

    I basically have No clue in this area of linux… So rather than me trying to explain, please have a look yourself…


    Jottalib is available in AUR. I tried installing it, but failed. I also tried “cloning” it from github, but Im basically fumbling in the dark…

    I set up an account for you to use.
    Username: fleindre
    Password: 1qwe2rty

  • @endre84 said in Please help with jottalib? AUR, github, Python:


    sudo pacman -S python-sphinx

    before build it will help it is missing for python2-humanize

    then you should be able to build jottalib

  • @joekamprad

    Thanks for responding!

    I managed to install jottalib, turned out I had already installed it from github. I’ve never used github before, so the process confused me a bit… Removed the github install, an reinstalled it from AUR, in hope of a more correct install.

    Anyway, when I’m trying to upload some files I get this error:

    [[email protected] ~]$ jotta-scanner /home/endre/Pictures /Jotta/Archive/test
    Traceback (most recent call last):
      File "/usr/bin/jotta-scanner", line 6, in <module>
        from pkg_resources import load_entry_point
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3138, in <module>
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3122, in _call_aside
        f(*args, **kwargs)
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3151, in _initialize_master_working_set
        working_set = WorkingSet._build_master()
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 664, in _build_master
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 981, in require
        needed = self.resolve(parse_requirements(requirements))
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 867, in resolve
        raise DistributionNotFound(req, requirers)
    pkg_resources.DistributionNotFound: The 'clint' distribution was not found and is required by jottalib

    Again, this is a bit out of my comfort zone, I have no clue how to interpret this…?

    From what I understand reading the jottacloud wiki, I need to export username and password. So i did…

    export JOTTACLOUD_USERNAME="fleindre"
    export JOTTACLOUD_PASSWORD="1qwe2rty"

    Then I ran:

    jotta-scanner /home/endre/Pictures /Jotta/Archive/test

    Now I’m stuck…

  • python2-clint is missing maybe try to install it!

  • @joekamprad

    Right again, thank you.

    I actually solved a few problems myself after this, by interpreting the output. I am however stuck again.
    This is starting to look like more of a programming challenge, which I am not capable of resolving. Judging by the project pages on github, the author seems to be inactive for most of the time. So this may be a waste of time…

    I’m giving it a last shot. Can you tell me whats wrong here? Or rather where (in what file?) the problem is?

    [[email protected] ~]$ jotta-scanner /home/endre/Pictures/ /jotta/Archive/test2
    Entering dir: /home/endre/Pictures/
    Traceback (most recent call last):
      File "/usr/bin/jotta-scanner", line 11, in <module>
        load_entry_point('jottalib==0.5.1', 'console_scripts', 'jotta-scanner')()
      File "/usr/lib/python2.7/site-packages/jottalib/cli.py", line 443, in scanner
        filescanner(args.topdir, args.jottapath, jfs, args.errorfile, args.exclude, args.dry_run, args.prune_files, args.prune_folders)
      File "/usr/lib/python2.7/site-packages/jottalib/scanner.py", line 77, in filescanner
        for f in progress.bar(onlylocal, label="uploading %s new files: " % len(onlylocal)):
      File "/usr/lib/python2.7/site-packages/clint/textui/progress.py", line 113, in bar
        filled_char=BAR_FILLED_CHAR, expected_size=count, every=every) \
      File "/usr/lib/python2.7/site-packages/clint/textui/progress.py", line 63, in __init__
      File "/usr/lib/python2.7/site-packages/clint/textui/progress.py", line 87, in show
        self.expected_size, self.etadisp))
    UnicodeEncodeError: 'ascii' codec can't encode characters in position 24-55: ordinal not in range(128)

    I tried reading up on the python unicode howto, but its to advanced for me.

  • way to much errors for my experience, this needs to be solved by the guy creating it, to solve it would be like rewriting it 🕵🏾

  • Yeah, I was afraid of that. Thanks anyway, I really appreciate it.

    Maybe I get bored some day and learn python. I did som basic c++ and bash scripting back in the Day…

  • Is there by chance a good way to run Android apps on linux?

  • there is… but i do not remember at the moment… we have a post about @Keegan was involved too…

  • @endre84 said in Please help with jottalib? AUR, github, Python:

    Is there by chance a good way to run Android apps on linux?

    Yep😀. Android is really just a heavily stripped down, customized Linux OS, so many apps can be made to work with Linux seamlessly. However, there are two disclaimers first.

    1. Actual Google Chrome must be installed for it to work (for some reason not even Chromium performs this correctly).

    2. Only small apps or games will work. If they are over 100 MB in size, they will often crash upon loading. Small games such as Candy Crush and calendars however, all work seamlessly. In addition, most social media apps have no problem with Linux.

    With that out of the way, here’s a link to my website containing detailed instructions on how to easily get Android apps working on Linux:


  • Thanks Keegan :)

  • @endre84 said in Please help with jottalib? AUR, github, Python:

    Thanks Keegan

    Just glad I could help😀. If you ever need any help in the future, feel free to message me directly on the Forum! I would love to (try) to help🙂.


  • Unfortunately ARC welder did not work either. I’m officially dropping the issue, for now anyway. I still have Windows 7 on my laptop, so I can work around the problem until a solution magically appears.

    Apparently WebGL is not supported in ARC welder.

    Failed to load extension from: /home/endre/Android/com.jottacloud.android.client.apk_export_wKlkY. WebGL is not supported.

    Maybe I should switch to a cloud storage backup with support for linux instead. It’s just that I get 100gb free on Jottacloud, and that it’s Norwegian (which I am also). I need at least 100gb to store my family photos and videos.

    Anyway, thank you both for your help. It’s not always easy to get friendly help on linux forums… :-D

  • Or force them to offer some linuxfriendly protocols :-)

  • @endre84 said in Please help with jottalib? AUR, github, Python:

    Unfortunately ARC welder did not work either.

    I’m sorry to hear that😞. But at least you still have Windows 7 to fall back to !!!

aur58 python15 github3 jottalib1 Posts 15Views 1598
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.