• AntergosPrime - Brings Optimus/ Prime functionality to Antergos


    @folgui said in AntergosPrime - Brings Optimus/ Prime functionality to Antergos:

    Perhaps running “nvidia-xconfig” to create one? I’ll try later.

    never NEVER do this!!!

  • @joekamprad said in AntergosPrime - Brings Optimus/ Prime functionality to Antergos:

    @folgui said in AntergosPrime - Brings Optimus/ Prime functionality to Antergos:

    Perhaps running “nvidia-xconfig” to create one? I’ll try later.

    never NEVER do this!!!

    I know that with bumblebee but perhaps with prime it’s needed. Waiting confirm. ;)

  • you can do:

    nvidia-xconfig -o xorg-nvidia
    as normal user it will create xorg-nvidia file where you are without creating xorg.conf in your system…
    you can see what it produce then before make use of it

  • Hi!

    The error in log is at “NVIDIA: Failed to initialize the NVIDIA kernel module”. How can it fix that? Perhaps i need something like “sudo mkinitcpio --preset linux” after “prime-select nvidia”. Going to try again :)

    EDIT: Well, now i have a black screen at DM but i can log through TTY (no flickering) when using mkinitcpio after prime-select.

    The latest log is Xorg.0.log

  • @folgui At least TTYs work :D

    Maybe on of your GPUs is differently called.
    Please check your xorg conf file after switching to Nvidia before rebooting and look if the entry is the correct one for the GPU.
    “NVIDIA GPU GeForce GTX 850M (GM107-A) at PCI:1:0:0 (GPU-0)”

    EDIT: I was talking bullshit. I will take a look at it the next days :)

  • @folgui Sorry for the late answer. Had and still have a busy time :D

    Do you have the nvidia-package installed?
    sudo pacman -S nvidia
    I found out that I have it installed, but the gpu switching script does not provide this.

    – If this did not work:
    If you have a bit time you could try if at least only using the NVIDIA GPU works. You can find instructions in the Arch Wiki: https://wiki.archlinux.org/index.php/NVIDIA_Optimus#Using_nvidia

    Are you using 32-Bit?
    If so: Can you please try to install the following NVIDIA packages after you installed prime-select?
    sudo pacman -S nvidia nvidia-libgl lib32-nvidia-libgl lib32-nvidia-utils

  • @got-it-man HI!

    Yes, i have “nvidia” package installed and i’m in 64-bits. Going to try the Arch Wiki instructions and tell you the results.

    Thanks.

  • @got-it-man Well, the archwiki instructions didn’t work for me. I’ve tried a lot of stuff, but without success. Going back to bumblebee for the moment. Perhaps in some days/weeks I’ll do a clean install of Antergos and try again.

    Hi. I successfully booted laptop with my nvidia card. How?

    • bumblebee uninstalled
    • antergos-prime uninstalled
    • intel driver installed
    • sudo pacman -S nvidia nvidia-utils xorg-xrandr (xorg-xrandr already installed)
    • GDM as Display Manager and with this config
    • xorg.conf file based on this post by doaxan, with some modifications needed because some parse errors:
    Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
    EndSection
    
    Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1:0:0"
    EndSection
    
    Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "True"
    EndSection
    
    Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0:2:0"
    Option "AccelMethod" "none"
    EndSection
    
    Section "Screen"
    Identifier "intel"
    Device "intel"
    EndSection
    

    With all these settings, my laptop booted and the result of

    [[email protected] ~]$ glxinfo | grep NVIDIA
    server glx vendor string: NVIDIA Corporation
    client glx vendor string: NVIDIA Corporation
    OpenGL vendor string: NVIDIA Corporation
    OpenGL core profile version string: 4.5.0 NVIDIA 387.12
    OpenGL core profile shading language version string: 4.50 NVIDIA
    OpenGL version string: 4.6.0 NVIDIA 387.12
    OpenGL shading language version string: 4.60 NVIDIA
    OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 387.12
    

    I don’t have now the possibility of switching gpu. Going to try antergos-prime with above config.

    Regards, folgui.

  • Interesting.
    The Arch wiki guide worked for me ootb.
    However I used LightDM.

    After my NVIDIA only setup I switched to Antergosprime.
    Maybe this is now also possible for you.

    Keep me up to date :)

    P.S. Which intel driver do you mean?

  • @got-it-man With the xorg.conf i’ve posted above, antergos-prime works for me with gdm and sddm for switching gpus ;) With sddm all perfect, with gdm i’ve a problem that i think is related to Xsetup that is in sddm and that i don’t have in gdm. This is what i get with gdm and intel:

    libGL error: failed to create dri screen
    libGL error: failed to load driver: nouveau
    Vendor: Intel Open Source Technology Center (0x8086)
    Device: Mesa DRI Intel® Haswell Mobile (0x416)
    OpenGL vendor string: Intel Open Source Technology Center
    OpenGL renderer string: Mesa DRI Intel® Haswell Mobile

    For now, i’m going to replace /etc/prime/xorg.conf with my xorg.conf for antergos-prime working OK.

    For intel driver i mean xf86-video-intel package.

    Thanks.

    Regards, folgui.

  • @folgui I think xorg-xrandr comes ootb with every installation. @developers Is this correct?

    Great to hear! So everything works for you now with SDDM?
    Switching also works? And glxinfo shows correct info for both “GPU modes”?

    Regarding GDM:
    You created the two scripts like explained here: https://wiki.archlinux.org/index.php/NVIDIA_Optimus#GDM , right?
    However I think there might be problems with GDM since the GDM things are commented out inside the gpumanager script.

    Regarding xorg:
    I would love to track down that issue.
    Can you please post me your exact xorg.conf in a pastebin? :D
    Makes it easier for me :D

    Which version of xorg do you use?

  • @got-it-man said in AntergosPrime - Brings Optimus/ Prime functionality to Antergos:

    Great to hear! So everything works for you now with SDDM?
    Switching also works? And glxinfo shows correct info for both “GPU modes”?

    Yes, with SDDM everything works, also switching of course and glxinfo is ok for intel and nvidia. This is with the xorg.conf i posted above and below in a link.

    Regarding GDM:
    You created the two scripts like explained here: https://wiki.archlinux.org/index.php/NVIDIA_Optimus#GDM , right?

    Yes copy and paste just what is says there.

    Regarding xorg:
    I would love to track down that issue.
    Can you please post me your exact xorg.conf in a pastebin? :D
    Makes it easier for me :D

    Here’s is my working xorg.conf

    Which version of xorg do you use?

    1.19.4-1

    Hope it helps.

    Regards, folgui.

  • @folgui Thanks for the xorg.conf.
    Maybe I’ll try this too.

    After the latest update my system freezes after logging in in KDE while using the Nvidia GPU.
    I switched back to version 1.19.3-3 of xorg-server and xorg-server-common.
    Maybe a bug or a change which makes problems with the current .conf

    EDIT:
    Seems to be a bug of xorg-server and xorg-server-common while using prime and nvidia-drm.modeset=1 to fix tearing.
    Downgrading to 1.19.3-3 fixed the problem.
    https://bugs.archlinux.org/task/55896?project=1&cat[0]=2&string=xorg-server

  • @got-it-man said in AntergosPrime - Brings Optimus/ Prime functionality to Antergos:

    Seems to be a bug of xorg-server and xorg-server-common while using prime and nvidia-drm.modeset=1 to fix tearing.
    Downgrading to 1.19.3-3 fixed the problem.
    https://bugs.archlinux.org/task/55896?project=1&cat[0]=2&string=xorg-server

    Seems like upgrading to xorg-server 1.19.5-1 fixes the bug ;)

  • @folgui Yep, also heard about that :D

  • @karasu said in AntergosPrime - Brings Optimus/ Prime functionality to Antergos:

    https://repo.antergos.info/antergos/x86_64/antergos-prime-0.1-1-any.pkg.tar.xz

    I simply packaged it, didn’t do any tests…

    To install:
    sudo pacman -S antergos-prime

    Cheers!

    Hey @karasu

    I did a complete reinstall and used antergos-prime so I now know exactly which packages are needed.
    Please add:

    • bbswitch
    • nvidia

    I have no idea of antergos packages but can you also the commands sudo systemctl disable lightdm and sudo systemctl enable sddm ?
    Or how @joekamprad recommended:
    sudo systemctl -f enable sddm ?

    I guess than it would work ootb.
    And maybe a message after a succesful installation that the user should switch to both GPUs after the installation once, using the following commands:
    sudo prime-select intel and sudo prime-select nvidia
    Later then the user can change with this command the current GPU and just have to reboot.

    Would be awesome :)
    If you don’t have enough time then just send me a link on how to build packages for antergos ;)

  • @got-it-man @karasu Hi!

    Could we also make this work with linux-lts kernel? Using these packages:

    bbswitch-lts
    nvidia-lts

    If linux-lts is detected in system, then install those packages. If not, don’t install them.

    Regards, folgui.

  • @folgui I guess this should work to.
    Unfortunately I have absolutely no idea of packages of Antergos :D

    Let’s wait for @karasu 's feedback, he is the one who packaged the antergos-prime package :D

  • Hi,

    No problem I’ll do it.

    I can also create an antergos-prime-lts package.

    I’ll get back to you when it’s done.

    Cheers!

  • This is something that I will need to test as well as I have the same setup with the graphic cards.

optimus26 prime8 antergosprime2 brings1 Posts 49Views 9485
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.