• AntergosPrime - Brings Optimus/ Prime functionality to Antergos


    Preface

    As someone who uses Antergos on a laptop with 2 GPUs (Intel and NVIDIA) I pretty much know the current situation. Unfortunately only *buntu-distros bring easy tools for switching between GPUs, so that you can use your Intel GPU for light surfing and switch with a relog or restart to your NVIDIA GPU if you want to game or do something that needs GPU power. There are alternatives like Bumblebee, however they do not suit me due to several reasons. More information on that in the repo: https://github.com/konstantingoretzki/AntergosPrime

    AntergosPrime

    AntergosPrime tries to solve this problem and lets you easily switch GPUs from the terminal with “sudo prime-select intel” and “sudo prime-select nvidia”.

    The script collection branch is a fork of emanuellopes’s archLinuxPrime which got optimized for the Antergos distribution. Emanuellopes forked for his repo the prime application that comes on Linux Mint.

    The main work of this script goes to Emanuellopes and the Linux-Mint-team, I just optimized on some paths, updated package names, added how to fix the tearing for the Nvidia-GPU and put everything well described together, so that even people with less bash skills can (hopefully) easily follow on how to install and use AntergosPrime.

    Status

    Currently this script only works with the display manager SDDM and NOT with Antergos’s default display manager LightDM. However switching is easy, so it should be not a big deal to switch your display manager. The prime-indicator does also not work - currently function goes before accessibility ;)

    Download

    I hope this collection helps others as much as it helped myself.
    You can find it here: https://github.com/konstantingoretzki/AntergosPrime
    Every step on how to use it is there written down. If you have questions: Feel free to ask me!

    Thanks to karasu and Keegan who supported me on my way. I love the Antergos community.

  • Thank you for the excellent work. I have at least one video card, but communicating with our community, I know that the problem was very urgent. Took the news in our russian fan club of Antergos.

    Russian fan club of Antergos

  • @got-it-man

    instead of:

    Disable LightDM

    sudo systemctl disable lightdm
    

    Enable SDDM

    sudo systemctl enable sddm
    

    you can use the force option to get it done in one command:

    sudo systemctl -f enable sddm

    this will remove the symlink to the before enabled one and inserts the one to the new…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • This one should really get on the Antergos Repos! It’s so handy:grinning:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • i vote for it too! As stuff like this will be great to grow the community!

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Thank you very much all!
    I hope that the script collection would be ready for the repos. xD
    First of all some people should try it if it works for them :D

    @joekamprad I’ll change/ add this the next time, thank you very much! :)

  • @got-it-man said in AntergosPrime - Brings Optimus/ Prime functionality to Antergos:

    @joekamprad I’ll change/ add this the next time, thank you very much!

    say thank you to @fernandomaroto he was inviting this “trick” :)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • https://repo.antergos.info/antergos/x86_64/antergos-prime-0.1-1-any.pkg.tar.xz

    I simply packaged it, didn’t do any tests…

    To install:
    sudo pacman -S antergos-prime

    Cheers!

  • @karasu Thank you very much!
    Hope this works for other people as well as it works for me :D

    Now we need people with Hybrid-GPUs to test it :D

  • Hi.

    I’ve bumblebee installed via nvidia-installer. Must i do something before installing/trying antergos-prime or just install and run?

    Thanks in advance.

    Regards, folgui.

  • @folgui Since the installation of bumblebee shouldn’t be that difficult, I would recommend to uninstall it. I myself come from an “use only the NIVIDIA GPU-conf”, so I am not 100% sure what it will be like with your config, but I would simply remove bumblebee. If antergos-prime does not work, then you can easily switch back to bumblebee ;)

    Please tell us if it works for you :)

  • @got-it-man I tried it yesterday without uninstalling bumblebee and without putting the kernel parameter: nvidia-drm.modeset=1. Installed with sudo pacman -S antergos-prime. Runned “sudo prime-select nvidia” and rebooted.
    I got a black screen and tried with Ctrl-Alt-Fx to log through term to recover system but the term windows where flickering and i couldn’t log into the system. I had to do a chroot from another system to uninstall antergos-prime and install bumblebee again to recover it.

    Would try today when i get home, uninstalling bumblebee first and with kernel parameter.

    I’ll tell you the results.

    Thanks.

  • @folgui I recommend to switch to the intel AND the nvidia at least once before rebooting, even if you only want to use GPU XYZ. Otherwise there might be old config files, which won’t get overwritten. More information about this in my repo inside my README: https://github.com/konstantingoretzki/AntergosPrime

    If you have a blackscreen, then you have a wrong config or a package is missing. Please uninstall bumblebee.
    The kernel parameter is only additional and not needed. This is only for fixing the screen tearing while using the Intel GPU. However this needs additional config, more information in my repo.

  • @got-it-man Hi. It doesn’t work for me. This is what I’ve done:

    1. Unstalled bumblebee as explained here: https://antergos.com/wiki/es/hardware/bumblebee-for-nvidia-optimus/#Uninstall_Bumblebee
    2. Rebooted. Accesed gnome-xorg without problems.
    3. Installed bbswitch (sddm is already installed and my default session manager)
    4. Installed prime with sudo pacman -S antergos-prime
    5. sudo prime-select intel (no errors)
    6. sudo prime-select nvidia (no errors)
    7. sudo prime-select intel
    8. Rebooted. Accesed gnome-xorg without problems.
    9. sudo prime-select nvidia
    10. Rebooted. System stops booting before i can see session manager. All terminals accesible with Ctrl+Alt+Fx are blinking and keyboard is not responding, so i can’t access system.
    11. Needed a chroot to unstall antergos-prime and reinstall bumblebee.
    12. Again everything ok.

    Do you need any log or other info.

    My system is an Asus N550JK with integrated intel and nvidia 850M.

    Regards, folgui.

  • @folgui The fact that the keyboard is not responding is very strange. During my tests I also had problems, however I always had the opportunity to switch TTYs. I also can not explain to myself why the conf-files would prevent the keyboard. Normally your DM or X just does not start.

    Can you try to install in manually after my guide and with the files inside my repo?
    Maybe some files got lost during the packaging process.

    Sorry for causing trouble. Normally TTY switch should always work…

    ALSO:
    Please check if you have “xf86-video-nouveau” installed. If so, please remove that. This can cause problems while using “xf86-video-intel” which is needed for the script.

  • @got-it-man said in AntergosPrime - Brings Optimus/ Prime functionality to Antergos:

    Maybe some files got lost during the packaging process.

    Or maybe I didn’t install them to the right place… as I said, I didn’t test it as I do not have an optimus card to test this on.

    Cheers!

    P.S. I’ll add xf86-video-nouveau to the PKGBUILD conflicts list, so if anybody installs antergos-prime, pacman will remove the nouveau driver.

  • @karasu Yeah, no problem. Wasn’t meant as offense ;)

  • @got-it-man The keyboard is working but ttys are flickering so much that it’s impossible to introduce user and password. I’ll try with the files on your repo and tell what happens.

    Regards, folgui.

  • @got-it-man Noveau is not installed. With the files on your repo the result is the same :(

    I’m attaching the xorg.log, it doesn’t look good but i don’t understand it’s content. Seems that there’s not a configured xorg.conf file or something like that. Perhaps running “nvidia-xconfig” to create one? I’ll try later.

    Xorg.log

    Regards, folgui

prime6 optimus25 brings1 antergosprime1 Posts 35Views 1093
Log in to reply