• no wifi after resume from suspend


    Hey guys, I am new to Antergos. I have used Arch before many times on older computers. This one though, I went with Antergos because I didn’t feel like hunting down the drivers for the weird hardware setup on my new one. Wifi and dual graphics is a pain I wish I had gone with the AMD version lol.
    Anyways, this is my problem:
    I am using the ATH10k drivers. Network Manager works fine after resuming from suspend, but I have no wifi. The only solution I have found is to restart the computer. I am using bumblebee and tlp. I figured maybe tlp-rdw was causing a problem so I uninstalled that, but it didn’t help. Bumblebee doesn’t touch the wifi, does it?

    My computer is Alienware 17r3

    I have the killer wireless card, i7-6700hq, intel hd 530, and gtx 970m.

  • Try:
    sudo iwconfig wlan0 power off

    Change “wlan0” to name of wifi card.

  • @schnappi It tells me there is no such device :/ i was supposed to use the logical name, right?

    I did sudo iwconfig wlp60s0 power off
    then i did power on and both times it said no such device

    every time i resume from suspend I have no wifi. Doesn’t matter which distribution I use :/

  • What does ifconfig (or “ip addr” show Debian has depreciated ifconfig) show as name of your wifi device?

  • @schnappi sorry for late reply

    enp59s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
            ether 18:db:f2:39:40:e4  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
            device interrupt 16  
    
    lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
            inet 127.0.0.1  netmask 255.0.0.0
            inet6 ::1  prefixlen 128  scopeid 0x10<host>
            loop  txqueuelen 1000  (Local Loopback)
            RX packets 880  bytes 82431 (82.4 KB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 880  bytes 82431 (82.4 KB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    wlp60s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
            inet 192.168.0.17  netmask 255.255.255.0  broadcast 192.168.0.255
            inet6 fe80::fb34:4e81:fbd0:9bc1  prefixlen 64  scopeid 0x20<link>
            ether 9c:b6:d0:d8:dd:4b  txqueuelen 1000  (Ethernet)
            RX packets 236578  bytes 275513005 (275.5 MB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 97212  bytes 21944894 (21.9 MB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    
  • there is the possibility to handle this by systemd:

    Suspend/resume service files
    Service files can be hooked into suspend.target, hibernate.target and sleep.target to execute actions before or after suspend/hibernate. Separate files should be created for user actions and root/system actions. Enable the [email protected] and [email protected] services to have them started at boot.

    https://wiki.archlinux.org/index.php/Power_management#Suspend.2Fresume_service_files

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Try:
    sudo iwconfig enp59s0 power off

  • @joekamprad thanks i’ll try this, but i have a feeling it might be my drivers since i’m not seeing alot of other people having this problem. and like it happens on fresh installs. doesn’t seem to matter which distribution or kernel i use. i’ve had the hardest time with this wifi card.

    @schnappi that is my ethernet and it didn’t work either. :/

  • yea this resume and suspend services only works if youz find out ow to reanable your wifi card after it fall asleep …
    then you can just automating it with the servicefiles…, but as its ays to put wifi off before suspend will make it easy to enable automatic after resume, it keeps it from getting unresponsable on suspending…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad this is exactly what was happening. thank you, guys!

  • Meant:
    sudo iwconfig wlp60s0 power off

    but you said you already tried and it said no such device.

    Hopefully all fixed now though.

suspend31 resume4 wifi86 Posts 11Views 268
Log in to reply